Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 400957 - portage-utils & gentoolkit utils color of help
Summary: portage-utils & gentoolkit utils color of help
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Lowest trivial (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 346443
  Show dependency tree
 
Reported: 2012-01-26 19:50 UTC by Ilya Gordeev
Modified: 2012-02-29 16:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Gordeev 2012-01-26 19:50:24 UTC
'equery -Ch' output isn't colored, but 'equery -hC' output is colored. It's true for all utils in portage-utils & gentoolkit. May be is't not bug, is't feature :-)

Reproducible: Always
Comment 1 Brian Dolbec gentoo-dev 2012-01-27 09:58:14 UTC
That happens due to printing the help immediately upon finding the -h option parsing the cli options.  At that point it did not parse the remaining options.

Equery, eclean, enalyze, new python version of revdep-rebuild are fixed in commit

http://git.overlays.gentoo.org/gitweb/?p=proj/gentoolkit.git;a=commit;h=10327ce9c7cd0f61c972a48d3c8b2efe470582ef

I did not check any of the non-python based programs.
Comment 2 Paul Varner (RETIRED) gentoo-dev 2012-02-29 16:23:11 UTC
Released in gentoolkit-0.3.0.5