Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 40023 - media-plugins/gimp-gap Gimp Animation Package
Summary: media-plugins/gimp-gap Gimp Animation Package
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: Low enhancement with 3 votes (vote)
Assignee: Default Assignee for New Packages
Whiteboard: sunrise suggested
Keywords: EBUILD
: 50867 (view as bug list)
Depends on:
Blocks: gimp-ext
  Show dependency tree
Reported: 2004-01-31 17:20 UTC by Daniel Haus
Modified: 2020-08-09 11:49 UTC (History)
30 users (show)

See Also:
Package list:
Runtime testing required: ---

gimp-gap-1.3.25.ebuild (gimp-gap-1.3.25.ebuild,493 bytes, text/plain)
2004-01-31 17:21 UTC, Daniel Haus
gimp-gap-2.0_pre1.ebuild (gimp-gap-2.0_pre1.ebuild,505 bytes, text/plain)
2004-03-27 03:42 UTC, Daniel Haus
gimp-gap-2.0_pre1.ebuild (gimp-gap-2.0_pre1.ebuild,564 bytes, text/plain)
2004-03-27 04:52 UTC, Daniel Haus
gimp-gap-2.0_pre1.ebuild (gimp-gap-2.0_pre1.ebuild,749 bytes, text/plain)
2004-04-19 04:16 UTC, Daniel Haus
gimp-gap-2.0.0.ebuild (gimp-gap-2.0.0.ebuild,696 bytes, text/plain)
2004-04-19 05:01 UTC, Daniel Haus
gimp-gap-2.0.2.ebuild (gimp-gap-2.0.2.ebuild,712 bytes, application/octet-stream)
2005-05-27 10:53 UTC, David Holm (RETIRED)
amd64 added to gimp-gap-2.0.2 (gimp-gap-2.0.2-r1.ebuild,767 bytes, text/plain)
2005-08-13 15:09 UTC, Jernej Kranjec
gimp-gap-2.0.2.ebuild (gimp-gap-2.0.2.ebuild,764 bytes, text/plain)
2005-09-07 21:18 UTC, Ed Catmur
gimp-gap-2.0.2.ebuild (gimp-gap-2.0.2.ebuild,956 bytes, text/plain)
2005-09-10 06:20 UTC, Ed Catmur
gimp-gap-2.2.0-ebuild.tar.gz (gimp-gap-2.2.0-ebuild.tar.gz,1.01 KB, application/x-gzip)
2005-11-24 12:14 UTC, Frank Huang
Revised ebuild with libmpeg3 workaround (gimp-gap-2.2.0-r1.ebuild.tar.gz,1.18 KB, application/x-gzip)
2006-01-21 14:14 UTC, Dave Crisp
gimp-gap-2.2.0.ebuild (gimp-gap-2.2.0.ebuild,875 bytes, text/plain)
2006-03-03 11:45 UTC, James Le Cuirot
extern_lib_fix.patch (extern_lib_fix.patch,596 bytes, patch)
2006-03-31 11:18 UTC, James Le Cuirot
Details | Diff
gimp-gap-2.2.1.ebuild (gimp-gap-2.2.1.ebuild,969 bytes, text/plain)
2006-09-10 01:46 UTC, Craig Lawson
gimp-gap emerge error, output and emerge --info attached (gimp-gap.txt,7.56 KB, text/plain)
2006-10-18 08:30 UTC, Guido Sanchez
gimp-gap-2.4.0.ebuild (still far from safe & perfect) (gimp-gap-2.4.0.ebuild,997 bytes, text/plain)
2008-02-13 21:56 UTC, quazgar
Patch for double definition of fucntion gimp_proc_view_new (fix_gap_dbbrowser_utils.patch,6.32 KB, patch)
2009-01-22 14:20 UTC, Franz Glauber Vanderlinde
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Haus 2004-01-31 17:20:42 UTC
Gimp Animation Package
Comment 1 Daniel Haus 2004-01-31 17:21:55 UTC
Created attachment 24709 [details]

save to {portage-overlay}/media-gfx/gimp-gap/gimp-gap-1.3.25.ebuild
Comment 2 Daniel Haus 2004-03-27 03:42:05 UTC
Created attachment 28140 [details]

new version
Comment 3 foser (RETIRED) gentoo-dev 2004-03-27 04:32:01 UTC
ok a few comments :

* we need the default gentoo header stuff
* use mirror:// gimp for SRC_URI
* there is not GPL2 file in /usr/portage/licenses
* src_compile : use econf if possible
* src_install : aren't there any docs to be installed -> README etc.

This probably won't go in before it's upstream stable, but i suppose that won't be too long.

CC-ing latexer, afaik I know he was also working on this package.
Comment 4 Daniel Haus 2004-03-27 04:52:28 UTC
Created attachment 28142 [details]

Ok, thank your for your hints.
I hope this one is better.
Comment 5 Daniel Kirkegaard Mouritsen 2004-04-11 14:09:30 UTC
Hi, I also have a couple of comments :)

according to gap/README(which should also be installed ;]) gimp-gap has the following runtime dependencies:
mpeg_encode and mpeg_decode
mpeg2encode and mpeg2decode
xanim 2.80.1 (loki)

The xanim package needed doesn't seem to be in portage, I've tried emerging xanim-export from portage and setting the GAP_XANIM_PROG enviroment variable to xanim-export. But apperently the version in portage takes its arguments in a different format(Ec# for output type(raw, jpeg etc) and Eq# (jpeg quality)) than the loki version used by GAP(Ee (selects ppm output) and Eq# for jpeg(selects jpeg and sets quality)).

Comment 6 Ed Catmur 2004-04-15 11:04:19 UTC
Has reached 2.0; URI is now
Comment 7 Daniel Haus 2004-04-19 04:16:33 UTC
Created attachment 29603 [details]

Ok, even if it's not quite it, it's at least a bit
better now. I added some dependencies according to
gap/README and it installs now gap/README as README-gap.gz
Obviously i missed something, because "dodoc gap/README"
did not do anything, that's why I made use of "newdoc".
Where should "gap/README" be copied?
Comment 8 Daniel Haus 2004-04-19 05:01:43 UTC
Created attachment 29609 [details]

Upgrade for 2.0.0-release. Still doesn't care about
"xanim 2.80.1 (loki)", requires normal xanim instead.
Comment 9 John Richard Moser 2004-05-04 09:15:00 UTC
2.0.1 is out.  Also, shouldn't this be media-plugins?  It's a plugin pack for gimp.
Comment 10 Daniel Haus 2004-05-04 13:20:19 UTC
Just a matter of renaming:
move (or copy) the existing ebuild to
and you should be fine
Comment 11 foser (RETIRED) gentoo-dev 2004-05-13 09:50:16 UTC
*** Bug 50867 has been marked as a duplicate of this bug. ***
Comment 12 Nicolai Lissner 2004-06-03 02:19:38 UTC
still works fine when renamed to gimp-gap-2.0.2.ebuild
Comment 13 David Holm (RETIRED) gentoo-dev 2005-05-27 10:53:28 UTC
Created attachment 59959 [details]
Comment 14 Aniruddha Shankar 2005-06-28 01:02:37 UTC
works great, should at least be in ~x86 portage
Comment 15 Jernej Kranjec 2005-08-13 15:09:03 UTC
Created attachment 65881 [details]
amd64 added to gimp-gap-2.0.2

Works well on amd64 (x86_64) too, with these modifications (ebuild attached).

I did have to download the source manually from though.
Comment 16 Ed Catmur 2005-09-07 21:18:22 UTC
Created attachment 67888 [details]

fix deprecated consecutive nonnexted use flags
Comment 17 Ciaran McCreesh 2005-09-09 20:21:50 UTC
Please fix the following and reopen:

* !arch? dependencies are illegal.
* emake should not be used for installs.
* Don't install INSTALL or COPYING
* You need an RDEPEND upon gimp.
* Don't use emake for installs.
* ${D} needs quoting.
* Use bzip2 sources over gzip sources where possible.
* Most of those dependencies should be controlled via USE flags.
Comment 18 Ed Catmur 2005-09-10 06:20:16 UTC
Created attachment 68105 [details]

OK, mostly fixed.
I'm not entirely happy about the USE flags (mpeg1? for mpeg-tools rather than
mpeg? because mpeg? is for MPEG-3; wavplay? for audio support as a local USE
flag; sox and mp3 only work if wavplay audio support is compiled in). But it's
a start.
Comment 19 Ciaran McCreesh 2005-09-11 10:03:17 UTC
Comment 20 Frank Huang 2005-11-24 12:14:05 UTC
Created attachment 73517 [details]

gimp-gap-2.2.0-ebuild.tar.gz: GIMP Animation Package 2.2.0 ebuild and small
patch to make it install correctly.
Comment 21 Aniruddha Shankar 2005-12-23 00:21:27 UTC
Connecting to||:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /pub/gimp/plug-ins/v2.2/gap ... done.
==> PASV ... done.    ==> RETR gimp-gap-2.2.0.tar.bz2 ... done.
Length: 4,298,685 (4.1M) (unauthoritative)

100%[====================================>] 4,298,685     17.81K/s    ETA 00:00

08:20:40 (29.34 KB/s) - `/usr/portage/distfiles/gimp-gap-2.2.0.tar.bz2' saved [4                            298685]

!!! Fetched file: gimp-gap-2.2.0.tar.bz2 VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
Removing corrupt distfile...
!!! Couldn't download gimp-gap-2.2.0.tar.bz2. Aborting.

!!! Fetch for /usr/local/portage/media-plugins/gimp-gap/gimp-gap-2.2.0.ebuild fa                            iled, continuing...
Comment 22 Aniruddha Shankar 2005-12-23 02:01:52 UTC
My apologies, there was a download problem - ignore the above comment. 

I got it to start compiling but I get a compilation error:

i686-pc-linux-gnu-gcc -shared -o utils.o cutils.o os_support.o allformats.o mpeg.o mpegts.o mpegtsenc.o ffm.o crc.o img.o img2.o raw.o rm.o avienc.o avidec.o wav.o swf.o au.o gif.o mov.o mpjpeg.o dv.o yuv4mpeg.o 4xm.o flvenc.o flvdec.o movenc.o psxstr.o idroq.o ipmovie.o nut.o wc3movie.o mp3.o westwood.o segafilm.o idcin.o flic.o sierravmd.o matroska.o sol.o electronicarts.o nsvdec.o asf.o asf-enc.o  pnm.o yuv.o png.o jpeg.o gifdec.o sgi.o avio.o aviobuf.o file.o  framehook.o  grab.o dv1394.o audio.o  udp.o tcp.o http.o rtsp.o rtp.o rtpproto.o  -lavcodec -L../libavcodec -lm -lz -ldl
rm -f libavformat.a
ar rc libavformat.a utils.o cutils.o os_support.o allformats.o mpeg.o mpegts.o mpegtsenc.o ffm.o crc.o img.o img2.o raw.o rm.o avienc.o avidec.o wav.o swf.o au.o gif.o mov.o mpjpeg.o dv.o yuv4mpeg.o 4xm.o flvenc.o flvdec.o movenc.o psxstr.o idroq.o ipmovie.o nut.o wc3movie.o mp3.o westwood.o segafilm.o idcin.o flic.o sierravmd.o matroska.o sol.o electronicarts.o nsvdec.o asf.o asf-enc.o  pnm.o yuv.o png.o jpeg.o gifdec.o sgi.o avio.o aviobuf.o file.o  framehook.o  grab.o dv1394.o audio.o  udp.o tcp.o http.o rtsp.o rtp.o rtpproto.o 
ranlib libavformat.a
make[4]: Leaving directory `/var/tmp/portage/gimp-gap-2.2.0/work/gimp-gap-2.2.0/extern_libs/ffmpeg/libavformat'
make[3]: Leaving directory `/var/tmp/portage/gimp-gap-2.2.0/work/gimp-gap-2.2.0/extern_libs/ffmpeg'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../../../i686-pc-linux-gnu/bin/ld: warning: creating a DT_TEXTREL in object.
make[4]: Leaving directory `/var/tmp/portage/gimp-gap-2.2.0/work/gimp-gap-2.2.0/extern_libs/ffmpeg/libavformat'
make[3]: Leaving directory `/var/tmp/portage/gimp-gap-2.2.0/work/gimp-gap-2.2.0/extern_libs/ffmpeg'
make[2]: Leaving directory `/var/tmp/portage/gimp-gap-2.2.0/work/gimp-gap-2.2.0/extern_libs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gimp-gap-2.2.0/work/gimp-gap-2.2.0'
make: *** [all] Error 2

Portage (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.14-gentoo-r4 i686)
System uname: 2.6.14-gentoo-r4 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.6.13
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=pentium3 -O2 -pipe -mmmx -msse -mfpmath=sse"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/              share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O2 -pipe -mmmx -msse -mfpmath=sse"
FEATURES="autoconfig buildpkg ccache distlocks sandbox sfperms strict userpriv usersandbox"
USE="x86 7zip X aalib acl acpi alsa amarok apache2 apm asf atm audiofile avi bash-completion bashlogger berkdb bitmap-fon              ts bzip2 cairo canvas ccache cdparanoia cdr cgi cli cpdflib cpudetection crypt cups curl dba dbus dga dhcp dnd dpms dri d              v dvd dvdr dvdread edl effects encode exif expat fam ffmpeg fftw firefox flac flash fltk font-server foomaticdb fortran f              px ftp gdbm gif gimp gimpprint gkrellm glitz glut gmp gnome gphoto2 gpm gs gstreamer gtk gtk2 gtkhtml gvim gzip hal hddte              mp i8x0 id3 idn imagemagick imap imlib imlib2 inkjar jack jack-tmpfs java javascript jbig jpeg kde kdeenablefinal kdexdel              tas lcms libcaca libclamav libg++ libwww lm_sensors lua lzo mad mailbox maildir mbox mhash mime ming mmx mng motif mozill              a moznoirc moznomail mozsvg mp3 mpeg mpeg2 mpeg4 mpi mplayer msn msnextras mysql nas ncurses nethack network new-login nf              s nls nptl nsplugin ogg oggvorbis openal openexr opengl oss pam pango pcre pdf pdflib perl php pic png posix postfix ppds               python qt quicktime readline real recode rtc samba scanner sdl session silc slp smp snmp soap sockets sox speex spell ss              e sse2 ssl svg symlink tcltk tcpd tga theora tiff toolbar truetype truetype-fonts type1-fonts udev underscores unicode us              b userlocales utf8 v4l v4l2 vim-with-x vorbis webdav wma wmf wxwindows x11vnc xml2 xmms xosd xpm xprint xscreensaver xv x              vid zeroconf zlib video_cards_i810 linguas_hi userland_GNU kernel_linux elibc_glibc"
Comment 23 Aniruddha Shankar 2006-01-16 03:26:21 UTC
can someone check if they can still compile and run gimp-gap ? 
Comment 24 Dave Crisp 2006-01-21 14:11:52 UTC
(In reply to comment #23)
> can someone check if they can still compile and run gimp-gap ? 

I had the same error as you. The solution seems to be to add --disable-libmpeg3 to the configure flags in src_compile(). This causes configure to emit a warning about its absence, but it's okay because the MPEG support in the bundled version of ffmpeg is more than adequate.

I'll upload an -r1 ebuild with this change applied, see if it works for you.
Comment 25 Dave Crisp 2006-01-21 14:14:38 UTC
Created attachment 77764 [details]
Revised ebuild with libmpeg3 workaround
Comment 26 James Le Cuirot gentoo-dev 2006-03-03 11:45:58 UTC
Created attachment 81227 [details]

I think the devs prefer it if you don't tar up the attachments.

I tried to get it to compile with libmpeg3 (internally and externally with 1.6) but it just would not work so I gave up. I also tried to apply the system ffmpeg's build flags to the bundled version but that just created problems.

wavplay isn't actually required to build, even if you want audio support. It's only a small package so I'm not sure if its worth having a USE flag for either.

mplayer is another optional application so I've added that.

Let's get this moving, it's taken long enough!
Comment 27 Toralf Goaltenner 2006-03-31 09:51:35 UTC
(In reply to comment #26)
> Created an attachment (id=81227) [edit]
> gimp-gap-2.2.0.ebuild
sorry guys but I'm unable to install gimp-gap.
It proclaims a missing:
I couldn't find it, even stop goggling and start searching doesn't help.
Also, I couldn't extract the attachments above mentioned :-(
Comment 28 James Le Cuirot gentoo-dev 2006-03-31 11:18:18 UTC
Created attachment 83535 [details, diff]

Good point. It's in the attached tarball but it should be uploaded directly. Here it is.
Comment 29 UB 2006-05-03 05:59:03 UTC
I've tried the latest ebuild and patch and while it compiles and install fine, I am unable to extract any video frames with it. It creates the audio file but does not give me the captured frame(s). It also will not seek with any video. I can play it in the preview window but if I try to seek it jumps to the end and claims a length of 1 frame. Here's what I have been trying:
Open the plugin under "Extract Video Range"
Select the video file (an mpeg 1) and click on video range.
Play (since I cant seek) until I find the frame I want.
Click the "Frame" button and the information appears in the screen on the left.
Click OK.
The wav file for the audio appears, none of the captured frames appear.

Anyone else having this problem or have a fix?
Comment 30 Craig Lawson 2006-09-10 01:46:15 UTC
Created attachment 96564 [details]

ebuild for gimp-gap-2.2.1.

This ebuild extends the 2.2.0 ebuild by copying the howto and reference texts to the doc directory. You need extern_lib_fix.patch for this one, too.

The gimp-gap-2.2.1 release notes say it's been tested against gimp 2.2.11. I have 2.2.8, and it seems to work, though I haven't tested thoroughly.

Thanks to the effort on the 2.2.0 ebuild, this one was incredibly easy.
Comment 31 Guido Sanchez 2006-10-18 08:30:01 UTC
Created attachment 99944 [details]
gimp-gap emerge error, output and emerge --info attached
Comment 32 Matteo 'The Peach' Pescarin 2007-06-11 11:05:54 UTC
seems like the master_video_encoder can't find any encoder to work with
can anyone modify the ebuild and add ffmpeg to RDEPEND and make GAP work with it?
contact me if you're working on it, I can provide support if you want.
Comment 33 Oliver Knodel 2007-11-04 19:58:19 UTC
For information. renaming the ebuild to gimp-gap-2.2.2.ebuild is working in conjunction with gimp (~)2.4.1. 
Comment 34 quazgar 2008-02-13 19:55:01 UTC
(In reply to comment #33)
> For information. renaming the ebuild to gimp-gap-2.2.2.ebuild is working in
> conjunction with gimp (~)2.4.1. 

renaming the ebuild itself won't be enough, but replacing all occurrences of 2.2 with 2.4 inside the ebuild might make it work with the right version (2.4.0 at the moment, btw).  Those are the path on the gimp ftp server and the dependency on the correct gimp version.
Comment 35 quazgar 2008-02-13 21:52:12 UTC
(In reply to comment #31)

I have a very similar error as Guido here (also on amd64), which looks like a case of

Find attached a modified ebuild that checks for the wavplay USE flag (which existed before already but was never used), as suggested in #31.

Another nasty workaround is in line 27:

CFLAGS="-fPIC" econf --disable-libmpeg3 || die "econf failed"

a) that is really ugly, I'm afraid 
b) at the moment that additional CFLAG is set for all archs, which is plain wrong, so please don't leave that line as it is if you're not on an AMD64 architecture.

I have totally no experience with ebuilds, so any help and/or hint to fix this would be very much appreciated.

On the plus side, this ebuild made gimp-gap compile and at least be added to GIMP's menu.
Comment 36 quazgar 2008-02-13 21:56:11 UTC
Created attachment 143450 [details]
gimp-gap-2.4.0.ebuild (still far from safe & perfect)

Other platforms than amd64 should remove the CFLAGS="-fPIC" in line 27.  Should still be improved.
Comment 38 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2008-12-29 18:53:26 UTC
(this is an automated message based on filtering criteria that matched this bug)

Hello, The Gentoo Team would like to firstly thank you for your ebuild
submission. We also apologize for not being able to accomendate you on a timely
manor. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The sunrise
overlay[1] is a overlay for Gentoo which we allow trusted users to commit to and
all users can have ebuilds reviewed by Gentoo devs for entry into the overlay.
So, the sunrise team is suggesting that you look into this and submit your
ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. We
anticipate a large number of requests in a short time. 

On behalf of the Gentoo Sunrise Team,

Comment 39 Franz Glauber Vanderlinde 2009-01-22 14:20:55 UTC
Created attachment 179338 [details, diff]
Patch for double definition of fucntion gimp_proc_view_new

I had problems compiling the 2.4 version using gimp-2.6.2

The patch simply removes the whole definition of function gimp_proc_view_new since it is already defined in the gimp's library, or sort of.

With the patch, it compiled fine and seems to be working (just clicked on some of the action on the video menu and they all appear to be normal, can't really say if there would be runtime bugs related)
Comment 40 Franz Glauber Vanderlinde 2009-01-22 14:23:33 UTC
Comment on attachment 179338 [details, diff]
Patch for double definition of fucntion gimp_proc_view_new

filename was wrong...
Comment 41 quazgar 2009-03-11 18:47:50 UTC
The amd54 -fPIC problem seems to be solved upstream in svn now.  See also
Comment 42 Andreas G 2009-06-06 14:33:32 UTC
there is a new version online, gimp-gap-2.6

I tried to compile it with the old ebuild, but it failed with:

QA Notice: Package has poor programming practices which may compile
 *            but will almost certainly crash on 64bit architectures.
 * Function `gap_fmac_get_alternate_name' implicitly converted to pointer at gap_story_properties.c:3340
 * Function `p_gtk_button_new_from_stock_icon' implicitly converted to pointer at gap_story_section_properties.c:869
 * Function `g_fopen' implicitly converted to pointer at gap_gve_misc_util.c:358
 * Function `gap_file_make_abspath_filename' implicitly converted to pointer at gap_enc_ffmpeg_main.c:1558
 *  Please file a bug about this at
 *  with the maintaining herd of the package.
 * ERROR: media-gfx/gimp-gap-2.6.0 failed.
 * Call stack:
 *, line 729:  Called install_qa_check
 *, line 421:  Called die
 * The specific snippet of code:
 *   				die "install aborted due to" \
 *  The die message:
 *   install aborted due to poor programming practices shown above
Comment 43 lalebarde 2011-09-09 09:36:32 UTC
2.6.0 in ibormuth overlay fails due to :

# emerge -av media-gfx/gimp-gap

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "media-gfx/gimp-gap" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-gfx/gimp-gap-2.6.0::ibormuth (masked by: invalid: RDEPEND: USE flag 'mplayer' referenced in conditional 'mplayer?' is not in IUSE)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

thought it is unmasked in /etc/portage/package.keywords

After having suppressed the mplayer line in the ebuild, it starts emerging. Then I have an error, but this is another story.....