Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 39981 - media-video/mgavideo-0.1.1b with i2c-2.8 support
Summary: media-video/mgavideo-0.1.1b with i2c-2.8 support
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 40664 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-01-31 08:01 UTC by Jules Gagnon
Modified: 2005-05-02 04:26 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for mgavideo-0.1.1b which allow compiling with i2c-2.8 (mod_marvel-i2c-2.8.0.patch,2.29 KB, patch)
2004-01-31 08:10 UTC, Jules Gagnon
Details | Diff
ebuild for mgavideo-0.1.1b with patch for i2c (mgavideo-0.1.1b.ebuild,1.77 KB, text/plain)
2004-01-31 08:18 UTC, Jules Gagnon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jules Gagnon 2004-01-31 08:01:46 UTC
The new i2c api used by i2c-2.8.x is not supported by mgavideo-0.1.0

Reproducible: Always
Steps to Reproduce:
1. emerge i2c or a kernel with i2c-2.8
2. emerge mgavideo
3.

Actual Results:  
mgavideo is not able to compile mgai2c and stop. The package is merge anyway but
many modules are missing.

gcc -I. -I/usr/src/linux/include -O2 -Wall -DMODULE -D__KERNEL__ -DEXPORT_SYMTAB
-I/usr/src/linux/drivers/media/video -include
/usr/src/linux/include/linux/modversions.h -DMODVERSIONS -Wstrict-prototypes
-Wno-trigraphs -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe
-mpreferred-stack-boundary=2 -c mgai2c.c
mgai2c.c:298: warning: initialization from incompatible pointer type
mgai2c.c:299: warning: missing braces around initializer
mgai2c.c:299: warning: (near initialization for `mga_i2c_adap_tmpl.name')
mgai2c.c:300: warning: initialization makes integer from pointer without a cast
mgai2c.c:301: warning: initialization makes integer from pointer without a cast
mgai2c.c:302: warning: initialization makes integer from pointer without a cast
mgai2c.c:302: initializer element is not computable at load time
mgai2c.c:302: (near initialization for `mga_i2c_adap_tmpl.name[3]')
mgai2c.c:303: warning: initialization makes integer from pointer without a cast
mgai2c.c:303: initializer element is not computable at load time
mgai2c.c:303: (near initialization for `mga_i2c_adap_tmpl.name[4]')
mgai2c.c:304: warning: initialization makes integer from pointer without a cast
mgai2c.c:304: initializer element is not computable at load time
mgai2c.c:304: (near initialization for `mga_i2c_adap_tmpl.name[5]')
mgai2c.c:305: warning: initialization makes integer from pointer without a cast
mgai2c.c:305: initializer element is not computable at load time
mgai2c.c:305: (near initialization for `mga_i2c_adap_tmpl.name[6]')
mgai2c.c:306: initializer element is not constant
mgai2c.c:306: (near initialization for `mga_i2c_adap_tmpl.name')
make: *** [mgai2c.o] Error 1


Expected Results:  
There should be a patch to allow compiling with i2c-2.8

Portage 2.0.49-r20 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r9, 2.4.22-gentoo-r5)
=================================================================
System uname: 2.4.22-gentoo-r5 i686 Pentium III (Coppermine)
Gentoo Base System version 1.4.3.10p1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium3 -O3 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/share/config /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://adelie.polymtl.ca/
http://mirror.clarkson.edu/pub/distributions/gentoo/
http://csociety-ftp.ecn.purdue.edu/pub/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.ca.gentoo.org/gentoo-portage"
USE="X aalib acpi alsa avi berkdb bonobo cdr crypt dga dvd encode esd evo fam
foomaticdb gdbm geoip gnome gpm gstreamer gtk gtk2 gtkhtml java jpeg libwww lirc
mad maildir matrox mmx mozilla mpeg mysql ncurses nls ofx oggvorbis opengl oss
pam pdflib perl pic png python readline slang spell sse ssl tcltk tcpd tetex
tiff transcode truetype unicode usb x86 xml xml2 xmms xv zlib linguas_fr"
Comment 1 Jules Gagnon 2004-01-31 08:10:32 UTC
Created attachment 24694 [details, diff]
patch for mgavideo-0.1.1b which allow compiling with i2c-2.8

I didn't find a patch for mgavideo-0.1.0 but i found this one in
kernel-multimedia-source-2.4.22-21mm.1mdk.i586.rpm for mgavideo-0.1.1b
Comment 2 Jules Gagnon 2004-01-31 08:18:48 UTC
Created attachment 24697 [details]
ebuild for mgavideo-0.1.1b with patch for i2c

I copied the ebuild for mgavideo-0.1.0, added the patch for i2c and removed
tuner.o which is no longer included.

I suggest to use mgavideo-0.1.1b. I have used it for more than 6 months without
problems. It is out since 2002-11-29 and no stable version have been released
since then.
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2004-02-18 02:04:47 UTC
Bryan can you handle this?
Comment 4 Joel Martin (RETIRED) gentoo-dev 2004-03-15 08:17:06 UTC
*** Bug 40664 has been marked as a duplicate of this bug. ***
Comment 5 Joel Martin (RETIRED) gentoo-dev 2004-03-15 08:21:13 UTC
changed summary to more accurately reflect that this is no longer just a i2c
problem, but a new version of mgavideo.

Previous summary: "media-video/mgavideo-0.1.0 doesn't compile with i2c-2.8"
Comment 6 Jules Gagnon 2005-04-28 07:21:50 UTC
I don't what is the policy with that but I think mgavideo could be removed from portage. It's no longer maintened and it applicable only to 2.4 kernels.

The 2.6 driver is available on CVS at https://sourceforge.net/cvs/?group_id=1764, it's called driver_fb but it need a kernel patch so it's not easily packagable for gentoo.

Personnaly, I no longer use my matrox card for capture and I use a 2.6 kernel so I can't easily provide more help on this.
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-05-02 04:26:57 UTC
As for latest comment, changing this as WONTFIX as it's ot going to be fixed for now. If someone wants to step in and maintain it, it's wellcome.