Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 3985 - updating of xmms and mysql fails; probably conflict with libdvdnav
Summary: updating of xmms and mysql fails; probably conflict with libdvdnav
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: Normal minor (vote)
Assignee: Martin Schlemmer (RETIRED)
Depends on:
Reported: 2002-06-21 10:40 UTC by Johannes Krause
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Krause 2002-06-21 10:40:53 UTC
'emerge xmms' tries to update to xmms-1.2.7-r8, fails:  
 ------- cut ------  
 cd . && aclocal  
 aclocal: /usr/share/aclocal/dvdnav.m4: 29: duplicated macro `AM_PATH_DVDNAV'  
 make: *** [aclocal.m4] Fehler 1  
 !!! ERROR: The ebuild did not complete successfully.  
 !!! Function src_compile, Line 93, Exitcode 2  
 !!! (no error message)   
 ------- cut ------  
'emerge mysql' tries to update to mysql-3.23.49-r2, fails:  
 ------- cut ------  
 patching file mysys/default.c  
 aclocal: /usr/share/aclocal/dvdnav.m4: 29: duplicated macro `AM_PATH_DVDNAV'  
 !!! ERROR: The ebuild did not complete successfully.  
 !!! Function src_unpack, Line -55, Exitcode 1  
 !!! (no error message)   
 ------- cut ------  
The conflicting file seems to be '/usr/share/aclocal/dvdnav.m4', which is part  
of 'media-libs/libdvdnav-0.1.1'.
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2002-06-21 12:57:09 UTC
Az, I can verify this. I solved it on my box by actually removing that dvdnav.m4
file, but there is sure a cleaner way?
Comment 2 Martin Schlemmer (RETIRED) gentoo-dev 2002-06-21 15:03:18 UTC
With which .m4 does /usr/share/aclocal/dvdnav.m4 conflict ?
Comment 3 Johannes Krause 2002-06-21 15:48:10 UTC
another one: media-libs/aalib-1.4_rc4-r2, same error.    
After moving /usr/share/aclocal/dvdnav.m4 away all updates complete 
'locate .m4 | xargs grep AM_PATH_DVDNAV' shows 2 files: 
/usr/share/aclocal/dvdnav.m4		(part of media-libs/libdvdnav-0.1.0) 
/usr/share/aclocal-1.4/dvdnav.m4	(part of media-libs/libdvdnav-0.1.1) 
Diff shows no difference between the 2 files. 
I am no programmer, maybe the double-existance of this file is the reason of 
the error. 
'emerge clean' does not remove the old version of libdvdnav. 
Comment 4 Martin Schlemmer (RETIRED) gentoo-dev 2002-06-21 16:56:35 UTC
Its a problem with automake itself ... "aclocal --print-ac-dir" should not
print the version specific dir, but rather just "/usr/share/aclocal".  This
is true for aclocal-1.4 and aclocal-1.5 ... aclocal-1.6 works fine though.
Comment 5 Martin Schlemmer (RETIRED) gentoo-dev 2002-06-21 17:10:12 UTC
Ok, automake-1.6.1-r5 should fix this.  You will have to remerge affected
packages though :(