Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 397971 - dev-python/pygobject-3.0.2 fails tests
Summary: dev-python/pygobject-3.0.2 fails tests
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2012-01-07 07:44 UTC by Paweł Hajdan, Jr. (RETIRED)
Modified: 2012-01-30 11:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (dev-python:pygobject-3.0.2:20120106-221223.log.gz,32.32 KB, application/x-gzip)
2012-01-07 07:44 UTC, Paweł Hajdan, Jr. (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-01-07 07:44:53 UTC
Created attachment 298163 [details]
build.log.gz

testExtractUris (test_uris.TestUris) ... ok

======================================================================
ERROR: testRange (test_properties.TestProperties)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/tmp/portage/dev-python/pygobject-3.0.2/work/pygobject-3.0.2-3.1/tests/test_properties.py", line 245, in testRange
    obj.set_property(key, max)
TypeError: could not convert argument to correct param type

----------------------------------------------------------------------
Ran 90 tests in 0.752s

FAILED (errors=1)
make[2]: *** [check-local] Error 1

Portage 2.1.10.41 (default/linux/x86/10.0/developer, gcc-4.5.3, glibc-2.13-r4, 3.0.6-gentoo i686)
=================================================================
System uname: Linux-3.0.6-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_P8700_@_2.53GHz-with-gentoo-2.0.3
Timestamp of tree: Fri, 06 Jan 2012 18:00:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect compress-build-logs distlocks ebuild-locks fixlafiles multilib-strict news parallel-fetch protect-owned sandbox sfperms sign splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus device-mapper dri dts dvd dvdr emacs emboss encode exif fam firefox flac fortran gdbm gdu gif git gnome-keyring gnutls gtk iconv icu jpeg lcms libkms libnotify mad mbox mercurial mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nss objc ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline sdl secure-delete session snmp spell sqlite ssl startup-notification subversion svg sysfs tcb tcpd threads tiff toolkit-scroll-bars truetype udev unicode usb vorbis x264 x86 xcb xft xinerama xml xorg xulrunner xv xvfb xvid zlib" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vmware vesa vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-01-07 13:28:33 UTC
Cannot reproduce on amd64.

What versions of glib, gobject-introspection, and gvfs are you using?
Comment 2 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-01-07 20:00:08 UTC
(In reply to comment #1)
> Cannot reproduce on amd64.

I got this during testing for bug #393007, so I had several unstable packages installed.

> What versions of glib, gobject-introspection, and gvfs are you using?

dev-libs/glib-2.30.2
dev-libs/gobject-introspection-1.30.0-r1
gnome-base/gvfs-1.6.7-r1 (this one was from stable, and unstable gnome-base/gvfs-1.10.1 has been emerged _after_ pygobject, i.e. after this failure).
Comment 3 Pacho Ramos gentoo-dev 2012-01-07 20:50:26 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Cannot reproduce on amd64.
> 
> I got this during testing for bug #393007, so I had several unstable packages
> installed.
> 
> > What versions of glib, gobject-introspection, and gvfs are you using?
> 
> dev-libs/glib-2.30.2
> dev-libs/gobject-introspection-1.30.0-r1
> gnome-base/gvfs-1.6.7-r1 (this one was from stable, and unstable
> gnome-base/gvfs-1.10.1 has been emerged _after_ pygobject, i.e. after this
> failure).

Does it still fail with gvfs-1.10.1
Comment 4 Pacho Ramos gentoo-dev 2012-01-08 19:15:32 UTC
Can any other x86 team member check if tests also fail for him? (I am now only able to test on amd64) Thanks
Comment 5 Pacho Ramos gentoo-dev 2012-01-11 11:54:40 UTC
(In reply to comment #4)
> Can any other x86 team member check if tests also fail for him? (I am now only
> able to test on amd64) Thanks

x86? Thanks :)
Comment 6 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2012-01-11 14:10:53 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Can any other x86 team member check if tests also fail for him? (I am now only
> > able to test on amd64) Thanks
> 
> x86? Thanks :)

all tests is ok on my x86. Indeed.
Comment 7 Pacho Ramos gentoo-dev 2012-01-11 18:48:02 UTC
Unblocking then :)

The problem is that I don't know what is occurring in Pawel's setup :(, have you tried to manually compile and run tests? (outside portage)
Comment 8 Pacho Ramos gentoo-dev 2012-01-30 11:18:30 UTC
(In reply to comment #7)
> Unblocking then :)
> 
> The problem is that I don't know what is occurring in Pawel's setup :(, have
> you tried to manually compile and run tests? (outside portage)