Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 397467 - app-admin/sysklogd: use of deprecated variable "opts" in init.d script
Summary: app-admin/sysklogd: use of deprecated variable "opts" in init.d script
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: init.d-depr-opts
  Show dependency tree
 
Reported: 2012-01-03 07:16 UTC by Carlo Marcelo Arenas Belon
Modified: 2013-01-24 19:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlo Marcelo Arenas Belon 2012-01-03 07:16:34 UTC
as shown at startup with the following warning :

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * sysklogd -> start: syslogd ...                                         [ ok ]
 * sysklogd -> start: klogd ...                                           [ ok ]

the problem was introduced by the new stable version of openrc (0.9.4)

Reproducible: Always




the following removes the warning at least, and could be used to get rid of this warning until the script is ported :

  sed -e "s/opts/extra_started_commands/g"

it will report the following warning though when called with reload :

  # /etc/init.d/sysklogd reload
   * Reloading configuration ...
   * WARNING: -o/--oknodo is deprecated and will be removed in the future
   * WARNING: -o/--oknodo is deprecated and will be removed in the future   [ ok ]
Comment 1 Carlo Marcelo Arenas Belon 2012-01-03 07:42:03 UTC
fixed in unstable (~amd64 at least) by BUG379515, and which was being tracked by BUG377843 probably to prevent that this would spill into stable as it did.
Comment 2 Jeroen Roovers gentoo-dev 2012-01-03 10:15:16 UTC
*sysklogd-1.5-r2 (14 Sep 2011)

  14 Sep 2011; Lars Wendler <polynomial-c@gentoo.org> +sysklogd-1.5-r2.ebuild,
  +files/sysklogd.rc7:
  non-maintainer commit: Removed deprecated --oknodo option (bug #379515).
  Replaced deprecated opts variable and removed --stop option from reload
  function. All done with kind permission from vapier.
Comment 3 Carlo Marcelo Arenas Belon 2012-01-05 07:20:53 UTC
fixed in unstable (~amd64, ~x86, ..) and which has other problems if keyword enabled in a stable system, but still not fixed for stable which is still using sysklogd-1.4.2 and a pre openrc init.

as pointed out though, using the newer init (sysklogd.rc7) with the old stable ebuild might be all that is needed to resolve this bug.
Comment 4 Roman Žilka 2013-01-24 19:26:59 UTC
I hope support for the deprecated 'opts' variable isn't going to be removed anytime soon. Is it still unsafe for us to unmask a later sysklogd package (wrt comment #3)?