Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 395385 - x11-drivers/nvidia-drivers-{96.43.20.173.14.31} does not work with the >x11-base/xorg-server-1.11 ABI
Summary: x11-drivers/nvidia-drivers-{96.43.20.173.14.31} does not work with the >x11-b...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Doug Goldstein
URL: http://www.nvnews.net/vbulletin/showt...
Whiteboard:
Keywords:
Depends on: 403941
Blocks: 394393
  Show dependency tree
 
Reported: 2011-12-20 18:33 UTC by Jeroen Roovers
Modified: 2012-03-23 15:38 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2011-12-20 18:33:22 UTC
I guess the same will prove true for 96.43.20. I tried running with -ignoreABI, but that only made the server segfault, so the workaround for now is to block the 1.11 upgrade using something like:

echo >x11-base/xorg-server-1.11 >> /etc/portage/package.mask/nvidia-drivers
Comment 1 Jeroen Roovers gentoo-dev 2011-12-20 18:33:43 UTC
I'm not even sure it should block the stabilisation bug.
Comment 2 Jeroen Roovers gentoo-dev 2011-12-20 18:37:30 UTC
Oh, I should, I guess, since the Whiteboard on the blocked bug says:

   if you find regression please DON'T COMMENT HERE, instead 
   file a new bug and make it block this bug

yay
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2011-12-20 22:12:09 UTC
I guess similar to bug 375215, NVidia will take more time to update legacy drivers.

If I understand correctly, no package.mask is necessary, as the <x11-base/xorg-server-1.11 dependency will make 96.* and 173.* users skip the xorg-server upgrade.

If package.mask is preferred, http://www.gentoo.org/doc/en/nvidia-guide.xml could tell users to additionally mask >=x11-base/xorg-server-1.11 for the legacy drivers.
Comment 4 Doug Goldstein gentoo-dev 2012-03-23 15:38:49 UTC
The depends present are correct to make users skip the xorg-server update.