Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 395137 - dev-lang/ruby failed to compile
Summary: dev-lang/ruby failed to compile
Status: RESOLVED DUPLICATE of bug 370413
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-18 11:49 UTC by Leonid Kopylov
Modified: 2011-12-18 12:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,33.11 KB, text/plain)
2011-12-18 11:50 UTC, Leonid Kopylov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Kopylov 2011-12-18 11:49:16 UTC
dev-lang/ruby failed to compile

Reproducible: Always

Steps to Reproduce:
emerge ruby
Actual Results:  
dev-lang/ruby failed to complile

Expected Results:  
successful compile

# emerge -pqv =dev-lang/ruby-1.8.7_p352
[ebuild  N    ] dev-lang/ruby-1.8.7_p352  USE="berkdb doc examples gdbm ncurses readline socks5 ssl threads tk xemacs -debug -ipv6 -libedit -rubytests"

# emerge --info =dev-lang/ruby-1.8.7_p352
Portage 2.1.10.41 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r1, 3.1.5-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.1.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Sun, 18 Dec 2011 10:15:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.7
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.10.3, 1.11.1-r1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1 Nero-EULA-US skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.isoc.org.il/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en he ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X X509 Xaw3d a52 aac aalib acl acpi aim all_sfx alsa amd64 amr apache2 apm apng applet archive aspell assistant audio audit auth auto-completion autoipd automount avahi bash-completion bcmath berkdb bidi bind bittorrent bluetooth bookmarks branding bzip2 cache cairo cal calendar caps ccache cdb cdda cddb cdparanoia cdr cdrom cdsound cgi classic cli clisp color colord common-lisp consolekit contactnotes cpudetection cracklib crashreporter crypt cscope css ctype cuda cups curl curlwrappers cursors cxx cyrillic daemon dbus declarative device-mapper dga dhcp dirac directfb discouraged disk-partition djvu doc downloadorder dri dts dvb dvd dvdr eap-tls editor eds elisp emacs emboss emerald enca enchant encode evo examples excel exif experimental extra extras fam fax fbcon ffmpeg fileinfo filter finger firefox flac flash fontconfig fontforge fortran fpm ftp fuse gadu gallium games gcj gcrypt gd gdbm gdm gdu gecko geoip ggi gif glibc-omitfp gmail gme gmp gnome gnome-keyring gnome-online-accounts gnutls google gopher gpm grammar graphics graphite grub gsm gstreamer gtk gtk3 gui guile hacking handbook hddtemp hesiod highlight histman history howl-compat hpijs hpn http httpd hunspell icons iconv icq icu id3 id3tag idn ieee1394 imap imlib inifile intl iodbc ios ios-vout irc irda jabber jack jadetex java javascript jingle jpeg kate kde kdm kerberos kolab kontact kpathsea lame lcms ldap ldap-bind libass libcaca libnotify libproxy libtiger libv4l2 live llvm lm_sensors lock logrotate lua luatex lxde mad mailwrapper map math mbox mdnsresponder-compat minizip mixer mms mmx mng modplug modules mouse mozilla mp3 mp4 mpeg mplayer mrim msn mssql mtp mudflap multilib multimedia multiuser musepack music mysql mysqli mysqlnd nas natspec nautilus ncurses neXt net nethack netlink network network-cron networking networkmanager nfs nfsidmap nfsv3 nfsv4 nis nls nntp nokia nowlistening nptl nptlonly nsplugin nspluginwrapper ntp nvidia objc objc++ objc-gc odbc odbcmanual odk offensive ogg opengl openid openldap openmp oscar otr overlays pam pango pcntl pcre pdf pdo perl phonon php pidgin pkcs11 plasma plotutils plugins png policykit pop posix postfix postgres ppds ppp pppd prediction procmail projectm proxy publishers pulseaudio python qemu qt3support qt4 quota radio rar readline recode remote remote-access remoteosd reports rpm rss rtsp samba sample samples sasl scanfolder scanner science sdl sdl-image semantic semantic-desktop sendmail sensord session sharedext simplexml sip skins skype slang slp smbclient smbkrb5passwd smi smp sms smtp snmp soap socialweb sockets socks socks5 solver sound soup source spamassassin speech speex spell spoof spoof-source sql sqlite sse sse2 ssh ssl ssse3 startup-notification statistics stats stream sudo suhosin svg swat swig symlink sysfs syslog sysvipc taglib tcl tcpd teletext theora thread threads thumbnail thunar thunderbird tidy tiff tk toolbar tools truetype tv tvtime twolame udev udisks unicode unsupported upnp upower usb utils v4l2 vaapi vcd vcdx video vim vim-pager vim-syntax vix vkontakte vlc vlm vmware-tools vnc voice vorbis wav wavpack wddx weather webkit webphoto webpresence webserver win32 win64 windeco wininst winpopup wma wmf x264 xattr xcb xcomposite xemacs xface xfce xine xinerama xinetd xls xml xmlpatterns xmlreader xmlrpc xmlwriter xmpp xorg xosd xpm xscreensaver xulrunner xv xvid xvmc yahoo yandexnarod zeroconf zip zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en he ru" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Leonid Kopylov 2011-12-18 11:50:14 UTC
Created attachment 296231 [details]
build.log
Comment 2 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-12-18 12:02:30 UTC

*** This bug has been marked as a duplicate of bug 370413 ***