Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 395067 - [qting-edge overlay] x11-libs/qt-assistant-4.8.0 fail to enable webkit
Summary: [qting-edge overlay] x11-libs/qt-assistant-4.8.0 fail to enable webkit
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-17 15:07 UTC by Francesco Riosa
Modified: 2011-12-27 15:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
qt-everywhere-opensource-src-4.8.0-qtwebkit-glib231.patch (qt-everywhere-opensource-src-4.8.0-qtwebkit-glib231.patch,874 bytes, text/plain)
2011-12-19 23:30 UTC, Francesco Riosa
Details
qt-4.8.0-0.23.rc1.fc16.src.tar.gz (qt-4.8.0-0.23.rc1.fc16.src.tar.gz,30.83 KB, application/x-gzip)
2011-12-19 23:39 UTC, Francesco Riosa
Details
remove missing manifests from doc/doc.pri (qt-assistant-4.8.0-remove_manifests.patch,2.61 KB, text/plain)
2011-12-21 11:52 UTC, Franz Trischberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francesco Riosa 2011-12-17 15:07:59 UTC
this regard upstream bug 20236, wich make webkit mandatory, after webkit is set to yes there is a check that revert it to 'no' if xrender is disabled (which is by ebuild).

After the fix it still fail but with a linking error (another bug)

--- /g/ovl/qting-edge/x11-libs/qt-assistant/qt-assistant-4.8.0.ebuild   2011-12-17 11:36:28.550940964 +0000
+++ qt-assistant-4.8.0.ebuild   2011-12-17 14:52:47.655621447 +0000
@@ -63,7 +63,7 @@
 }

 src_configure() {
-       myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+       myconf="${myconf} -no-xkb -no-fontconfig -no-xrandr
                -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
                -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
                -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
@@ -74,7 +74,8 @@
        # https://bugreports.qt.nokia.com//browse/QTBUG-20236
        # Even though webkit option is included, we do not build
        # any targets
-       myconf="${myconf} -webkit"
+       # according to configure xrender is needed by webkit
+       myconf="${myconf} -xrender -webkit"

        qt4-build_src_configure
 }
Comment 1 Francesco Riosa 2011-12-17 15:15:54 UTC
I suspect the linking bug mentioned may depend on bug #395055 since I cannot
build qt-declarative +webkit
Comment 2 Franz Trischberger 2011-12-18 13:08:02 UTC
The error that makes qt-assistant fail is this one:

========
cp: cannot stat `/var/tmp/paludis/x11-libs-qt-assistant-4.8.0/work/qt-everywhere-opensource-src-4.8.0/doc/html/examples-manifest.xml': No such file or directory
========

The "linking"-errors are just from qdoc, so documentation-related. They never make installation fail.
Comment 3 Francesco Riosa 2011-12-19 23:30:19 UTC
Created attachment 296411 [details]
qt-everywhere-opensource-src-4.8.0-qtwebkit-glib231.patch

thanks for clarification.

I'also needed to apply this patch from the fedora qt-4.8.0-0.23.rc1.fc16.src.rpm
Comment 4 Francesco Riosa 2011-12-19 23:39:09 UTC
Created attachment 296413 [details]
qt-4.8.0-0.23.rc1.fc16.src.tar.gz

stripped archive from the srpm (images and qt tarball removed).
There are a pair of interesting patches, notably:

webkit-qtwebkit-2.2-no_Werror.patch
qt-everywhere-opensource-src-4.8.0-QTBUG-22037.patch
qt-everywhere-opensource-src-4.8.0-QUrl_toLocalFile.patch
qt-everywhere-opensource-src-4.8.0-qtwebkit-glib231.patch
Comment 5 Franz Trischberger 2011-12-21 11:06:57 UTC
(In reply to comment #4)
> qt-everywhere-opensource-src-4.8.0-QTBUG-22037.patch

According to https://bugreports.qt.nokia.com/browse/QTBUG-22037 comment by Oswald Buddenhagen, the patch itself contains no error, but it >> unveils bugs in the usage of qlist <<
The applications that behave bad (e.g. crash) should be patched, not Qt. So I don't know if it is good to add this patch, only to make akregator etc. not crash.
Comment 6 Francesco Riosa 2011-12-21 11:26:49 UTC
being a long time gentoo user I do agree with comment #5 by Franz Fellner, but it can delay the qt-4.8 appearance in the portage tree, on the same bug is also stated that qt itself has problem with this optimization.
Anyway I've been unable to install this release even after a certain amount of effort, and shifted on working with qt5 from git but not portge managed.
Comment 7 Franz Trischberger 2011-12-21 11:46:45 UTC
(In reply to comment #6)
> on the same bug is also stated that qt itself has problem with this optimization.

had problems - I think qt-4.8.0 would not have been released, if this change would have caused errors somewhere in Qt itself.

> Anyway I've been unable to install this release even after a certain amount of
effort

Which problems did you run into? I did not have any problem, except this one. The simple cause: examples-manifest is not existent in the tarball. The simplest solution would be to patch qt-src/doc/doc.pri, removing all the work done with this manifest-file.
Comment 8 Franz Trischberger 2011-12-21 11:52:19 UTC
Created attachment 296563 [details]
remove missing manifests from doc/doc.pri

I don't have any idea, if this is the only solution, but it finally makes qt-assistant install. There are not problems in Qt Assistant, examples and demos got indexed, they are accessible through assistant.

Should these manifests be existent in the .tar.gz, or do they get created on the fly during build? I grepped the sources and did not get any matches other then in doc.pri.
Comment 9 Alex Alexander (RETIRED) gentoo-dev 2011-12-26 18:25:02 UTC
These files are either not generated at some point or simply missing, couldn't find anything either.

I've applied the fix in the overlay, thanks :)
Comment 10 Francesco Riosa 2011-12-27 15:03:38 UTC
indeed it now compile for me too