Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 394549 - app-office/libreoffice-3.5.0.0 looks like crap
Summary: app-office/libreoffice-3.5.0.0 looks like crap
Status: RESOLVED DUPLICATE of bug 392943
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-13 12:30 UTC by Pryka
Modified: 2011-12-13 17:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pryka 2011-12-13 12:30:59 UTC
Libreoffice is badly damaged... is useless for now

Reproducible: Always

Steps to Reproduce:
1. Start Writer

Actual Results:  
Screenshoot:
http://imageshack.us/photo/my-images/708/201112131328511680x1050.png/


app-office/libreoffice-3.5.0.0  USE="branding dbus gnome graphite gtk gtk3 java jemalloc nsplugin opengl vba webdav xmlsec (-aqua) -binfilter -debug -eds -gstreamer -kde (-kdeenablefinal) -mysql -odk -pdfimport -postgres -svg -test"



Portage 2.1.10.40 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r1, 3.1.5 x86_64)
=================================================================
System uname: Linux-3.1.5-x86_64-Intel-R-_Pentium-R-_Dual_CPU_E2180_@_2.00GHz-with-gentoo-2.1
Timestamp of tree: Mon, 12 Dec 2011 11:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.7
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1-r1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r1
Repositories: gentoo roslin
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10 AdobeFlash-10.1 Nero-EULA-US Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.vectranet.pl/gentoo/ http://ftp.vectranet.pl/gentoo/"
LANG="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/roslin"
SYNC="rsync://ftp.vectranet.pl/gentoo-portage"
USE="64bit X a52 accessibility acl acpi additions alsa amd64 apng ass audacious automount bash-completion berkdb binary-drivers branding bzip2 cairo cdda cdr clamdtop cli color consolekit cracklib crashreporter crypt css cups cxx dbus device-mapper dri dvd dvdnav edit emerald enca fastscroll fat fbcondecor ffmpeg fontconfig fortran gadu gcj gdbm gdu gif git gnome gnome-shell gpm gtk gtk3 gudev hddtemp hires-icons hwdb iconv idn imlib introspection iostats ipv6 java jpeg lame libburn libnotify lua lua-cairo lua-imlib mmx modules mp3 mudflap multilib nautilus ncurses network-cron nls nptl nptlonly nsplugin nss ntfs opengl openmp osdmenu pam pcre png policykit portmon pppd pulseaudio qt3support readline session slang spell sqlite sse sse2 ssl ssse3 subversion symlink sysfs syslog tcpd templates threads truetype udev unicode usb weather-metar weather-xoap webm xcb xorg xv xvfb xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-12-13 13:03:57 UTC
Did you update X or your DE recently? If so, did you restart X after the update?
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2011-12-13 14:01:23 UTC

*** This bug has been marked as a duplicate of bug 392943 ***
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2011-12-13 14:02:14 UTC
Gtk3 useflag is pretty nicely described in the use-desc.
Do not set useflags if you are unsure whether you want them :)
Comment 4 Pryka 2011-12-13 17:10:29 UTC
I use GTK3 flag because I want it :P 

Didn't know that cause an issue. I'm pretty sure that when I firs install 3.5.0 in Thu Dec 1 2011, the use-desc don't have any notes telling me that using gtk3 flag with libreoffice is highly-experimental.


Anyway... why the 3.5.0 version of libreoffice is now downgraded to 3.4.99.1-r1?

ps. Sorry for my eng.