Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 394215 - dev-lang/ruby-1.8.7_p352 fails to compile.it's makes wrong callback.func
Summary: dev-lang/ruby-1.8.7_p352 fails to compile.it's makes wrong callback.func
Status: RESOLVED DUPLICATE of bug 370413
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-10 09:03 UTC by Senghoo Kim
Modified: 2011-12-10 09:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,33.05 KB, text/plain)
2011-12-10 09:04 UTC, Senghoo Kim
Details
it's wrong file that ruby Generated : callback.func (callback.func,84.00 KB, text/plain)
2011-12-10 09:07 UTC, Senghoo Kim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Senghoo Kim 2011-12-10 09:03:06 UTC
dev-lang/ruby-1.8.7_p352 fails to compile.it's makes wrong callback.func


Reproducible: Always

Steps to Reproduce:
1.emerge ruby
Actual Results:  
emake failed
 * ERROR: dev-lang/ruby-1.8.7_p352 failed (compile phase):
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line  84:  Called src_compile
 *   environment, line 3355:  Called die
 * The specific snippet of code:
 *       emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
 * 
 * If you need support, post the output of 'emerge --info =dev-lang/ruby-1.8.7_p352',
 * the complete build log and the output of 'emerge -pqv =dev-lang/ruby-1.8.7_p352'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/ruby-1.8.7_p352/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/ruby-1.8.7_p352/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/ruby-1.8.7_p352/work/ruby-1.8.7-p352'





emerge --info :
Portage 2.1.10.39 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r1, 3.1.4-gentoo x86_64)
=================================================================
System uname: Linux-3.1.4-gentoo-x86_64-Intel-R-_Core-TM-_i3_CPU_M_330_@_2.13GHz-with-gentoo-2.1
Timestamp of tree: Sat, 10 Dec 2011 00:45:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1-r1
sys-devel/binutils:       2.22
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="zh zh_CN ko ko_KR en en_US"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.cn.gentoo.org/gentoo-portage"
USE="X a52 acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cjk cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emacs emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv intel ipv6 jpeg laptop lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline sdl session smp socialweb spell sse sse2 sse3 sse4 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb v4l v4l2 vorbis wifi x264 xcb xml xorg xulrunner xv xvid zh_CN zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="zh zh_CN ko ko_KR en en_US" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Senghoo Kim 2011-12-10 09:04:23 UTC
Created attachment 295343 [details]
build.log
Comment 2 Senghoo Kim 2011-12-10 09:07:25 UTC
Created attachment 295345 [details]
it's wrong file that ruby Generated : callback.func
Comment 3 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-12-10 09:08:19 UTC

*** This bug has been marked as a duplicate of bug 370413 ***