Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 393201 - sys-boot/grub-0.97-r10 has a typo in the grub-set-default utility and configuration files
Summary: sys-boot/grub-0.97-r10 has a typo in the grub-set-default utility and configu...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal trivial (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on: 674364
Blocks:
  Show dependency tree
 
Reported: 2011-12-05 00:39 UTC by Claudio Roberto França Pereira
Modified: 2019-02-08 15:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
\`default\' TYPO fix. (grub_set_default_TYPO.patch,731 bytes, patch)
2011-12-05 00:42 UTC, Claudio Roberto França Pereira
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio Roberto França Pereira 2011-12-05 00:39:32 UTC
Both the grub-set-default utility and the default file it creates (/boot/grub/default) contains a small typo, leading the user to believe that 'default\' is a keyword.

Reproducible: Always

Steps to Reproduce:
Run grub-set-default --help as root.
or
Inspect the default (/boot/grub/default) file created by the grub-set-default utility



This is a small typo, I just changed \`default\' to \`default\`. Should I change the patch to use simple apostrophes instead ('default')?

It seems the matter is actually a bit too complicated... From wikipedia:

Many earlier (pre 1985) computer displays and printers rendered the ASCII apostrophe as a typographic apostrophe, and rendered the ASCII grave accent ( ` ) U+0060 as a matching left single quotation mark. This allowed a more typographic appearance of text: ``I can't'' would appear as ‘‘I can’t’’ on these systems. This can still be seen in many documents prepared at that time, and is still used in the TeX typesetting system to create typographic quotes.
http://en.wikipedia.org/wiki/Apostrophe

Maybe the author thougth that autotools would generate pretty/simetric quotation marks.
Comment 1 Claudio Roberto França Pereira 2011-12-05 00:41:56 UTC
Forgot to mention, I'm reporting this here because grub legacy support has been dropped officially. Anyways, since I use Gentoo and the fix is trivial, why not make this perfect?

Patch supplied.
Comment 2 Claudio Roberto França Pereira 2011-12-05 00:42:34 UTC
Created attachment 294815 [details, diff]
\`default\' TYPO fix.
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-02-08 15:22:35 UTC
grub:0 is gone