Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 392009 - Gnome 3.2 can't run standard mode, only fallback
Summary: Gnome 3.2 can't run standard mode, only fallback
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Blocks: gnome3.2 gnome3.6
  Show dependency tree
Reported: 2011-11-26 20:11 UTC by Pryka
Modified: 2012-11-28 23:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

:0-greeter.log (:0-greeter.log,37.96 KB, text/plain)
2011-11-26 20:13 UTC, Pryka

Note You need to log in before you can comment on or make changes to this bug.
Description Pryka 2011-11-26 20:11:06 UTC
So after update to Gnome 3.2 there are only problems on my desktop:

x11-drivers/nvidia-drivers-285.05.09 + x11-base/xorg-server-1.10.4-r1 = Can log to system but only in fallback Gnome, don't have idea why.

x11-drivers/nvidia-drivers-290.06 + x11-base/xorg-server-1.11.2-r2 = Everything hangs on GDM, can't even type password. I can only see this blue background.

Building GDM with or without gnome-shell USE flag don't give any result.

Reproducible: Always

Steps to Reproduce:
1.Try to log on my Gnome 3.2 desktop

Portage (hardened/linux/amd64, gcc-4.5.3, glibc-2.14.1-r0, 3.1.1-grsec x86_64)
System uname: Linux-3.1.1-grsec-x86_64-Intel-R-_Pentium-R-_Dual_CPU_E2180_@_2.00GHz-with-gentoo-2.1
Timestamp of tree: Fri, 25 Nov 2011 16:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1-r1
sys-devel/binutils:       2.22
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.14.1
Repositories: gentoo roslin
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10 AdobeFlash-10.1 Nero-EULA-US Oracle-BCLA-JavaSE"
CFLAGS="-march=core2 -O2 -pipe"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="64bit X a52 accessibility acl acpi additions alsa amd64 apng ass audacious automount bash-completion berkdb binary-drivers branding bzip2 cairo cdda cdr clamdtop cli color consolekit cracklib crashreporter crypt css cups cxx dbus device-mapper dri dvd dvdnav edit emerald enca fastscroll fat fbcondecor ffmpeg fontconfig gadu gcj gdbm gdu gif git gnome gnome-shell gpm gtk gudev hardened hddtemp hires-icons hwdb iconv idn imlib introspection iostats java jpeg justify lame libburn libnotify lua lua-cairo lua-imlib mmx modules mp3 mudflap multilib nautilus ncurses network-cron nls nptl nptlonly nsplugin nss ntfs opengl openmp osdmenu pam pax_kernel pcre png policykit portmon pppd pulseaudio qt3support readline session slang spell sqlite sse sse2 ssl ssse3 subversion symlink sysfs syslog tcpd templates threads truetype udev unicode urandom usb weather-metar weather-xoap webm xcb xorg xv xvfb xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Pryka 2011-11-26 20:13:24 UTC
Created attachment 293887 [details]
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-11-28 06:58:09 UTC
> gnome-session[7683]: DEBUG(+): fill: *** Launching helper 'bash -c 'gnome-shell --help | grep -q gdm-mode && /usr/libexec/gnome-session-check-accelerated'' to know if session is runnable
> gnome-session-check-accelerated: Helper exited with code 11

Gnome is refusing to run in gnome-shell mode because the tool that checks for opengl acceleration is exiting with an error. To find out what the specific error is, please post the output of the following command (needs to be run from a terminal in X):

LANG=C /usr/libexec/gnome-session-check-accelerated-helper

> Portage (hardened/linux/amd64, gcc-4.5.3, glibc-2.14.1-r0,
> 3.1.1-grsec x86_64)

@gnome, does anyone know if gnome-3.2 might have problems on a hardened (grsec) system?
Comment 3 Pryka 2011-11-28 09:43:22 UTC
If I run Gnome 3.2 on a kernel without grsec Gnome-Shell is running fine, just checked it out.

Anyway there are those outputs U are asking for:

From Gnome fallback mode command output is empty, when I run this command in X with no graphic environment I get this:

"gnome-session-is-accelerated: No X display"
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-11-28 17:01:00 UTC
Unfortunately, if you want to use gnome-shell, you will probably have to give up grsec:

> <chithead> tetromino: 3d acceleration and grsec don't mix, you have to disable so much that the result will cannot be considered secure any longer

(In reply to comment #3)
> From Gnome fallback mode command output is empty, when I run this command in X
> with no graphic environment I get this:
> "gnome-session-is-accelerated: No X display"

I apologize if I was unclear. Please run that command in a terminal *in a graphic environment* of some sort (doesn't matter whether it's gnome, or fluxbox, or even just startx with twm and xterm - anything X11-based will do).
Comment 5 Pryka 2011-11-28 17:22:06 UTC
No problem my bad. Anyway i run this command in Gnome terminal with no effect. No output at all :|

About that 3D acceleration @chithead is wrong. In standard Hardened profile nvidia drivers and nvidia USE flag are hard-masked in profile because there is a no way to successfully install them. But if U unmask USE flag and driver U can patch them and install with no problem on your PC with patch from grsecurity team. This was not only Gentoo issue, and it was solved long time ago. I really don't understand why Gentoo Hardened team refuse to add this drivers in our repo.

I play 3D games on my Hardened + Nvidia like Witcher, WoT, WoW, and many many others with any problem at all. And like I write before, full 3D support.


ps. Sorry for my eng.
Comment 6 Pryka 2011-11-28 17:23:51 UTC
>I really don't understand why Gentoo Hardened team refuse to add this
> drivers in our repo.

I mean patches not drivers
Comment 7 Mart Raudsepp gentoo-dev 2011-11-28 17:26:02 UTC
(In reply to comment #5)
> No problem my bad. Anyway i run this command in Gnome terminal with no effect.
> No output at all :|

If there are no problems, it would be just returning with successful exit code.

Issue an "echo $?" command right after the check-accelerated command. If it outputs 0, then it was a successful executing code and GNOME ought to be trying to use non-fallback
Comment 8 Pryka 2011-11-28 17:34:40 UTC

Iluvatar pryka # LANG=C /usr/libexec/gnome-session-check-accelerated-helper
Iluvatar pryka # echo $?
Comment 9 Gilles Dartiguelongue gentoo-dev 2012-10-31 08:33:16 UTC
Hi there,

could you update us on your situation ?