Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 391799 - mpfr-3.1.0 fails to install due to missing html files
Summary: mpfr-3.1.0 fails to install due to missing html files
Status: RESOLVED FIXED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-24 19:03 UTC by Sven Schwyn (svoop)
Modified: 2011-11-27 17:49 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for mpfr-3.1.0 which uses EAPI="3" (mpfr-3.1.0.patch,664 bytes, patch)
2011-11-25 19:29 UTC, Benda Xu
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Schwyn (svoop) 2011-11-24 19:03:35 UTC
/Gentoo/var/tmp/portage/dev-libs/mpfr-3.1.0/image/Gentoo//usr/share/doc/mpfr-3.1.0: No such file or directory
!!! dohtml: *.html does not exist
dohtml failed
 * ERROR: dev-libs/mpfr-3.1.0 failed (install phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  98:  Called call-ebuildshell 'src_install'
 *   environment, line 421:  Called src_install
 *   environment, line 2642:  Called die
 * The specific snippet of code:
 *       dohtml *.html && rm COPYING* *.html || die;
 * 
 * If you need support, post the output of 'emerge --info =dev-libs/mpfr-3.1.0',
 * the complete build log and the output of 'emerge -pqv =dev-libs/mpfr-3.1.0'.
 * The complete build log is located at '/Gentoo/var/tmp/portage/dev-libs/mpfr-3.1.0/temp/build.log'.
 * The ebuild environment file is located at '/Gentoo/var/tmp/portage/dev-libs/mpfr-3.1.0/temp/environment'.
 * S: '/Gentoo/var/tmp/portage/dev-libs/mpfr-3.1.0/work/mpfr-3.1.0'
 * QA Notice: file does not exist:
 * 
 * 	dohtml: *.html does not exist


Reproducible: Always




Portage 2.2.01.19572-prefix (prefix/darwin/macos/10.7/x64, gcc-4.2.1, unavailable, 11.2.0 i386)
=================================================================
                        System Settings
=================================================================
System uname: Darwin-11.2.0-i386-64bit
Timestamp of tree: Thu, 24 Nov 2011 09:40:14 +0000
distcc 3.1-toolwhip.1 i386-apple-darwin11.0 [disabled]
app-shells/bash:      4.2_p10
dev-lang/python:      2.7.2-r3
dev-util/cmake:       2.8.6-r3
dev-util/pkgconfig:   0.26
sys-devel/autoconf:   2.68
sys-devel/automake:   1.11.1
sys-devel/gcc-config: 1.4.1-r00.2
sys-devel/libtool:    2.4-r4
sys-devel/make:       3.82
Repositories: gentoo_prefix bitcetera-prefix local
Installed sets: 
ACCEPT_KEYWORDS="~x64-macos"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-apple-darwin11"
CFLAGS="-O2 -pipe -march=nocona"
CHOST="x86_64-apple-darwin11"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/portage /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=nocona"
DISTDIR="/Gentoo/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles news nostrip parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-dead_strip_dylibs"
PKGDIR="/Gentoo/usr/portage/packages"
PORTAGE_CONFIGROOT="/Gentoo/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/Gentoo/var/tmp"
PORTDIR="/Gentoo/usr/portage"
PORTDIR_OVERLAY="/Gentoo/var/lib/layman/bitcetera-prefix /Gentoo/usr/local/portage/local"
SYNC="rsync://rsync.prefix.freens.org/gentoo-portage-prefix"
USE="aqua coreaudio cracklib cxx mmx mmxext modules ncurses nls objc objc++ prefix readline sse sse2 ssl unicode x64-macos zlib" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="Darwin" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="Darwin" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jordi Paul 2011-11-25 14:17:16 UTC
I think this is caused by

/home/paul/gentoo/usr/bin/install -c -m 644  AUTHORS BUGS COPYING COPYING.LESSER NEWS TODO '/home/paul/gentoo/var/tmp/portage/dev-libs/mpfr-3.1.0/image//home/paul/gentoo/usr/share/doc/mpfr/.'

but pushd uses ${PF}, so the -3.1.0 part of the string is missing.

Also, docdir does not use EPREFIX.
Comment 2 Benda Xu gentoo-dev 2011-11-25 19:29:54 UTC
Created attachment 293745 [details, diff]
patch for mpfr-3.1.0 which uses EAPI="3"
Comment 3 Benda Xu gentoo-dev 2011-11-25 19:32:05 UTC
mpfr-3.1.0 uses EAPI="3" and introduced src_configure, which caused the original prefix patch for it fail. A patch is attached reflecting this to make it emerged.
Comment 4 Fabian Groffen gentoo-dev 2011-11-27 17:49:46 UTC
Thanks heroxdb, indeed a merge error caused this problem.  Committed now.