Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 39113 - mod_php fails with qt
Summary: mod_php fails with qt
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: PPC Porters
Depends on:
Reported: 2004-01-22 22:24 UTC by Steven Wagner
Modified: 2004-03-28 20:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Steven Wagner 2004-01-22 22:24:02 UTC
mod_php simply doesn't work if it is compiled with qt support.  I found the -qt solution in the forums.  Since I dont think this has been fixed yet, and has been around for somet time, maybe qt should be disabled by default in the ebuild.

Reproducible: Always
Steps to Reproduce:
Comment 1 SpanKY gentoo-dev 2004-01-22 22:26:47 UTC
maybe you should give us more info to work with :)

`emerge info`, the error you're seeing, and config.log from the build directory at a minimum
Comment 2 Steven Wagner 2004-01-22 22:30:38 UTC
Here is the thread, which contains the info you requested.
Comment 3 Steven Wagner 2004-01-22 22:41:00 UTC
lu_zero says this is solved, so I'll close.

<lu_zero> with the latest glibc the problem should be solved
<shwag> lu_zero: the mod_php problem ?
<lu_zero> yes

# ldd /usr/lib/apache2-extramodules/ |grep qt => /usr/qt/3/lib/ (0x6f09f000)
Comment 4 Rajiv Aaron Manglani (RETIRED) gentoo-dev 2004-03-28 20:38:41 UTC
tested. mod_php 4.3.4-r4 works with USE=qt.