Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 39098 - "emerge openoffice" crashes in compile after consuming 2.9 GB of disk space
Summary: "emerge openoffice" crashes in compile after consuming 2.9 GB of disk space
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-22 19:39 UTC by M. Edward Borasky
Modified: 2004-01-22 21:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description M. Edward Borasky 2004-01-22 19:39:04 UTC
Openoffice (189 megabytes in a single file to download) fills up a disk partition, which is 2.9 gigbaytes, without completing the emerge. Command was "emerge openoffice". It took 18 hours to download the tarball on a 24 kilobaud line. Then the compile process croaked. The tail end of the console output is below:
-------------------------------------------------------------------------------
>>> Install openoffice-1.1.0-r2 into /var/tmp/portage/openoffice-1.1.0-r2/image/ category app-office
cat: write error: No space left on device
cat: write error: No space left on device
 * Installing OpenOffice.org into build root...
install: cannot create directory `/var/tmp/portage/openoffice-1.1.0-r2/image': No space left on device
 * Scanning for a open DISPLAY to start Xvfb...
 * Starting Xvfb on $DISPLAY=1 ...
/usr/sbin/ebuild.sh: line 1367: 32425 Bus error               ${maketype} $*

!!! ERROR: app-office/openoffice-1.1.0-r2 failed.
!!! Function src_install, Line 541, Exitcode 135
!!! (no error message)

DreamSongGentoo root # df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda8              7874528   5034484   2440028  68% /
none                    257412         0    257412   0% /dev/shm
/dev/hda10            18761948   9540316   8268580  54% /homex
/dev/hda7              2949028   2949028         0 100% /var/tmp
DreamSongGentoo root #
-------------------------------------------------------------------------------
"/var/tmp" is a single partition. I created it specifically for this test since the first attempt filled up "/" and I had to clean it out to do anything. Here's a "du -sk" on "/var/tmp":

DreamSongGentoo root # du -sk /var/tmp/*
16      /var/tmp/lost+found
2949008 /var/tmp/portage
DreamSongGentoo root #

Reproducible: Always
Steps to Reproduce:
1. Create a separate partition for "/var/tmp".
2. Type "emerge openoffice".
3. Wait.

Actual Results:  
See above log.

Expected Results:  
Finished the compile and deleted its workspace.

The package needs to be broken into smaller chunks. 189 megabytes takes 18 hours
to download on my 24K connection, and the exact size of workspace I need to
compile it is as yet undetermined. I'm guessing, from looking in "/var/tmp"
after other emerges, that the intermediate workspace is *not* cleared after a
successful emerge, and I couldn't find a documented way to clear it -- I ended
up doing "rm -fr" manually while trying to make this work.
Comment 1 SpanKY gentoo-dev 2004-01-22 21:43:00 UTC
wget can resume so breaking up the package is dumb

if you dont have the free space requirements (and yes, gigs is not a bug, thats how much it takes), use openoffice-bin

as for leaving /var/tmp/portage/ stuff behind, it will always be left behind after a _failed_ emerge ... a pita to debug if you dont have whats left over :P

if you _really_ want that feature file a new bug for portage to get a new FEATURES keyword (maybe like 'cleanfailed')