Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 39066 - nvidia-kernel-1.0.5328-r1 oopses on 2.6.2-rc1-mm1
Summary: nvidia-kernel-1.0.5328-r1 oopses on 2.6.2-rc1-mm1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2004-01-22 12:16 UTC by Andrei Ivanov
Modified: 2004-04-06 00:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

kernel logs... (nvidia-bug,8.35 KB, text/plain)
2004-01-22 12:17 UTC, Andrei Ivanov
2.6.2-rc2-mm1 log (2.6.2-rc2-mm1.txt,2.38 KB, text/plain)
2004-02-02 01:18 UTC, Andrei Ivanov

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Ivanov 2004-01-22 12:16:20 UTC
This is just a FYI, I expect the bleeding edge kernels not to really work nvidia..  at least not until you guys patch it... ;)
Attached you will find the logs...
Comment 1 Andrei Ivanov 2004-01-22 12:17:27 UTC
Created attachment 24251 [details]
kernel logs...
Comment 2 Andrei Ivanov 2004-01-22 12:18:08 UTC
Portage 2.0.50_pre19 (default-x86-1.4, gcc-3.3.2, glibc-2.3.3_pre20031222-r0, 2.6.1-mm1)
System uname: 2.6.1-mm1 i686 Celeron (Mendocino)
Gentoo Base System version
Autoconf: sys-devel/autoconf-2.59
Automake: sys-devel/automake-1.7.8
CFLAGS="-march=pentium2 -O3 -pipe -fomit-frame-pointer -ffast-math -fforce-addr -falign-functions=4"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=pentium2 -O3 -pipe -fomit-frame-pointer -ffast-math -fforce-addr -falign-functions=4"
FEATURES="autoaddcvs ccache sandbox"
USE="X aalib acl acpi adns alsa apache2 arts avi berkdb bonobo caps cdr crypt cups curl dga dvd dvdr encode esd faad flash foomaticdb gd gdbm gif gnomedb gnutls gphoto2 gpm gstreamer gtk gtk2 gtkhtml imap imlib innodb java javascript jpeg lcms ldap libg++ libgda libwww mad maildir memlimit mikmod mmx mozilla mozsvg mpeg ncurses nls nptl odbc oggvorbis opengl oss pam pdflib pg-hier pg-intdatetime pg-vacuumdelay pic png python qt quicktime readline samba sdl slang slp speex ssl tcpd tiff truetype usb wxwindows x86 xml xml2 xv zlib"
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2004-01-22 22:31:30 UTC
I don't know much at all about oops's .. any kernel guys can lend a little hand?
Comment 4 Brian Jackson (RETIRED) gentoo-dev 2004-01-22 23:07:28 UTC
It's also bad form to file bugs against packages that aren't in portage ;)

I'd try to grab the latest patch from and hack the nvidia-kernel ebuild to use it. The patch it uses currently is dated Jan. 4th. The Changelog on says there were some locking changes. I don't know if this will help, but it's probably your best option at this point.
Comment 5 Brian Jackson (RETIRED) gentoo-dev 2004-01-23 10:11:42 UTC
How exactly did you get 2.6.2-rc2-mm1 installed? Hopefully not by copying the 2.6.1-mm5 ebuild. If so that could be the problem, the new eclass doesn't handle -pre/-rc external patchsets yet.
Comment 6 Andrei Ivanov 2004-01-23 12:54:33 UTC
I've installed it by hand... untarred 2.6.1, patched to 2.6.2-rc1 and then patched to -mm1, copied the .config from 2.6.1-mm1, and then make oldconfig and the rest...
Comment 7 John Mylchreest (RETIRED) gentoo-dev 2004-02-01 18:24:43 UTC
this should now be fixed with nvidia-kernel 5336
Comment 8 Andrei Ivanov 2004-02-02 00:41:10 UTC
Not really... I just tried 2.6.2-rc2-mm1 and the latest nvidia-kernel and nvidia-glx, and I still get an oops... should I open another bug or reopen this one ?
Comment 9 John Mylchreest (RETIRED) gentoo-dev 2004-02-02 01:02:47 UTC
re-open this one :)
Comment 10 Andrei Ivanov 2004-02-02 01:15:09 UTC
New stuff:

media-video/nvidia-kernel-1.0.5336-r1 *
media-video/nvidia-glx-1.0.5336 *
kernel: 2.6.2-rc2-mm1
Comment 11 Andrei Ivanov 2004-02-02 01:18:04 UTC
Created attachment 24799 [details]
2.6.2-rc2-mm1 log
Comment 12 John Mylchreest (RETIRED) gentoo-dev 2004-02-06 00:57:00 UTC
can you pleae try this on 2.6.2 vanilla (development-sources)
Comment 13 Andrei Ivanov 2004-04-06 00:00:06 UTC
It seems to work on 2.6.4-mm1...
On 2.6.5-rc3-mm? I get an unknown module format...
2.6.5-mm1 freezes the computer on boot at "Calculating module dependencies" :(

Anyway, the computer got an hardware upgrade so too many things have changed and I think this bug can be closed...
Comment 14 Donnie Berkholz (RETIRED) gentoo-dev 2004-04-06 00:17:09 UTC
Reopen if you hit this problem again.