Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 389717 - dev-java/icedtea-7.2.0-r1 fails due to unmappable character
Summary: dev-java/icedtea-7.2.0-r1 fails due to unmappable character
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-06 10:41 UTC by Oleg Mikheev
Modified: 2012-05-01 17:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,184.08 KB, text/plain)
2011-11-06 10:43 UTC, Oleg Mikheev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Mikheev 2011-11-06 10:41:54 UTC
/var/tmp/portage/dev-java/icedtea-7.2.0-r1/work/icedtea-2.0/openjdk.build/corba/gensrc/org/omg/PortableServer/AdapterActivator.java:8: error: unmappable character for encoding ascii

that's because the sources are considered to be ASCII, but line 8 of corbe generated stubs is:

* 6 Ноябрь 2011 г. 13:22:00 MSK

I guess that's because my LC_CTYPE is set to ru_RU.UTF-8

Reproducible: Always

Steps to Reproduce:
1. set LC_CTYPE to something like ru_RU.UTF-8
2. emerge dev-java/icedtea-7.2.0-r1
3.
Actual Results:  
ERROR: dev-java/icedtea-7.2.0-r1 failed (compile phase):
 *   emake failed

Expected Results:  
build successful

$ emerge --info =dev-java/icedtea-7.2.0-r1
Portage 2.1.10.11 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.12.2-r0, 3.1.0 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.1.0-x86_64-Intel-R-_Core-TM-_i3_CPU_M_330_@_2.13GHz-with-gentoo-2.0.3
Timestamp of tree: Sat, 05 Nov 2011 20:30:02 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo mozilla my_local_overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://mirror.mdfnet.se/gentoo ftp://ftp.df.lth.se/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/mozilla /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 berkdb branding bzip2 cli cracklib crypt cups cxx dbus dri fortran gdbm gpm gtk iconv jpeg libnotify lm_sensors midi mmx modules mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre pppd readline session sse sse2 ssl startup-notification sysfs tcpd thunar truetype udev unicode usb xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Oleg Mikheev 2011-11-06 10:43:53 UTC
Created attachment 291809 [details]
build log
Comment 2 Oleg Mikheev 2011-11-06 10:56:38 UTC
OK, I can confirm that the problem was with LC_CTYPE set to ru_RU.UTF-8.
To workaround the bug I used this:

$ sudo LC_CTYPE=UTF-8 emerge --update dev-java/icedtea
Comment 3 Alexander 2011-11-06 18:18:11 UTC
But not working for me.

LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=ru_RU.UTF-8
Comment 4 Alexander 2011-11-06 18:36:03 UTC
Just export 
LC_CTYPE=C
and emerge again.
Comment 5 Nikolaos Chatzidakis 2011-11-08 08:36:19 UTC
(In reply to comment #4)
> Just export 
> LC_CTYPE=C
> and emerge again.

I have the same problem, and neither UTF-8 or C LC_TYPE solves the problem. Any other workaround?
Comment 6 Ralph Sennhauser (RETIRED) gentoo-dev 2011-11-08 08:48:06 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Just export 
> > LC_CTYPE=C
> > and emerge again.
> 
> I have the same problem, and neither UTF-8 or C LC_TYPE solves the problem. Any
> other workaround?

Please try

LANG="C" LC_ALL="C" emerge icedtea
Comment 7 Ralph Sennhauser (RETIRED) gentoo-dev 2011-11-10 21:58:34 UTC
Fixed in tree and java-overlay. Thanks for the report and testing.
Comment 8 Nikolaos Chatzidakis 2011-11-11 10:17:03 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > Just export 
> > > LC_CTYPE=C
> > > and emerge again.
> > 
> > I have the same problem, and neither UTF-8 or C LC_TYPE solves the problem. Any
> > other workaround?
> 
> Please try
> 
> LANG="C" LC_ALL="C" emerge icedtea

Work like a charm by the way. Thanks a lot.
Comment 9 R Stephan 2012-05-01 17:44:52 UTC
As paludis user, I had to ignore jdk using '-0 jdk' as option to resolve. Just FYI.