Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 388671 - net-analyzer/net-snmp-5.4.3: opts to extra_commands transition
Summary: net-analyzer/net-snmp-5.4.3: opts to extra_commands transition
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: init.d-depr-opts
  Show dependency tree
 
Reported: 2011-10-27 15:58 UTC by Jonathan Thibault
Modified: 2011-12-31 21:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch that changes opts to extra_commands (net-snmp-init-script.patch,396 bytes, patch)
2011-10-27 16:00 UTC, Jonathan Thibault
Details | Diff
switch to extra_started_commands, use s-s-d for reload (snmpd.patch,771 bytes, patch)
2011-11-21 20:18 UTC, Michael Palimaka (kensington)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Thibault 2011-10-27 15:58:39 UTC
The following warning shows up when starting net-snmp

/etc/init.d/snmpd start
 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.


Reproducible: Always

Steps to Reproduce:
1. /etc/init.d/snmpd start

Actual Results:  
Warning is displayed

Expected Results:  
Should start without warning

Trivial change, see attached patch.  Following a similar bug for iptables, this probably should have been marked as blocking Bug 381895.
Comment 1 Jonathan Thibault 2011-10-27 16:00:00 UTC
Created attachment 291017 [details, diff]
Patch that changes opts to extra_commands

Tested the patch, works for me.
Comment 2 Michael Palimaka (kensington) gentoo-dev 2011-11-21 20:18:34 UTC
Created attachment 293357 [details, diff]
switch to extra_started_commands, use s-s-d for reload

Patch to use extra_started_commands to avoid manual check, and to use start-stop-daemon for reload.
Comment 3 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2011-12-31 21:29:43 UTC
This has been fixed by swegener already. Thanks!