Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 388421 - net-im/pidgin should depend on slotted app-text/gtkspell:0 due to new gtkspell-3
Summary: net-im/pidgin should depend on slotted app-text/gtkspell:0 due to new gtkspell-3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome3.2
  Show dependency tree
 
Reported: 2011-10-25 09:02 UTC by Pim Vullers
Modified: 2011-10-27 04:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pim Vullers 2011-10-25 09:02:38 UTC
In the gnome overlay app-text/gtkspell-3.0.0_pre20110814:3 is available. Pidgin does not build against this, only gtkspell-2.*. This can be solved by depending on the slotted version.

Reproducible: Always

Steps to Reproduce:
1. emerge gtkspell-3
2. unmerge gtkspell-2 (depclean)
3. emerge pidgin (preserved-rebuild)
Actual Results:  
...
checking X11/SM/SMlib.h presence... yes
checking for X11/SM/SMlib.h... yes
checking for GTKSPELL... no
no
configure: error: 
GtkSpell development headers not found.
Use --disable-gtkspell if you do not need it.
...

Expected Results:  
Build finishes successfully.

I know this issue is caused by the gnome-overlay, but this ebuild will hit the portage tree one time. So it is better to be prepared.
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-10-27 04:57:12 UTC
>  27 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
>  pidgin-2.10.0-r1.ebuild:
>  Slot gtkspell dependency to 2 in preparation for gtkspell-3.