Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 388325 - sys-devel/llvm-2.9-r2 shared lib linking error
Summary: sys-devel/llvm-2.9-r2 shared lib linking error
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal minor with 1 vote (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-24 10:41 UTC by Massimo Burcheri
Modified: 2015-09-03 09:49 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo Burcheri 2011-10-24 10:41:03 UTC
sys-devel/llvm-2.9-r2 (also 2.8-r2) shared library is searched at /usr/lib.
This makes emerge icedtea fail with USE="zero shark" at least on PPC but presumably on other 32bit archs capable of shark too.

Reproducible: Always

Steps to Reproduce:
1. patch icedtea with patch from bug 257567
2. USE="zero shark" icedtea

Actual Results:  
./gamma: error while loading shared libraries: libLLVM-2.9.so: cannot open shared object file: No such file or directory 


Work-around:
ln -s /usr/lib/llvm/libLLVM-2.8.so /usr/lib/
or
ln -s /usr/lib/llvm/libLLVM-2.9.so /usr/lib/
Comment 1 Ian Stakenvicius gentoo-dev 2011-10-24 17:39:22 UTC
USE="shark" in all in-tree versions of icedtea (and all versions in java-overlay, it seems) is not supported at the moment.  However, since other packages work fine with the llvm libs where they are, I would expect that it would be icedtea that needs to be patched to work with this LD location.  

Assigning to the llvm dev anyways so they know what's up (and in case i'm incorrect about this being icedtea's responsibility), and CC'ing icedtea maintainers.
Comment 2 Bernard Cafarelli gentoo-dev 2011-11-08 13:35:34 UTC
Hmm other packages depending on llvm find the library without a problem (clang and mesa being the biggest examples).

Searching on icedtea bugzilla, I found this:
http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=639
(still open)
Comment 3 Ralph Sennhauser (RETIRED) gentoo-dev 2012-05-12 10:54:41 UTC
This can be fixed in icedtea by adding it to rpath.

http://overlays.gentoo.org/proj/java/browser/java-overlay/dev-java/icedtea/files/icedtea-7.2.0_shark_jvm_rpath.patch?rev=8922

However, currently Shark doesn't build either way. For icedtea:6 CACAO and for icedtea:7 JamVM is currently used if HotSpot isn't available for a given architecture.
Comment 4 Bernard Cafarelli gentoo-dev 2015-09-03 09:49:57 UTC
Cleaning some old llvm/clang bugs, does it still fail with current versions? (llvm-3.7.0 was just added in tree)