Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 388149 - media-gfx/hugin-2011.2.0 fails to configure
Summary: media-gfx/hugin-2011.2.0 fails to configure
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-22 19:58 UTC by Juergen Rose
Modified: 2013-11-24 16:44 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/media-gfx/hugin-2011.2.0/temp/build.log (build.log,481.52 KB, text/plain)
2011-10-23 18:16 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2011-10-22 19:58:29 UTC
'emerge hugin' fails with:
...
-- Found SWIG: /usr/bin/swig (found suitable version "2.0.4", required is "2.0")
CMake Warning (dev) at /usr/share/cmake/Modules/FindLAPACK.cmake:48 (find_package):
  File /usr/share/cmake/Modules/FindLAPACK.cmake includes
  /var/tmp/portage/media-gfx/hugin-2011.2.0/work/hugin-2011.2.0/CMakeModules/FindPkgConfig.cmake
  (found via CMAKE_MODULE_PATH) which shadows
  /usr/share/cmake/Modules/FindPkgConfig.cmake.  This may cause errors later
  on .

  Policy CMP0017 is not set: Prefer files from the CMake module directory
  when including from there.  Run "cmake --help-policy CMP0017" for policy
  details.  Use the cmake_policy command to set the policy and suppress this
  warning.
Call Stack (most recent call first):
  CMakeLists.txt:344 (FIND_PACKAGE)
This warning is for project developers.  Use -Wno-dev to suppress it.

-- checking for module 'lapack'
--   found lapack, version 3.8.4
-- LAPACK found (atllapack;f77blas;atlcblas;m;atlas)
-- Using shared internal libraries
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_FIND_LIBRARY_SUFFIXES
-- Python libs version: 2.7.2
-- Found PythonInterp: /usr/bin/python (found version "2.7.2")
-- Install Python libs into /usr/lib/python2.7/site-packages
-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -O2 -march=pentium-m -fomit-frame-pointer 
C++             -O2 -march=pentium-m -fomit-frame-pointer 
Linker flags:
Executable       -Wl,-O1 -Wl,--as-needed
Module           -Wl,-O1 -Wl,--as-needed
Shared           -Wl,-O1 -Wl,--as-needed

-- Configuring incomplete, errors occurred!
 * ERROR: media-gfx/hugin-2011.2.0 failed (configure phase):
 *   cmake failed
Comment 1 Juergen Rose 2011-10-22 20:00:03 UTC
root@thinkpad:/root(30)# emerge --info =media-gfx/hugin-2011.2.0
Portage 2.1.10.30 (default/linux/x86/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 3.0.6-gentoo i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.0.6-gentoo-i686-Intel-R-_Pentium-R-_M_processor_2.00GHz-with-gentoo-2.1
Timestamp of tree: Sat, 22 Oct 2011 08:00:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r4
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo arcon lordvan science x11 java-overlay sunrise local x-cpan g-octave
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.1 cadsoft Oracle-BCLA-JavaSE"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium-m -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=pentium-m -fomit-frame-pointer"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://ftp.easynet.nl/mirror/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/arcon /var/lib/layman/lordvan /var/lib/layman/science /var/lib/layman/x11 /var/lib/layman/java-overlay /var/lib/layman/sunrise /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="R X Xaw3d a52 aac abiword accessibility acl acpi admin afs alsa amrr ao apache2 applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion beagle berkdb blas blast bluetooth boo boost branding bzip2 cairo cardbus cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit corba cracklib crypt css cups curl cxx daap db dbase dbi dbm dbus declarative designer devhelp device-mapper dga dia djvu doc dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse galago garmin gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp ginac git glade glib glpk gml gmp gmtsuppl gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gsm gstreamer gtk gudev guile harness hddtemp hdf hdf5 hdri http httpd hwdb iconv icq icu id3 ide imagemagick imap innodb inotify ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kdrive kerberos kpathsea ladspa lame lapack laptop latex latex3 lcms ldap lensfun libffi libgda libnotify libsamplerate lirc lua lzo mad madwifi mail maildir mapnik math matroska mkl mmx mmxext mng modules mono moonlight motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ogdi ogg ole openexr opengl openmp overview pam pango pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl science sdk sdl secure-delete semantic-desktop server session sip slang slp smbclient sms sndfile snmp soup sox speex spell sql sqlite sse sse2 ssl startup-notification stlport subtitles subversion suexec svg svm swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thinkpad threads thunderbird tidy tiff tk tools truetype udev unicode usb userlocales utempter v4l2 vaapi video virtualbox vorbis wav webdav webdav-serf webkit wifi win32codecs wmf wxwidgets x264 x86 xattr xcb xemacs xext xft xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc yaml zlib zvbi" ALSA_CARDS="intel8x0 ac97_codec emu10k1 emu10k1x" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="usb-wt220u" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon vesa displaylink" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-gfx/hugin-2011.2.0 was built with the following:
USE="lapack python -sift" LINGUAS="de fr -bg -ca -cs -da -en_GB -es -fi -hu -it -ja -ko -nl -pl -pt_BR -ro -ru -sk -sl -sv -uk -zh_CN -zh_TW"



root@thinkpad:/root(31)# emerge -pqv =media-gfx/hugin-2011.2.0
[ebuild   R   ] media-gfx/hugin-2011.2.0  USE="lapack python -sift" LINGUAS="de fr -bg -ca -cs -da -en_GB -es -fi -hu -it -ja -ko -nl -pl -pt_BR -ro -ru -sk -sl -sv -uk -zh_CN -zh_TW"
Comment 2 Mike Gilbert gentoo-dev 2011-10-23 16:54:42 UTC
Please attach the full build log.
Comment 3 Juergen Rose 2011-10-23 18:16:25 UTC
Created attachment 290647 [details]
/var/tmp/portage/media-gfx/hugin-2011.2.0/temp/build.log
Comment 4 Benj FitzPatrick 2011-10-25 20:49:12 UTC
Have you tried USE="-lapack" as this workaround solved the problem for me.
Comment 5 Juergen Rose 2011-10-26 17:05:10 UTC
USE="-lapack" worked for me too.
Comment 6 Gunnar Steiniger 2011-10-26 20:29:31 UTC
USE="-lapack" worked here too ~amd64
Comment 7 Matthias Raffelsieper 2011-10-28 09:54:37 UTC
The problem is not hugin or boost, but a bug in cmake-2.8.6-r1: The file /usr/share/cmake/Modules/FindLAPACK.cmake is broken, since it resets the CMAKE_FIND_LIBRARY_SUFFIXES variable if pkg-config is used.

I have filed a new bug report #388757 for this, since this is rather a problem with cmake and could affect more packages. See that bug for a fix.
Comment 8 gentoo 2012-09-13 19:29:12 UTC
I filed a bug here https://bugs.launchpad.net/hugin/+bug/1048799
since I met the same issue.

Their answer suggested that Hugin 2011.0 and oldest versions than 2012.0 can not compile against boost version greater than 1.47...It has been fixed with 2012.0 version but not oldest one.

I followed their suggestion, and downgraded boost from 1.49 to 1.46.
Hugin now compile fine, and is working again.

I would then suggest to block within Hugin's ebuild boost versions above 1.47 
my package mask : >dev-libs/boost-1.47
Comment 9 Justin Lecher gentoo-dev 2013-11-24 16:44:07 UTC
+*hugin-9999 (24 Nov 2013)
+*hugin-2012.0.0-r1 (24 Nov 2013)
+
+  24 Nov 2013; Justin Lecher <jlec@gentoo.org> +hugin-2012.0.0-r1.ebuild,
+  hugin-2013.0.0.ebuild, +hugin-9999.ebuild, +files/hugin-2012.0.0-boost.patch,
+  +files/hugin-2012.0.0-perl.patch, +files/hugin-2013.0.0-boost.patch,
+  metadata.xml:
+  Backport fix for building with newer boost; Use system cmake modules to
+  detect lapack; backport patch to use perl 5.16; fixes bugs
+  #296510,300127,373387,374337,388149,404227,484238
+