Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 388105 - net-print/cups fails to build with dev-lang/php-5.4.0_rc4
Summary: net-print/cups fails to build with dev-lang/php-5.4.0_rc4
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
: 399627 401133 402105 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-22 12:38 UTC by Andreas Sturmlechner
Modified: 2012-02-07 22:07 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build.log (build.log,43.49 KB, text/plain)
2011-10-22 12:38 UTC, Andreas Sturmlechner
Details
emerge --info (emerge.info,16.34 KB, text/plain)
2011-10-22 12:47 UTC, Andreas Sturmlechner
Details
cups-1.5.0-r2 build.log (against php-5.4.0_rc1) (build.log,56.55 KB, text/plain)
2011-11-19 13:24 UTC, Andreas Sturmlechner
Details
build.log (build.log,47.41 KB, text/plain)
2011-11-20 09:52 UTC, Dennis Schridde
Details
cups-1.5.0-r2.diff (cups-1.5.0-r2.ebuild.diff,373 bytes, patch)
2011-12-31 13:53 UTC, Andreas Sturmlechner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2011-10-22 12:38:05 UTC
Created attachment 290507 [details]
full build.log

More a heads-up since php-5.4 is still beta and masked anyway, so of minor importance.


Compiling phpcups.c...
phpcups.c:43:16: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘phpcups_functions’
phpcups.c:64:3: error: ‘phpcups_functions’ undeclared here (not in a function)
cc1: warning: unrecognized command line option "-Wno-tautological-compare"
make[1]: *** [phpcups.o] Error 1
make: *** [all] Error 1
Comment 1 Andreas Sturmlechner gentoo-dev 2011-10-22 12:47:53 UTC
Created attachment 290509 [details]
emerge --info
Comment 2 Chris Smith 2011-10-28 19:28:29 UTC
FYI, CUPS is dropping php support:
http://cups.org/str.php?L3932
Comment 3 dyle 2011-11-18 08:40:23 UTC
Isn't this also related to https://bugs.gentoo.org/show_bug.cgi?id=347521
Comment 4 dyle 2011-11-18 08:41:47 UTC
(In reply to comment #3)
> Isn't this also related to https://bugs.gentoo.org/show_bug.cgi?id=347521
Ups. Nope. Same cause (php) other impact. Sorry.
Comment 5 Andreas Sturmlechner gentoo-dev 2011-11-19 13:24:56 UTC
Created attachment 293089 [details]
cups-1.5.0-r2 build.log (against php-5.4.0_rc1)

The error has changed somewhat with php-5.4.0_rc1:

...
Compiling phpcups.c...
phpcups.c:43:1: error: unknown type name ‘function_entry’
...
phpcups.c:45:3: error: initializer element is not computable at load time
phpcups.c:45:3: error: (near initialization for ‘phpcups_functions[0]’)
Comment 6 Dennis Schridde 2011-11-20 09:52:02 UTC
Created attachment 293181 [details]
build.log

Probably a similar issue:
---
Compiling phpcups.c...
/bin/sh: --includes: command not found
phpcups.c:33:17: fatal error: php.h: No such file or directory
compilation terminated.
---
Using dev-lang/php-5.4.0_rc1
Comment 7 Dennis Schridde 2011-11-20 14:04:11 UTC
(In reply to comment #6)
> Created attachment 293181 [details]
> build.log
> 
> Probably a similar issue:
> ---
> Compiling phpcups.c...
> /bin/sh: --includes: command not found
> phpcups.c:33:17: fatal error: php.h: No such file or directory
> compilation terminated.
> ---
> Using dev-lang/php-5.4.0_rc1
The error changed for me to:
---
Compiling phpcups.c...
phpcups.c:43:1: error: unknown type name ‘function_entry’
---
Maybe the previous problem was a parallel-make issue...
Comment 8 Andreas Sturmlechner gentoo-dev 2011-12-31 13:26:54 UTC
Updated summary because, naturally, older versions are not compatible as well as reported in this forum thread: http://forums.gentoo.org/viewtopic-t-905934.html

Elevated importance to normal because PHP-5.4 nears its first release and is just ~arch keyworded anymore, people are stumbling over this.
Comment 9 Andreas Sturmlechner gentoo-dev 2011-12-31 13:53:06 UTC
Created attachment 297457 [details, diff]
cups-1.5.0-r2.diff

since the error hasn't changed, but I wanted to upload something anyway, here's an easy dependency fix für the cups ebuild.
Comment 10 Guy 2012-01-22 23:52:15 UTC
*** Bug 399627 has been marked as a duplicate of this bug. ***
Comment 11 Dennis Schridde 2012-01-27 12:56:41 UTC
Issue persists, can someone please fix this in the portage tree?
Comment 12 Brandon Penglase 2012-01-29 17:39:55 UTC
I was getting the same error as the original poster, with cups-1.5.0-r4 and php-5.4.0_rc6. However with reading through this post, and noting in Comment #2 that upstream is removing PHP support, I recompiled with USE="-php", and it compiled cleanly for me. If I'm understanding upstream's report correctly, it will be removed in version 1.6. It seems to be functioning for me without PHP compiled in, but I'm not doing anything too fancy.
Comment 13 tman 2012-02-03 18:24:04 UTC
 USE="-php" emerge  cups -1av

cause on my box same errors


lease specify prototyping behavior for CUPS.xs (see perlxs manual)
x86_64-pc-linux-gnu-gcc -c  -I../../ -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -march=core2 -O2 -pipe   -DVERSION=\"1.2\" -DXS_VERSION=\"1.2\" -fPIC "-I/usr/lib64/perl5/5.12.4/x86_64-linux-thread-multi/CORE"   CUPS.c
rm -f blib/arch/auto/CUPS/CUPS.so
LD_RUN_PATH="/usr/lib64" x86_64-pc-linux-gnu-gcc  -shared -march=core2 -O2 -pipe -Wl,-O1 -Wl,--as-needed CUPS.o -Wl,-O1 -Wl,--as-needed -o blib/arch/auto/CUPS/CUPS.so 	\
   -lcups  	\
  
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lcups
collect2: ld returned 1 exit status
make: *** [blib/arch/auto/CUPS/CUPS.so] Error 1
 * ERROR: net-print/cups-1.5.0-r4 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of 'emerge --info =net-print/cups-1.5.0-r4',
 * the complete build log and the output of 'emerge -pqv =net-print/cups-1.5.0-r4'.
 * The complete build log is located at '/var/log/portage/net-print:cups-1.5.0-r4:20120203-182126.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-print/cups-1.5.0-r4/temp/environment'.
 * S: '/var/tmp/portage/net-print/cups-1.5.0-r4/work/cups-1.5.0'
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info

>>> Failed to emerge net-print/cups-1.5.0-r4, Log file:

>>>  '/var/log/portage/net-print:cups-1.5.0-r4:20120203-182126.log'

 * Messages for package net-print/cups-1.5.0-r4:

 * Package:    net-print/cups-1.5.0-r4
 * Repository: gentoo
 * Maintainer: printing@gentoo.org
 * USE:        X acl amd64 dbus elibc_glibc filters gnutls java jpeg kerberos kernel_linux ldap linguas_de multilib pam perl png python slp ssl threads tiff usb userland_GNU xinetd
 * FEATURES:   preserve-libs sandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
Comment 14 Andrei Slavoiu 2012-02-04 07:32:21 UTC
@tman You have a completely different problem, the one covered by this bug is:

Compiling phpcups.c...
phpcups.c:43:16: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before
‘phpcups_functions’
phpcups.c:64:3: error: ‘phpcups_functions’ undeclared here (not in a function)
cc1: warning: unrecognized command line option "-Wno-tautological-compare"
make[1]: *** [phpcups.o] Error 1
make: *** [all] Error 1

while the one you are experiencing is:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld:
cannot find -lcups
collect2: ld returned 1 exit status
make: *** [blib/arch/auto/CUPS/CUPS.so] Error 1

You should log a different bug.
Comment 15 Andreas K. Hüttel gentoo-dev 2012-02-07 16:35:13 UTC
*** Bug 402105 has been marked as a duplicate of this bug. ***
Comment 16 Andreas K. Hüttel gentoo-dev 2012-02-07 16:45:12 UTC
"Fixed"...

+  07 Feb 2012; Andreas K. Huettel <dilfridge@gentoo.org> cups-1.5.2-r1.ebuild:
+  Drop php scripting support; it is unmaintained by upstream, has already been
+  removed in trunk, and displays build failures with recent php. Bug 388105
+
Comment 17 Andreas K. Hüttel gentoo-dev 2012-02-07 21:52:35 UTC
*** Bug 401133 has been marked as a duplicate of this bug. ***