Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 387963 - media-gfx/gtkimageview: awkward configure.in adds unuseful dependency to gnome-common
Summary: media-gfx/gtkimageview: awkward configure.in adds unuseful dependency to gnom...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-21 05:50 UTC by Samuel Bauer
Modified: 2016-10-12 18:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
pre-version not inheriting gnome2 (gtkimageview-1.6.4-r1.ebuild,829 bytes, text/plain)
2011-10-21 06:02 UTC, Samuel Bauer
Details
gtkimageview-1.6.4-r1.ebuild (gtkimageview-1.6.4-r2.ebuild,1.92 KB, text/plain)
2011-10-31 09:45 UTC, Samuel Bauer
Details
gtkimageview-1.6.4-gnome-common.patch (gtkimageview-1.6.4-gnome-common.patch,591 bytes, patch)
2016-10-10 19:31 UTC, Samuel Bauer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Bauer 2011-10-21 05:50:49 UTC
gtkimageview inherits gnome2
thus requiring gnome-base/gnome-common to compile

adding to the ebuild an extra and unrequired dependency ( not runtime dep )


Reproducible: Always

Steps to Reproduce:
emerge gtkimageview
Actual Results:  
gnome-common ebuild will be installed as dependency

Expected Results:  
the ebuild doesn't require gnome-common to be compiled and installed
Comment 1 Samuel Bauer 2011-10-21 06:02:50 UTC
Created attachment 290405 [details]
pre-version not inheriting gnome2

The ebuild compile but it's just sample

it doesn't install the gtk-doc entries
it doesn't install the sample files
Comment 2 Samuli Suominen gentoo-dev 2011-10-21 15:30:30 UTC
gnome-common is set of .m4 macros for autotools, and the gtkimageview's configure.ac has:

# Initialize GNOME environment
GNOME_COMMON_INIT

and the ebuild calls eautoreconf for patches

thus this bug is invalid, and the dependency is required
Comment 3 Samuel Bauer 2011-10-31 09:45:58 UTC
Created attachment 291341 [details]
gtkimageview-1.6.4-r1.ebuild

Do not use GNOME_COMMON_INIT, as it does not work with autoreconf.

See: http://live.gnome.org/GnomeGoals/ModernAutotools

Take a look at the src_prepare it's easy to understand that the configure.in is broken (already two fix without the one I suggest)
Comment 4 poletti.marco 2013-01-20 17:42:12 UTC
Any progress on this?
There's a fixed ebuild attached to this bug already.

Due to this bug, emerging imagemagick with USE="raw gtk" pulls in gnome-common (through gtkimageview) for no apparent reason.
Comment 5 Pacho Ramos gentoo-dev 2016-10-09 11:47:18 UTC
This is INVALID, gnome2.eclass has nothing to do with gnome-common requirement
Comment 6 Samuel Bauer 2016-10-10 19:31:22 UTC
Created attachment 449780 [details, diff]
gtkimageview-1.6.4-gnome-common.patch

This is unrelated to gnome2.eclass, even my local overlay wasn't throwing it, before I updated it yesterday, seeing changes in the tree.
But still the GNOME_COMMON_INIT line seem to be a waste

Trying to emerge the new patched ebuild version:

emerge -C gnome-common
emerge gtkimageview -1

Ensures that gnome common isn't installed, is not pushed through emerge, and still doesn't complain nor at compile time, nor at runtime.
Removing GNOME_COMMON_INIT line just removes the dependency.
So it doesn't appear to be mandatory dependency.
Comment 7 Pacho Ramos gentoo-dev 2016-10-12 18:20:54 UTC
Upstream is the one that should consider all the gnome-common functionality can be replaced by others (dropping gnome-common macros is not as easy as simply dropping its usage and go on... that is the reason you still see tons of packages still DEPENDing on gnome-common waiting for someone to port them to, for example, autoconf-archive macros for "similar" functionality