Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 387781 - dev-lang/gnat-gcc-4.4.5 won't link programs
Summary: dev-lang/gnat-gcc-4.4.5 won't link programs
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: ada team [OBSOLETE]
Depends on:
Reported: 2011-10-20 06:32 UTC by Nick Schwindt
Modified: 2012-04-14 06:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Nick Schwindt 2011-10-20 06:32:36 UTC
Installed gnat-gcc-4.4.5.  Have eselect-gnat-1.5 installed FWIW.  Tried to compile a simple hello world program (i.e. gnatmake hello_world_1.adb).  The compilation fails during linking with the following errors

gnatbind -x hello_world_1.ali
gnatlink hello_world_1.ali
/usr/lib64/gnat-gcc/x86_64-pc-linux-gnu/4.4/adalib/libgnat.a(a-finali.o): In function `ada__finalization___assign__3':
(.text+0x21e): undefined reference to `_Unwind_Resume'

Reproducible: Always

Tried to roll back to gnat-gcc-4.4.3 and 4.3.5, but those ebuilds don't appear to bootstrap.
Comment 1 Nick Schwindt 2011-10-22 18:39:11 UTC
If I tell the linker to link against the c++ std library, i.e.

>gnatmake hello_world.adb -largs -lstdc++

then i get what appears to be a working program.  This does not feel like the right fix for this.
Comment 2 Nick Schwindt 2012-04-14 06:05:54 UTC
Did a reinstall just to see what would happen, and I no longer have this issue.