Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 387079 - app-admin/gkrellm-2.3.5 just left me with 116 GiB (sic) worth of core dumps (x11-drivers/nvidia-drivers-285.05.09 related)
Summary: app-admin/gkrellm-2.3.5 just left me with 116 GiB (sic) worth of core dumps (...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-13 23:15 UTC by PM
Modified: 2012-07-22 22:06 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PM 2011-10-13 23:15:42 UTC
It was happily filling my hard drive at the rate of 16 dumps per minute, each one about 16MiB, for about two days until I noticed the issue, traced it and closed gkrellm. In the meantime it continued to operate seemingly normally and gave no indication that it's on it's way to cause a small disaster. 

Here's an example backtrace: 

#0  0x00007f1e1bde2c50 in _nv019tls () from /usr/lib64/opengl/nvidia/lib/libnvidia-tls.so.285.05.09
#1  0x00007f1e225546e6 in __libc_fork () at ../nptl/sysdeps/unix/sysv/linux/fork.c:170
#2  0x00007f1e23ce7968 in fork_exec_with_pipes (intermediate_child=1, working_directory=0x0, argv=0x1ddbef0, envp=0x0, close_descriptors=1, search_path=1, stdout_to_null=0, stderr_to_null=0, child_inherits_stdin=0, 
    file_and_argv_zero=0, child_setup=0, user_data=0x0, child_pid=0x0, standard_input=0x0, standard_output=0x0, standard_error=0x0, error=0x0) at gspawn.c:1227
#3  0x00007f1e23ce8737 in g_spawn_async_with_pipes (working_directory=<optimized out>, argv=<optimized out>, envp=<optimized out>, flags=<optimized out>, child_setup=<optimized out>, user_data=<optimized out>, child_pid=0x0, 
    standard_input=0x0, standard_output=0x0, standard_error=0x0, error=0x0) at gspawn.c:648
#4  0x00007f1e23ce883c in g_spawn_async (working_directory=<optimized out>, argv=<optimized out>, envp=<optimized out>, flags=<optimized out>, child_setup=<optimized out>, user_data=<optimized out>, child_pid=0x0, error=0x0)
    at gspawn.c:137
#5  0x00007f1e23ce8992 in g_spawn_command_line_async (command_line=<optimized out>, error=0x0) at gspawn.c:763
#6  0x0000000000417f6a in gkrellm_abort (sig=<optimized out>) at main.c:2058
#7  <signal handler called>
#8  0x00007f1e1bde2c50 in _nv019tls () from /usr/lib64/opengl/nvidia/lib/libnvidia-tls.so.285.05.09
#9  0x00007f1e225546e6 in __libc_fork () at ../nptl/sysdeps/unix/sysv/linux/fork.c:170
#10 0x00007f1e23ce7968 in fork_exec_with_pipes (intermediate_child=0, working_directory=0x0, argv=0x7f1e169ceae0, envp=0x0, close_descriptors=1, search_path=1, stdout_to_null=0, stderr_to_null=1, child_inherits_stdin=0, 
    file_and_argv_zero=0, child_setup=0, user_data=0x0, child_pid=0x7f1e169ce9f4, standard_input=0x0, standard_output=0x7f1e169ce9fc, standard_error=0x0, error=0x7f1e169ceb70) at gspawn.c:1227
#11 0x00007f1e23ce81d4 in g_spawn_sync (working_directory=<optimized out>, argv=<optimized out>, envp=<optimized out>, flags=<optimized out>, child_setup=<optimized out>, user_data=<optimized out>, standard_output=0x7f1e169ceb68, 
    standard_error=0x0, exit_status=0x0, error=0x7f1e169ceb70) at gspawn.c:284
#12 0x0000000000471a3c in gkrellm_sys_sensors_get_temperature (sensor_path=0x1ba34c0 "GPUCoreTemp", id=<optimized out>, iodev=0, interface=<optimized out>, temp=0x1bb6f50) at sysdeps/linux.c:3107
#13 0x00000000004493f3 in read_sensors_thread (data=<optimized out>) at sensors.c:211
#14 0x00007f1e23cc94c6 in g_thread_create_proxy (data=0x1d20c90) at gthread.c:1962
#15 0x00007f1e1d3d925a in ?? () from /usr/lib64/libGL.so.1
#16 0x00007f1e2283fd4c in start_thread (arg=0x7f1e169cf700) at pthread_create.c:301
#17 0x00007f1e22584ded in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115



Reproducible: Sometimes




Portage 2.2.0_alpha67 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 2.6.39-pf3 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.39-pf3-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E7400_@_2.80GHz-with-gentoo-2.1
Timestamp of tree: Wed, 12 Oct 2011 07:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.4_p6-r1, 1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise multimedia dupa
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles installsources news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=native -pipe -ggdb"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
LANG="pl_PL.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/multimedia /usr/local/portage/moje"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac aalib acl acpi alsa amd64 amr amrnb amrwb apng async audiofile automount bash-completion berkdb bfq bineditor bluray branding bzip2 cairo cdda cddb cdparanoia cdr chdir cli consolekit cracklib crypt css cuda cups curl cxx dbus dirac disk-partition divx djvu dri dts dvd dvdr editor emboss emovix enca encode exchange exif faac faad fam fat ffmpeg fftw firefox firefox3 flac fontconfig fortran gd gdbm gdu geoip gif glitz gmedia gphoto2 gpm gtk hddtemp iconv id3 id3tag imagemagick inotify iostats ipod jpeg kde kde4 kdehiddenvisibility kipi kompare kpathsea kqemu ladspa lame laptop lastfm latex lcms libass libcaca libnotify libsamplerate lm_sensors lzma lzo mad matroska midi mjpeg mmap mmx mmxext mng modules mp3 mp3tunes mp4 mpeg mplayer mtp mudflap multilib musicbrainz ncurses nls nptl nptlonly nsplugin ntfs nvidia ogg okteta openal opencore-amr opengl openmp pam pango pch pcre pdf plasma png policykit portage ppds pppd private-headers qt3 qt3support qt4 qthelp readline realmedia roe scanner schroedinger sdl secure-delete sensord session shaders slang sndfile solver soundtouch sourceview sparse spell sse sse2 sse3 sse4 sse4a ssl ssse3 startup-notification suid svg swat symlink sysfs syslog tcpd theora threads tiff truetype udev unicode upnp usb vaapi vamp vcd vdpau vorbis webkit wicd wifi wmf wmp wxwidgets wxwindows x264 xcb xcomposite xine xml xorg xscreensaver xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-admin/gkrellm-2.3.5 was built with the following:
USE="X hddtemp lm_sensors (multilib) nls ssl -gnutls -ntlm"
Comment 1 PM 2011-10-13 23:22:04 UTC
Holy shit. Just after posting this I had a video encoder called Handbrake crash just before finishing a 20 hour encode. The trace also ended in libnvidia-tls.so. What the hell.
Comment 2 PM 2011-10-14 00:49:25 UTC
I noticed it looks similar to https://bugs.gentoo.org/show_bug.cgi?id=375615 , but as far as I can see this bug is supposed to be fixed in nvidia-drivers-285.05.09
Comment 3 Eric Grüttefien 2011-10-17 17:38:15 UTC
Seems happen me too dmesg show me some hints of died apps:


evolution[8297]: segfault at 30 ip 00007fee242b6a08 sp 00007fedddfeaca0 error 4 in libnvidia-tls.so.285.05.09[7fee242b6000+3000]
evolution[13766] general protection ip:7f099c6efa08 sp:7f095cff8ca0 error:0 in libnvidia-tls.so.285.05.09[7f099c6ef000+3000]
device lo entered promiscuous mode
evolution[14202] general protection ip:7f324f9d3a08 sp:7f320aff5ca0 error:0 in libnvidia-tls.so.285.05.09[7f324f9d3000+3000]
device lo left promiscuous mode
device lo entered promiscuous mode
evolution[6699] general protection ip:7fbf55ee9a08 sp:7fbf1477eca0 error:0 in libnvidia-tls.so.285.05.09[7fbf55ee9000+3000]
device lo left promiscuous mode
device lo entered promiscuous mode
device lo left promiscuous mode
evolution[22485] general protection ip:7f44fbfefa08 sp:7f44d7b38ca0 error:0 in libnvidia-tls.so.285.05.09[7f44fbfef000+3000]
Comment 4 PM 2012-01-23 14:28:22 UTC
This just happened again with nvidia-drivers-290.10.

http://pastebin.com/ZKZGyUDX
Comment 5 PM 2012-02-16 02:33:30 UTC
With nvidia-drivers-295.20-r1 gkrellm hangs up immediately after starting, probably when probing for GPU temp.
Comment 6 Tomasz Golinski 2012-02-17 01:30:53 UTC
I have the same issue with nvidia-drivers-295.20-r1 - gkrellm hangs. Removing GPU temp sensor fixes the problem. (I didn't have any issues with earlier versions of nvidia-drivers).
Comment 7 Gavin Pryke 2012-02-21 09:44:07 UTC
With =x11-drivers/nvidia-drivers-290.10 gkrellm started fine for me, as soon as I upgraded to =x11-drivers/nvidia-drivers-295.20-r1 gkrellm hangs on start like in comment 5 and comment 6. Running gdb gkrellm there is no hang and GPU temp sensor does display...
Comment 8 Philip Webb 2012-03-24 17:14:11 UTC
(In reply to comment #6)
> I have the same issue with nvidia-drivers-295.20-r1 - gkrellm hangs.
> Removing GPU temp sensor fixes the problem. (I didn't have any issues with
> earlier versions of nvidia-drivers).

I can confirm all of this on my machine after updating Nvidia-drivers.
Comment 9 Doug Goldstein gentoo-dev 2012-07-22 21:55:39 UTC
Is anyone experiencing this with the 295.x drivers or newer?
Comment 10 Doug Goldstein gentoo-dev 2012-07-22 22:06:12 UTC
If you still are experiencing this, the issue is occurring in the closed part of the driver. Please use nvidia-bug-report.sh and e-mail the output along with a description of the issue to linux-bugs@nvidia.com