Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 386877 - sys-kernel/gentoo-sources-3.0.6,sky2 and 8021q vlan broken
Summary: sys-kernel/gentoo-sources-3.0.6,sky2 and 8021q vlan broken
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2011-10-12 08:48 UTC by A Sotirov
Modified: 2012-01-11 20:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

current config (config-3.0.6-kt,84.98 KB, text/plain)
2011-10-17 09:29 UTC, A Sotirov
Last working kernel config (config-2.6.38-killer-r7-ok,80.78 KB, text/plain)
2011-10-17 09:30 UTC, A Sotirov
sky2 with debug=16 dmesg (3.1_sky2_debug=16_dmesg,209.92 KB, text/plain)
2011-11-03 19:23 UTC, A Sotirov
Commands run to get the vlan interface up (gentoo3.1_commands,1.99 KB, text/plain)
2011-11-03 19:23 UTC, A Sotirov
Working dmesg 2.6.38-r7 (2.6.38_sky2_debug16_ok_dmesg,122.76 KB, text/plain)
2011-11-03 19:24 UTC, A Sotirov
Commands run to get the vlan interface up 2.6.38 (2.6.38_commands_ok,828 bytes, text/plain)
2011-11-03 19:24 UTC, A Sotirov

Note You need to log in before you can comment on or make changes to this bug.
Description A Sotirov 2011-10-12 08:48:01 UTC
Vlan tagging with sky2 does not work

Reproducible: Always

Steps to Reproduce:
1. Add vlan tag to the inteface
2. Add ip address to the vlan interface and no trafic passes trough
Actual Results:  
No traffic flows

[ 5878.338201] eth0: no IPv6 routers present
[ 5936.530202] vlan100: no IPv6 routers present
[ 6738.055175] 802.1Q VLAN Support v1.8

filename:       /lib/modules/3.0.6-gentoo/kernel/drivers/net/sky2.ko
version:        1.28
license:        GPL
author:         Stephen Hemminger <>
description:    Marvell Yukon 2 Gigabit Ethernet driver
srcversion:     5D9820C75BF0C4D5AF89FB2
alias:          pci:v000011ABd00004381sv*sd*bc*sc*i*
alias:          pci:v00001148d00009000sv*sd*bc*sc*i*
vermagic:       3.0.6-gentoo SMP preempt mod_unload modversions 
parm:           debug:Debug level (0=none,...,16=all) (int)
parm:           copybreak:Receive copy threshold (int)
parm:           disable_msi:Disable Message Signaled Interrupt (MSI) (int)

filename:       /lib/modules/3.0.6-gentoo/kernel/net/8021q/8021q.ko
version:        1.8
license:        GPL
alias:          rtnl-link-vlan
srcversion:     7D905721D310E29168B7DE8
vermagic:       3.0.6-gentoo SMP preempt mod_unload modversions
Comment 1 Stratos Psomadakis (RETIRED) gentoo-dev 2011-10-16 10:28:12 UTC
What was the last working kernel? 

Can you also post your emerge --info output, and your kernel config? 

Comment 2 A Sotirov 2011-10-17 09:28:41 UTC
Last working kernel is gentoo-sources-2.6.38-r7

emerge --info 

Portage (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.0.6-gentookillertop x86_64)
System uname: Linux-3.0.6-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9500_@_2.60GHz-with-gentoo-2.1
Timestamp of tree: Thu, 13 Oct 2011 05:45:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x-ishoof vmware
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA Q3AEULA Nero-EULA-US dlj-1.1 sun-bcla-java-vm skype-eula AdobeFlash-10.1 cadsoft PUEL Oracle-BCLA-JavaSE"
CFLAGS="-march=core2 -msse4.1 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -msse4.1 -O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en bg ru"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/ishoof /var/lib/layman/vmware"
USE="X acl acpi aio alsa amd64 apng bash-completion berkdb bluetooth bzip2 cdr cleartype cleatype cli consolekit corefonts cracklib crypt cups cxx dbus device-mapper dri dvd fontforge fortran fuse gdbm gdu git gnome gnome-keyring gnutls gpg gpm gtk gtk2 guile hal iconv ipv6 java jpeg latex libnotify lirc lm_sensors mmx modules mplayer mudflap multilib multiuser ncurses networking networkmanager nls nokia nptl nptlonly nsplugin nss nvidia opengl openmp pam pcre pdf pmu png policykit pppd pulseaudio qt3support readline session sound spell sse sse2 ssl subversion suid svg sysfs tcpd threads tk toolbar truetype type1 udev unicode usb vim-syntax webkit xinerama xml xmp xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en bg ru" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

i can confirm it doesn't work with gentoo-sources-2.6.39-r3 too.
Comment 3 A Sotirov 2011-10-17 09:29:59 UTC
Created attachment 290037 [details]
current config

The broken kernel config
Comment 4 A Sotirov 2011-10-17 09:30:49 UTC
Created attachment 290039 [details]
Last working kernel config
Comment 5 Iorgo Stamatelos 2011-10-17 19:06:18 UTC
Same here with sys-kernel/gentoo-sources-3.0.3:3.0.3
Comment 6 Stratos Psomadakis (RETIRED) gentoo-dev 2011-10-26 14:36:59 UTC
Is there any output from dmesg, except the 3 lines you posted, related to this bug?

Can you also try loading sky2 with increased debug level?

I can see a *lot* sky2 related patches in 2.6.39 changelog, and the ones related to vlan handling: 

    sky2: convert to new VLAN model (v0.2)
    sky2: restore vlan acceleration on reset
    sky2: FE+ vlan workaround
    sky2: fix VLAN receive processing (resend)
    sky2: Fix VLAN unregistration
    sky2: checksum offload plus vlan bug
    [PATCH] sky2: add hardware VLAN acceleration support
Comment 7 A Sotirov 2011-11-03 19:22:36 UTC
Updated to 3.1 same thing.
Comment 8 A Sotirov 2011-11-03 19:23:18 UTC
Created attachment 291601 [details]
sky2 with debug=16 dmesg
Comment 9 A Sotirov 2011-11-03 19:23:52 UTC
Created attachment 291603 [details]
Commands run to get the vlan interface up
Comment 10 A Sotirov 2011-11-03 19:24:26 UTC
Created attachment 291605 [details]
Working dmesg 2.6.38-r7
Comment 11 A Sotirov 2011-11-03 19:24:58 UTC
Created attachment 291607 [details]
Commands run to get the vlan interface up 2.6.38
Comment 12 A Sotirov 2011-11-03 19:26:28 UTC
BTW have tried couple other distros. same thing since 2.6.39 vanila does not work as well. Should we go upstream ?
Comment 13 Mike Pagano gentoo-dev 2011-12-11 19:13:08 UTC
Yes, we can. But before we do, they will want to know if the latest vanilla 3.1 was tested.

If that fails, they will then look to see if latest git sources is tested.

Can you test both and then we can go upstream with this.
Comment 14 A Sotirov 2012-01-11 20:45:36 UTC
Οκ. I have now tested:

linux-3.2-rc7          git
linux-3.2.0            vanilla
linux-3.2.0-gentoo-r1  gentoo
They are all broken 802.1q tags does not work. 

Now do you want me to enable some specific debuging or anything ? BTW marvell has independent linux 2.6 driver (sk98lin) it compiles up to 3.1 and works fine so far. 

BTW here is the marvell i have:
09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 12)
on DELL XPS M1530

have anybody tried different 88E80xx ?