Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 386759 - sys-block/spindown-0.4.0-r1init script should change opts variable to use either extra_commands or extra_started_commands
Summary: sys-block/spindown-0.4.0-r1init script should change opts variable to use eit...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Wolfram Schlich (RETIRED)
URL: http://sources.gentoo.org/cgi-bin/vie...
Whiteboard:
Keywords:
Depends on:
Blocks: init.d-depr-opts
  Show dependency tree
 
Reported: 2011-10-11 09:57 UTC by Martin von Gagern
Modified: 2012-01-01 01:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to stop using deprecate variables, and to actually reload properly (spindownd.init-patch,527 bytes, patch)
2011-11-17 16:55 UTC, Michael Palimaka (kensington)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin von Gagern 2011-10-11 09:57:03 UTC
The sys-block/spindown-0.4.0-r1 init script uses variables deprecated by
sys-apps/openrc-0.9.x. See bug #381895 for details.

# grep ^opts= /etc/init.d/spindownd 
opts="reload"
Comment 1 Michael Palimaka (kensington) gentoo-dev 2011-11-17 16:55:44 UTC
Created attachment 292919 [details, diff]
patch to stop using deprecate variables, and to actually reload properly
Comment 2 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2012-01-01 01:05:12 UTC
Fixed in CVS. Thanks!