Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 386579 - x11-misc/google-gadgets-0.11.2 fails to build with parallel make
Summary: x11-misc/google-gadgets-0.11.2 fails to build with parallel make
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
Depends on:
Blocks: parallel-make
  Show dependency tree
Reported: 2011-10-09 19:54 UTC by Leonid Kopylov
Modified: 2013-03-20 14:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (,51.41 KB, text/plain)
2011-10-09 19:58 UTC, Leonid Kopylov

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Kopylov 2011-10-09 19:54:50 UTC
x11-misc/google-gadgets-0.11.2 failed to emerge

Reproducible: Always

Steps to Reproduce:
1. emerge google-gadgets
Actual Results:  
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lggadget-webkitjs-1.0
collect2: ld returned 1 exit status
libtool: install: error: relink `' with the above command before installing it
make[4]: *** [install-extensionLTLIBRARIES] Error 1
make[4]: *** Waiting for unfinished jobs....
libtool: install: /usr/bin/install -c .libs/ /var/tmp/portage/x11-misc/google-gadgets-0.11.2/image//usr/lib64/
libtool: install: (cd /var/tmp/portage/x11-misc/google-gadgets-0.11.2/image//usr/lib64 && { ln -s -f || { rm -f && ln -s; }; })
libtool: install: (cd /var/tmp/portage/x11-misc/google-gadgets-0.11.2/image//usr/lib64 && { ln -s -f || { rm -f && ln -s; }; })
libtool: install: /usr/bin/install -c .libs/libggadget-webkitjs-1.0.lai /var/tmp/portage/x11-misc/google-gadgets-0.11.2/image//usr/lib64/
libtool: install: /usr/bin/install -c .libs/libggadget-webkitjs-1.0.a /var/tmp/portage/x11-misc/google-gadgets-0.11.2/image//usr/lib64/libggadget-webkitjs-1.0.alibtool: install: chmod 644 /var/tmp/portage/x11-misc/google-gadgets-0.11.2/image//usr/lib64/libggadget-webkitjs-1.0.a
libtool: install: x86_64-pc-linux-gnu-ranlib /var/tmp/portage/x11-misc/google-gadgets-0.11.2/image//usr/lib64/libggadget-webkitjs-1.0.a
libtool: install: warning: remember to run `libtool --finish /usr/lib64'
make[4]: Leaving directory `/var/tmp/portage/x11-misc/google-gadgets-0.11.2/work/google-gadgets-for-linux-0.11.2/extensions/webkit_script_runtime'
make[3]: *** [install-am] Error 2
make[3]: Leaving directory `/var/tmp/portage/x11-misc/google-gadgets-0.11.2/work/google-gadgets-for-linux-0.11.2/extensions/webkit_script_runtime'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-misc/google-gadgets-0.11.2/work/google-gadgets-for-linux-0.11.2/extensions/webkit_script_runtime'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-misc/google-gadgets-0.11.2/work/google-gadgets-for-linux-0.11.2/extensions'
make: *** [install-recursive] Error 1
emake failed
 * ERROR: x11-misc/google-gadgets-0.11.2 failed (install phase):
 *   died running make install, base_src_install
 * Call stack:
 *, line   91:  Called src_install
 *   environment, line 2991:  Called base_src_install
 *   environment, line  529:  Called die
 * The specific snippet of code:
 *       emake DESTDIR="${D}" "$@" install || die "died running make install, $FUNCNAME";
 * If you need support, post the output of 'emerge --info =x11-misc/google-gadgets-0.11.2',
 * the complete build log and the output of 'emerge -pqv =x11-misc/google-gadgets-0.11.2'.
 * The complete build log is located at '/var/tmp/portage/x11-misc/google-gadgets-0.11.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-misc/google-gadgets-0.11.2/temp/environment'.
 * S: '/var/tmp/portage/x11-misc/google-gadgets-0.11.2/work/google-gadgets-for-linux-0.11.2'

Expected Results:  
successful emerge

# emerge -pqv =x11-misc/google-gadgets-0.11.2
[ebuild  N    ] x11-misc/google-gadgets-0.11.2  USE="dbus gstreamer gtk networkmanager qt4 soup startup-notification webkit xulrunner -debug"

#emerge --info =x11-misc/google-gadgets-0.11.2
Portage (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.13-r4, 3.0.6-gentoo x86_64)
                        System Settings
System uname: Linux-3.0.6-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Sun, 09 Oct 2011 06:45:02 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1 Nero-EULA-US skype-eula"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en he ru"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X X509 Xaw3d a52 aac aalib acl acpi aim all_sfx alsa amd64 amr apache2 apm apng applet archive aspell assistant audio audit auth auto-completion autoipd automount avahi bash-completion bcmath berkdb bidi bind bittorrent bluetooth bookmarks branding bzip2 cache cairo cal calendar caps ccache cdb cdda cddb cdparanoia cdr cdrom cdsound cgi classic cli clisp color common-lisp consolekit contactnotes cpudetection cracklib crashreporter crypt cscope css ctype cuda cups curl curlwrappers cursors cxx cyrillic daemon dbus declarative device-mapper dga dirac directfb discouraged disk-partition djvu doc downloadorder dri dts dvb dvd dvdr editor eds elisp emacs emboss emerald enca enchant encode evo examples excel exif experimental extra extras fam fax fbcon ffmpeg fileinfo filter finger firefox flac flash fontconfig fontforge fortran fpm ftp fuse gadu gallium games gcj gcrypt gd gdbm gdm gdu gecko geoip ggi gif glibc-omitfp gmail gme gmp gnome gnome-keyring gnutls google google-gadgets gopher gpm grammar graphics graphite grub gsm gstreamer gtk gtk3 gui guile hacking handbook hddtemp hesiod highlight histman history howl-compat hpijs hpn http httpd hunspell icons iconv icq icu id3 id3tag idn ieee1394 imap imlib inifile intl iodbc ios ios-vout irc irda jabber jack jadetex java javascript jingle jpeg kate kde kdm kerberos kolab kontact kpathsea lame latex lcms ldap libass libcaca libnotify libproxy libtiger libv4l2 lirc live llvm lm_sensors lock logrotate lua luatex lxde mad mailwrapper map math mbox mdnsresponder-compat minizip mixer mms mmx mng modplug modules mouse mozilla mp3 mp4 mpeg mplayer mrim msn mssql mtp mudflap multilib multimedia multiuser musepack music mysql mysqli mysqlnd nas natspec nautilus ncurses neXt net nethack netlink network network-cron networking networkmanager nfs nfsv3 nfsv4 nis nls nntp nokia nowlistening nptl nptlonly nsplugin nspluginwrapper ntp nvidia objc objc++ objc-gc odbc odbcmanual odk offensive ogg opengl openid openmp oscar otr overlays pam pango pcntl pcre pdf pdo perl phonon php pidgin plasma plugins png policykit pop posix postfix postgres ppds ppp pppd prediction procmail profile projectm proxy publishers pulseaudio python qemu qt3support qt4 quota radio rar readline recode remote remote-access remoteosd reports rpm rss rtsp ruby samba sample samples sasl scanfolder scanner science sdl sdl-image semantic semantic-desktop sendmail sensord session sharedext simplexml sip skins skype slang slp smbclient smbkrb5passwd smi smp sms smtp snmp soap sockets solver sound soup source spamassassin speech speex spell spoof spoof-source sql sqlite sse sse2 ssh ssl ssse3 startup-notification statistics stats stream sudo suhosin svg swat swig symlink sysfs syslog sysvipc taglib tcl tcpd teletext theora thread threads thumbnail thunar thunderbird tidy tiff tk toolbar tools truetype tv tvtime twolame udev unicode unsupported upnp usb utils v4l2 vaapi vcd vcdx video vim vim-pager vim-syntax vix vkontakte vlc vlm vmware-tools vnc voice vorbis wav wavpack wddx weather webkit webphoto webpresence webserver win32 win64 windeco wininst winpopup wma wmf x264 xattr xcb xcomposite xemacs xface xfce xine xinetd xls xml xmlpatterns xmlreader xmlrpc xmlwriter xmpp xorg xosd xpm xscreensaver xulrunner xv xvid xvmc yahoo yandexnarod zeroconf zip zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en he ru" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Leonid Kopylov 2011-10-09 19:58:01 UTC
Created attachment 289409 [details]
Comment 2 David W Noon 2012-03-15 19:08:58 UTC
I have this same issue on a stable x86 box.
Comment 3 Bernard Cafarelli gentoo-dev 2012-03-16 13:01:51 UTC
Ok, I finally could reproduce it, it's a parallel make issue :/
With MAKEOPTS=-j1 it worked
Comment 4 Leonid Kopylov 2012-04-12 06:06:12 UTC
i still have this error even with MAKEOPTS=-j1
Comment 5 Leonid Kopylov 2012-04-12 06:08:08 UTC
(In reply to comment #3)
> Ok, I finally could reproduce it, it's a parallel make issue :/
> With MAKEOPTS=-j1 it worked

(In reply to comment #3)
> Ok, I finally could reproduce it, it's a parallel make issue :/
> With MAKEOPTS=-j1 it worked

i had to reinstall the whole system, the error remains, even with MAKEOPTS=-j1
Comment 6 Bernard Cafarelli gentoo-dev 2013-03-20 14:42:05 UTC
Package last rites in progress in bug #462472