Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385961 - ruby-1.8.7_p352 fails to compile
Summary: ruby-1.8.7_p352 fails to compile
Status: RESOLVED DUPLICATE of bug 370413
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-06 23:48 UTC by Andriy Baranskyy
Modified: 2011-10-08 06:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,34.20 KB, text/plain)
2011-10-06 23:54 UTC, Andriy Baranskyy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andriy Baranskyy 2011-10-06 23:48:10 UTC
ruby-1.8.7_p352 fails to compile with message:

i686-pc-linux-gnu-gcc -I. -I../.. -I../../. -I../.././ext/dl -DHAVE_DLFCN_H -DHAVE_DLOPEN -DHAVE_DLCLOSE -DHAVE_DLSYM -DHAVE_DLERROR  -D_FILE_OFFSET_BITS=64  -I. -fPIC -O2 -march=native -pipe -fno-strict-aliasing  -fPIC  -fno-defer-pop -fno-omit-frame-pointer  -c sym.c
sym.c: In function ‘rb_dlsym_inspect’:
sym.c:275:30: warning: format ‘%lx’ expects type ‘long unsigned int’, but argument 4 has type ‘struct sym_data *’
sym.c:275:30: warning: format ‘%lx’ expects type ‘long unsigned int’, but argument 5 has type ‘void *’
sym.c:275:30: warning: format ‘%lx’ expects type ‘long unsigned int’, but argument 4 has type ‘struct sym_data *’
sym.c:275:30: warning: format ‘%lx’ expects type ‘long unsigned int’, but argument 5 has type ‘void *’
In file included from dl.c:104:0:
callback.func:1:1: warning: data definition has no type or storage class
callback.func:1:7: error: expected identifier or ‘(’ before ‘long’
In file included from dl.c:104:0:
callback.func:78:33: error: expected ‘)’ before ‘(’ token
callback.func:79:3: warning: data definition has no type or storage class
callback.func:79:24: error: ‘proc’ undeclared here (not in a function)
callback.func:79:39: error: ‘argc’ undeclared here (not in a function)
callback.func:79:45: error: ‘argv’ undeclared here (not in a function)
callback.func:82:1: error: expected identifier or ‘(’ before ‘}’ token
dl.c:106:1: error: expected ‘;’, ‘,’ or ‘)’ before ‘static’


Reproducible: Always




emerge --info
Portage 2.1.10.22 (default/linux/x86/10.0, gcc-4.5.3, glibc-2.14-r0, 3.0.6-gentoo i686)
=================================================================
System uname: Linux-3.0.6-gentoo-i686-Intel-R-_Core-TM-2_CPU_T5500_@_1.66GHz-with-gentoo-2.1
Timestamp of tree: Thu, 06 Oct 2011 20:30:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.3-r1, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.25-r2
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.8.5-r3, 1.9.6-r2, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.14
Repositories: gentoo local
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="uk_UA.UTF-8"
LC_ALL="uk_UA.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en pl uk be de en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dfx 3dnow 3dnowext 7zip X Xaw3d a52 aac aalib accessibility acl acpi adns alsa amarok amr amrnb amrr amrwb ao apng arts aspnet auto-completion autoipd automount avahi bash-completion bidi bittorrent-external bluetooth bonjour bookmarks branding bzip2 c++ cairo calendar caps ccache cdaudio cdda cdio cdr chm cisco cli consolekit context cracklib crypt css cups curl cxx cyrillic daap dbus declarative desktopglobe detex device-mapper dga dia directfb divx djvu docbook dot dri drm dts dv dvd dvdnav dvdr dvdread dvi2tty ebook emovix enca encode exif expat expoblending extra extras fam fax fbcon ffmpeg firefox flac font-server fontconfig fortran ftp fts3 games gd gdbm geoip geolocation ggi gif glib glitz gmail gmedia gnutls google gpg2-experimental gphoto2 gpm gps graphics gsm gstreamer gtk h224 h281 h323 html htmlhandbook http humanities hyperestraier iconv icq icu ide idn imagemagick inotify ipod ipv6 ipw3945 jadetex java javascript jce jpeg jpeg2k justify kde kerberos kpathsea ladspa lame laptop lastfm latex latex3 lcms lensfun libcaca libsamplerate libssh2 libwww live lm_sensors lzo mad marble matroska matrox mbrola md5sum mdnsresponder-compat minizip mjpeg mmap mmx mmxext mng modplug modules moonlight motif mp2 mp3 mp4 mp4live mpeg mpeg2 mpi mplayer msn mtp mudflap musepack music musicbrainz mysql nas ncurses neXt net netbeans netboot network network-cron networking nfs nls npp nptl nptlonly nsplugin ntfs ntp nvidia nvram nvtv obex ogg omega openal openct openexr opengl openmp openssh openvpn oss overlays pam pch pcmcia pcre pcsc-lite pda pdf phonon plasma player plotutils plugins pmu png policykit pppd pstricks publishers python python3 qalculate qos qt3support qt4 quicktime radio rar raw rdesktop rdp readline redeyes reiser4 reiserfs romio rss rtc rtf samba sasl scanner science sdl semantic-desktop session sip skype slp smartcard smbclient sms sndfile snmp socks5 sourceview speech speex spell sql sqlite sqlite3 srt sse sse2 ssl ssse3 startup-notification subversion svg sysfs tcl tcpd templates tetex tex4ht tga themedesigner theora threads tiff timidity tk tools truetype unicode usb v4l v4l2 vcd video vidix visualization vorbis wav wavpack webinterface webkit wifi win32codecs wma wmf wmp wps wxwindows x264 x86 xanim xcb xcomposite xetex xindy xine xinerama xml xorg xpm xprint xulrunner xv xvid xvmc yv12 zeroconf zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="nikon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en pl uk be de en_GB" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andriy Baranskyy 2011-10-06 23:54:16 UTC
Created attachment 289031 [details]
Build log
Comment 2 Hans de Graaff gentoo-dev 2011-10-08 06:24:55 UTC

*** This bug has been marked as a duplicate of bug 370413 ***