Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 38541 - arc program segfaults when reading an arc based archive.
Summary: arc program segfaults when reading an arc based archive.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Daniel Ahlberg (RETIRED)
Depends on:
Reported: 2004-01-17 13:03 UTC by Dan Egli
Modified: 2005-01-01 11:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Dan Egli 2004-01-17 13:03:52 UTC
I have discovered that the arc-521e ebuild has a segfault issue. I took a VERY small arc file (<3k) and tried to de-arc it or perform any operation on it via arc. All operations crezted a segfault.

I grabbed the arc from a nearby RedHat system and it worked fine on the file, even on the Gentoo box. 

Reproducible: Always
Steps to Reproduce:
1. emrege arc
2. attempt to de-arc an arc file
3. watch the segfauly

Actual Results:  
As shown in reproduction steps:

arc e part-0001
Segmentation Fault

Expected Results:  
should have written the .zoo file contained in the .arc file (Don't ask! It's an
amavisd test archive! Not my idea to nest archives).
Comment 1 Daniel Ahlberg (RETIRED) gentoo-dev 2004-02-24 11:56:28 UTC
New version 5.21j in CVS that doesn't seem to segfault.
Comment 2 Dan Egli 2004-12-21 20:54:50 UTC
Looks good. Sorry to take so long in verifying. I keep forgetting I need to :)
Comment 3 Daniel Ahlberg (RETIRED) gentoo-dev 2005-01-01 11:29:09 UTC