Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385361 - Stabilize =media-video/kino-1.3.4
Summary: Stabilize =media-video/kino-1.3.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Denis Dupeyron
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 384733
  Show dependency tree
 
Reported: 2011-10-02 10:54 UTC by Samuli Suominen
Modified: 2011-10-16 19:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild.patch (diff,535 bytes, text/plain)
2011-10-03 16:19 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2011-10-02 10:54:24 UTC
required for compability with newer linux-headers
Comment 1 Agostino Sarubbo gentoo-dev 2011-10-02 12:12:12 UTC
@Samuli,Denis:

RDEPEND.suspect               1
   media-video/kino/kino-1.3.3.ebuild: 'dev-util/intltool'
and drop .la files.
Anyone of you can fix "on the fly" ?
Comment 2 Elijah "Armageddon" El Lazkani (amd64 AT) 2011-10-02 16:21:39 UTC
amd64: other than the problems mentioned by @ago, this package passes
Comment 3 Denis Dupeyron gentoo-dev 2011-10-03 15:45:02 UTC
(In reply to comment #1)
> @Samuli,Denis:

I currently do not have a dev box. ETA for one is unknown as it's a financial issue. But if you can attach a patch here I'll find somebody to commit it.

Thanks,
Denis.
Comment 4 Agostino Sarubbo gentoo-dev 2011-10-03 16:19:37 UTC
Created attachment 288687 [details]
ebuild.patch

(In reply to comment #3)
> I currently do not have a dev box. ETA for one is unknown as it's a financial
> issue. But if you can attach a patch here I'll find somebody to commit it.
> 
> Thanks,
> Denis.

Should be fine for me, please review ;)
Comment 5 Ian Delaney (RETIRED) gentoo-dev 2011-10-05 12:21:18 UTC
amd64:

emerges fine with all use flags; passes test; There is a doubling up of -O,

libtool: link: x86_64-pc-linux-gnu-g++ -march=athlon64 -O2 \
-pipe -fomit-frame-pointer -Wl,-O1 -Wl,--as-needed 

disrespecting of CFLAGS.  up to you to decide its gravity.  
If you would like a patch prepared, just say so, but sorting CFLAG entries can get ugly.
Comment 6 Samuli Suominen gentoo-dev 2011-10-06 08:09:43 UTC
(In reply to comment #1)
> @Samuli,Denis:
> 
> RDEPEND.suspect               1
>    media-video/kino/kino-1.3.3.ebuild: 'dev-util/intltool'

This is already fixed in 1.3.4, the attached patch is invalid

> and drop .la files.

Not a regression, but fixed anyway without revbump now

Arches, please go on
Comment 7 Tony Vroon gentoo-dev 2011-10-06 11:30:56 UTC
+  06 Oct 2011; Tony Vroon <chainsaw@gentoo.org> kino-1.3.4.ebuild:
+  Marked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo,
+  Elijah "Armageddon" El Lazkani & Ian "idella4" Delaney in bug #385361.
Comment 8 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-10-08 16:19:32 UTC
x86 stable
Comment 9 Denis Dupeyron gentoo-dev 2011-10-08 17:05:32 UTC
Samuli, thanks for committing the changes.

Ian, about the "doubling" of -O flag. Are you talking about -O2 and -Wl,-O1? If that's the case, the latter is for the linker not the compiler, and thus there's no doubling.

Denis.
Comment 10 Samuli Suominen gentoo-dev 2011-10-16 19:23:26 UTC
ppc/ppc64 stable. sparc dropped to ~sparc (how many users do you think sparc and kino has? :)