Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 384429 - dev-python/pyglet should depend on media-libs/libtxc_dxtn
Summary: dev-python/pyglet should depend on media-libs/libtxc_dxtn
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Justin Lecher
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-25 12:36 UTC by Arne Babenhauserheide
Modified: 2013-10-03 07:13 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arne Babenhauserheide 2011-09-25 12:36:44 UTC
pyglet should depend on media-libs/libtxc_dxtn to avoid 

Mesa warning: couldn't open libtxc_dxtn.so, software DXTn compression/decompression unavailable


Reproducible: Always
Comment 1 Arne Babenhauserheide 2011-09-26 04:39:36 UTC
maybe the dependency should be optional: 

http://dri.freedesktop.org/wiki/S3TC

“We cannot integrate and enable S3TC code by default due to the patents on the algorithm. Because of this, to be cautious, code was integrated to only attempt to open an external library, libtxc_dxtn.so, and use a small number of functions from that to implement S3TC if available.”
Comment 2 Justin Lecher gentoo-dev 2011-10-05 19:38:41 UTC
when does it happen? I cannot find any hint in the code.
Comment 3 Matt Turner gentoo-dev 2013-10-03 07:13:27 UTC
I disagree. If pyglet is what I understand it to be -- a python API that uses OpenGL -- it merely wraps functionality available in the GL driver. Whether your driver supports S3TC features may depend on whether this compression library is installed, but that doesn't mean that the pyglet wrapper depends on it.

If an application that uses pyglet needs S3TC, that's a different story.