Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 383731 - media-tv/xbmc-10.1 fails to build against media-libs/libpng-1.5.4
Summary: media-tv/xbmc-10.1 fails to build against media-libs/libpng-1.5.4
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Xbox herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-19 22:48 UTC by Martin von Gagern
Modified: 2011-09-20 15:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (media-tv:xbmc-10.1:20110919-223435.log.gz,79.50 KB, application/octet-stream)
2011-09-20 06:23 UTC, Martin von Gagern
Details
emerge --info (media-tv:xbmc-10.1.emerge--info,6.78 KB, text/plain)
2011-09-20 06:24 UTC, Martin von Gagern
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin von Gagern 2011-09-19 22:48:48 UTC
media-tv/xbmc-10.1 won't compile against media-libs/libpng-1.5.4:

../pngimage.cc: In member function ‘void PNG::load(FILE*, bool)’:
../pngimage.cc:39:2: error: ‘png_byte’ was not declared in this scope
../pngimage.cc:39:11: error: expected ‘;’ before ‘sig’
../pngimage.cc:40:23: error: ‘sig’ was not declared in this scope
../pngimage.cc:42:34: error: ‘png_sig_cmp’ was not declared in this scope
../pngimage.cc:45:2: error: ‘png_structp’ was not declared in this scope
../pngimage.cc:45:14: error: expected ‘;’ before ‘png’
../pngimage.cc:47:7: error: ‘png’ was not declared in this scope
../pngimage.cc:49:2: error: ‘png_infop’ was not declared in this scope
../pngimage.cc:49:12: error: expected ‘;’ before ‘pngInfo’
../pngimage.cc:50:7: error: ‘pngInfo’ was not declared in this scope
../pngimage.cc:54:7: error: ‘png’ was not declared in this scope
../pngimage.cc:54:7: error: ‘png_jmpbuf’ was not declared in this scope
../pngimage.cc:57:15: error: ‘png’ was not declared in this scope
../pngimage.cc:57:22: error: ‘png_init_io’ was not declared in this scope
../pngimage.cc:58:34: error: ‘png_set_sig_bytes’ was not declared in this scope
../pngimage.cc:60:22: error: ‘pngInfo’ was not declared in this scope
../pngimage.cc:60:29: error: ‘png_read_info’ was not declared in this scope
../pngimage.cc:62:38: error: ‘png_get_color_type’ was not declared in this scope
../pngimage.cc:62:43: error: ‘PNG_COLOR_TYPE_PALETTE’ was not declared in this scope
...
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-09-19 23:51:04 UTC

*** This bug has been marked as a duplicate of bug 380127 ***
Comment 2 Ian Stakenvicius (RETIRED) gentoo-dev 2011-09-20 01:53:43 UTC
Our previous patch didn't cover any file called pngimage.cc.

What were your USE flags when you attempted this installation?  Could you please post your emerge --info and your full build.log?

Thanks,
Comment 3 Ian Stakenvicius (RETIRED) gentoo-dev 2011-09-20 02:23:33 UTC
..removing the duplicate status; this is not (at least at first glance) a libpng-1.5 issue.  As far as I can tell all of the code in this section is compatible with libpng-1.5, however there is definitely a build system issue responsible for these errors -- it looks like png.h was not included properly?  Perhaps -I/usr/include/libpng15 is missing for some reason?

I have no issues compiling this section of code against libpng-1.4 or libpng-1.5 ... Also, the config.log in ${S}/xbmc/screensavers/rsxs-0.9 has proper entries for libpng-1.5 inside it.

(x86 stable with libpng-1.5 keyworded and libpng14.so.14 removed)

If someone can replicate this, I'd appreciate it.
Comment 4 SpanKY gentoo-dev 2011-09-20 04:23:03 UTC
you must post `emerge --info` with every bug report, as well as full build logs as attachments.  snippets isn't going to cut it.
Comment 5 Martin von Gagern 2011-09-20 06:23:46 UTC
Created attachment 287117 [details]
build log

Sorry, had to gzip this due to its size.
Comment 6 Martin von Gagern 2011-09-20 06:24:16 UTC
Created attachment 287119 [details]
emerge --info
Comment 7 Martin von Gagern 2011-09-20 07:02:06 UTC
(In reply to comment #3)
> there is definitely a build system issue responsible for these errors

Cannot reproduce this today. Looking at both my bash history and the build log, it seems I had CPPFLAGS='-DOF=_Z_OF' exported when I invoked that emerge. As bug #383179 comment #11 describes, that was intended as a work-around for recent zlib header modifications, affecting some other package in the same emerge run. Strange, that the error message doesn't mention this name, but I still guess that's the difference why the build succeeds today. Sorry for the noise. Feel free to resolve this INVALID or WORKSFORME unless someone else encounters the same.
Comment 8 Ian Stakenvicius (RETIRED) gentoo-dev 2011-09-20 15:26:19 UTC
Failure caused by non-standard CPPFLAGS; marking bug resolved/invalid.  Thanks for the extra info!  Hopefully nobody else will run into this issue.