Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 383721 - sci-biology/ncbi-tools++ fails with libpng15
Summary: sci-biology/ncbi-tools++ fails with libpng15
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Biology related packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-09-19 22:00 UTC by Justin Lecher
Modified: 2011-09-23 09:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
proposed patch (ncbi-tools++-2010.06.15-libpng15.patch,1.21 KB, patch)
2011-09-20 21:22 UTC, Markos Chandras (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher gentoo-dev 2011-09-19 22:00:53 UTC
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp: In function ‘void ncbi::s_PngWriteInit(png_struct*&, png_info*&, size_t, size_t, size_t, ncbi::CImageIO::ECompress)’:
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp:150:44: error: ‘Z_NO_COMPRESSION’ was not declared in this scope
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp:153:44: error: ‘Z_BEST_SPEED’ was not declared in this scope
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp:156:44: error: ‘Z_DEFAULT_COMPRESSION’ was not declared in this scope
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp:159:44: error: ‘Z_BEST_COMPRESSION’ was not declared in this scope
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp: In function ‘void ncbi::s_PngReadValidate(png_structp, png_infop, size_t&, size_t&, size_t&, size_t&, size_t&, size_t&, size_t&)’:
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp:180:28: error: invalid use of incomplete type ‘png_info {aka struct png_info_def}’
/usr/include/png.h:696:16: error: forward declaration of ‘png_info {aka struct png_info_def}’
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp:181:28: error: invalid use of incomplete type ‘png_info {aka struct png_info_def}’
/usr/include/png.h:696:16: error: forward declaration of ‘png_info {aka struct png_info_def}’
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp:182:28: error: invalid use of incomplete type ‘png_info {aka struct png_info_def}’
/usr/include/png.h:696:16: error: forward declaration of ‘png_info {aka struct png_info_def}’
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp:183:35: error: invalid use of incomplete type ‘png_info {aka struct png_info_def}’
/usr/include/png.h:696:16: error: forward declaration of ‘png_info {aka struct png_info_def}’
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/util/image/image_io_png.cpp:184:35: error: invalid use of incomplete type ‘png_info {aka struct png_info_def}’
/usr/include/png.h:696:16: error: forward declaration of ‘png_info {aka struct png_info_def}’
make[7]: *** [image_io_png.o] Error 1
make[7]: *** Waiting for unfinished jobs....
make[7]: Leaving directory `/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15


$ einfo ncbi-tools++
Portage 2.2.0_alpha59 (default/linux/amd64/10.0, gcc-4.6.1-asneeded, glibc-2.13-r4, 3.0.4-lh x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.0.4-lh-x86_64-Intel-R-_Core-TM-_i7_CPU_860_@_2.80GHz-with-gentoo-2.0.3
Timestamp of tree: Mon, 19 Sep 2011 05:30:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.5.4-r4, 2.6.7-r2, 2.7.2-r2, 3.1.4-r2, 3.2-r2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2::science
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.2.4-r1, 4.3.6-r1, 4.4.6-r1, 4.5.3-r1, 4.6.1-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1::last-hope
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise bicatali betagarden dummy Neurogeek-s-overlay science last-hope g-ctan
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ftracer -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 -mtune=corei7 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g -Wimplicit-function-declaration"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/eselect/ /usr/share/gnupg/qualified.txt /usr/share/nano/ /usr/share/openvpn/easy-rsa /var/lib/hsqldb /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -ftracer -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 -mtune=corei7 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g -Wenum-compare"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-t --jobs=12 --load-average=12 --keep-going --autounmask-write --autounmask"
FEATURES="assume-digests binpkg-logs buildsyspkg collision-protect distlocks ebuild-locks fixlafiles fixpackages metadata-transfer multilib-strict news noinfo parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms sign split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe -ftracer -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 -mtune=corei7 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g"
GENTOO_MIRRORS=" /mnt/tmpfs/ http://gentoo.j-schmitz.net/mirror/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common"
LINGUAS="en"
MAKEOPTS="-j16 -l12"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-z -e -9 -v"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/data/local/sunrise/reviewed /data/local/bicatali /data/local/betagarden /data/local/dummy /data/local/neurogeek /data/local/sci /data/local/lh/ebuilds /data/local/g-ctan"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit 7zip X acpi additions alsa amd64 arpwarp atlas bash-completion berkdb blas branding bzip2 c++ cairo caps cblas ccache cleartype cli command-args consolekit corefonts cracklib crypt cups cupsddk custom-optimization cxx dbus dri dts exif fbcondecor fortran gdbm gif glib glibc-omitfp gmp gnome gnome-keyring gpm graphics gstreamer gtk hddtemp iconv icu ios ipod iproute2 iptables ipv6 ipython javascript jpeg jpeg2k kqemu lapack largefile lcms ldap libnotify libsexy lm_sensors lzma mailtrain md5sum mmx mmxext mng modules mp3 mudflap multilib multiuser nagios-dns nagios-ntp nagios-ping nagios-ssh nano-syntax ncurses network-cron nis nls nptl nptlonly nsplugin objc objc++ opengl openmp openntpd pam pcre pdf perl png policykit pppd pymol python qt-static qt3support readline rrdcgi rrdtool science sensord session smp sqlite sqlite3 sse sse2 sse3 sse4 sse4a sse5 ssl startup-notification svg sysfs system-sqlite tcpd threads tiff truetype type1 udev unicode vaapi vdpau x264 xcb xcomposite xinerama xorg xulrunner zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sci-biology/ncbi-tools++-2010.06.15-r1 was built with the following:
USE="(multilib) sqlite -mysql"
CFLAGS="-O2 -pipe -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g -Wdisabled-optimization -Wimplicit-function-declaration"
CXXFLAGS="-O2 -pipe -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g -Wdisabled-optimization -Wenum-compare"
Comment 1 Justin Lecher gentoo-dev 2011-09-20 08:43:04 UTC
*** Bug 383789 has been marked as a duplicate of this bug. ***
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2011-09-20 21:22:24 UTC
Created attachment 287207 [details, diff]
proposed patch
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2011-09-23 09:44:15 UTC
+  23 Sep 2011; Lars Wendler <polynomial-c@gentoo.org>
+  ncbi-tools++-2010.06.15-r1.ebuild,
+  +files/ncbi-tools++-2010.06.15-libpng15.patch:
+  non-maintainer commit: Added a patch to fix compilation with libpng15 (bug
+  #383721).
+