Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 383077 - sys-apps/portage new feature: preserve old libs to keep binary working
Summary: sys-apps/portage new feature: preserve old libs to keep binary working
Status: RESOLVED DUPLICATE of bug 240323
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Enhancement/Feature Requests (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-15 11:57 UTC by Marcin Mirosław
Modified: 2011-09-19 09:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Mirosław 2011-09-15 11:57:24 UTC
This idea is taken from freebsd.
Short description: when we upgrade library dev-libs/foo and SONAME is changed all binaries(app-foo/bar) linked to them are broken. If they are using e.g. as CGI script our page immediately becomes broken.
I know revdep-rebuild is solution but this tool needs time to find broken binaries and emerge needs time to recompile app-foo/bar.
Maybe it could be worth to keep old libraries in e.g. /usr/backup/lib/ , add this path to LDPATH. app-foo/bar will still work and sysadmin would have time to recompile app-foo/bar agains new version of dev-libs/foo.
Revdep-rebuild should report binaries linked against lib placed in /usr/backup/lib as broken.
Maybe revdep-rebuild should create cache with such information then emerge could check if app-foo/bar was recompiled after upgrade of dev-libs/foo and display warning about it after emerging any package?
Maybe this idea(s) aren't good however it would be great to don't have downtime after upgrade of any libs.


Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2011-09-15 12:10:18 UTC
That feature has been around for over an year or so

*** This bug has been marked as a duplicate of bug 240323 ***
Comment 2 Samuli Suominen gentoo-dev 2011-09-15 12:13:19 UTC
Or duplicate of bug 337880, or one of the many others.
Comment 3 Mike Gilbert gentoo-dev 2011-09-16 02:27:27 UTC
In case you are confused Samuli's response: a similar feature to the one you describe (preserve-libs) has been implemented in portage-2.2. To install this version, add the following to package.keywords:

sys-apps/portage ~*
Comment 4 Marcin Mirosław 2011-09-16 10:19:17 UTC
I've found it:) I tried use portage-2.2 and functionality looks ok for me (in context of this bug). (i've have some problem when libs is downgraded @preserved-libs didn't preserve libs, but this i'll report in other bug. If it isn't reported earlier)
I can see portage-2.2 brings many new feature, it's great but portage-2.2 is too long masked. From my point of view it could be better to have lower number of features but more frequently.
Thanks.
Comment 5 Zac Medico gentoo-dev 2011-09-16 18:20:34 UTC
(In reply to comment #4)
> I can see portage-2.2 brings many new feature, it's great but portage-2.2 is
> too long masked. From my point of view it could be better to have lower number
> of features but more frequently.

All features that are considered stable are enabled in portage-2.1.10.x. The only difference between the portage-2.1.10 branch and the portage-2.2 branch is a few constants that enable/disable features:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=1a540597eecef10c2346b32fa9ceb8e688cc9f92
Comment 6 Marcin Mirosław 2011-09-19 09:44:16 UTC
Thanks for additional explanation!