Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 382227 - net-misc/openssh - openrc-0.9.x complains about opts variable in init script
Summary: net-misc/openssh - openrc-0.9.x complains about opts variable in init script
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 392069 (view as bug list)
Depends on:
Blocks: init.d-depr-opts
  Show dependency tree
 
Reported: 2011-09-08 04:51 UTC by Lars Wendler (Polynomial-C)
Modified: 2013-10-06 15:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sshd.rc6.3.diff (sshd.rc6.3.diff,462 bytes, patch)
2011-09-14 14:17 UTC, Lars Wendler (Polynomial-C)
Details | Diff
sshd.rc6.3.diff (sshd.rc6.3.diff,418 bytes, patch)
2011-09-14 20:46 UTC, Lars Wendler (Polynomial-C)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2011-09-08 04:51:09 UTC
# /etc/init.d/sshd restart
 * Caching service dependencies ...                               [ ok ]
 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Stopping sshd ...                                              [ ok ]
 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Starting sshd ...                                              [ ok ]
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2011-09-14 14:17:05 UTC
Created attachment 286435 [details, diff]
sshd.rc6.3.diff

possible fix.

I'd like to fix this in about a week with a revbump unless you guys fix it before.
Comment 2 SpanKY gentoo-dev 2011-09-14 15:36:54 UTC
do extra_commands and friends need to be appended ?  i would hope not.
Comment 3 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2011-09-14 15:42:05 UTC
(In reply to comment #2)
> do extra_commands and friends need to be appended ?  i would hope not.

No.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2011-09-14 20:46:17 UTC
Created attachment 286467 [details, diff]
sshd.rc6.3.diff

Okay, this should be a better fix then...
Comment 5 SpanKY gentoo-dev 2011-09-14 20:53:52 UTC
looks fine to me ... feel free to revbump after all your init.d changes have been merged
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2011-09-14 21:47:07 UTC
+*openssh-5.9_p1-r2 (14 Sep 2011)
+*openssh-5.8_p2-r1 (14 Sep 2011)
+
+  14 Sep 2011; Lars Wendler <polynomial-c@gentoo.org>
+  +openssh-5.8_p2-r1.ebuild, -openssh-5.9_p1-r1.ebuild,
+  +openssh-5.9_p1-r2.ebuild, files/sshd.rc6.3:
+  non-maintainer commit: Replaced deprecated opts variable (bug #382227) and
+  removed --stop option from reload function (bug #382975). Bot changes and
+  revbumps were done with kind permission from vapier.
+
Comment 7 SpanKY gentoo-dev 2011-11-29 19:16:57 UTC
*** Bug 392069 has been marked as a duplicate of this bug. ***