Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 381927 - app-i18n/libgooglepinyin (new ebuild)
Summary: app-i18n/libgooglepinyin (new ebuild)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2011-09-05 11:38 UTC by iGentoo
Modified: 2013-03-07 07:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
libgooglepinyin-0.1.0.ebuild (libgooglepinyin-0.1.0.ebuild,1.07 KB, text/plain)
2011-09-05 11:42 UTC, iGentoo
Details
libgooglepinyin-0.1.0-ldflags.patch (libgooglepinyin-0.1.0-ldflags.patch,649 bytes, patch)
2011-09-05 11:44 UTC, iGentoo
Details | Diff
libgooglepinyin-0.1.1.ebuild (libgooglepinyin-0.1.1.ebuild,875 bytes, text/plain)
2011-09-06 16:15 UTC, iGentoo
Details
libgooglepinyin-0.1.1-ldflags.patch (libgooglepinyin-0.1.1-ldflags.patch,520 bytes, patch)
2011-09-06 16:16 UTC, iGentoo
Details | Diff
ibus-googlepinyin-0.1.1.ebuild (ibus-googlepinyin-0.1.1.ebuild,572 bytes, text/plain)
2011-09-06 16:21 UTC, iGentoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description iGentoo 2011-09-05 11:38:31 UTC
libgooglepinyin is a fork from google pinyin on android.

Reproducible: Always
Comment 1 iGentoo 2011-09-05 11:42:07 UTC
Created attachment 285619 [details]
libgooglepinyin-0.1.0.ebuild

metadata.xml:

<flag name='opencc'>Enable support for Simplified-Traditional Chinese Conversion</flag>
Comment 2 iGentoo 2011-09-05 11:44:28 UTC
Created attachment 285621 [details, diff]
libgooglepinyin-0.1.0-ldflags.patch
Comment 3 iGentoo 2011-09-06 16:15:05 UTC
Created attachment 285705 [details]
libgooglepinyin-0.1.1.ebuild
Comment 4 iGentoo 2011-09-06 16:16:07 UTC
Created attachment 285707 [details, diff]
libgooglepinyin-0.1.1-ldflags.patch
Comment 5 iGentoo 2011-09-06 16:21:11 UTC
Created attachment 285709 [details]
ibus-googlepinyin-0.1.1.ebuild
Comment 6 Yixun Lan gentoo-dev 2013-03-07 02:41:41 UTC
I'd suggest we close this bug.
libgooglepinyin is abandoned by upstream. and the original author suggest to use libpinyin or sunpinyin

Quote: 
As this project starter (wengxt), I'm not interested in adding any new feature to this library. Since it would be only kind of re-inventing wheel against sunpinyin or libpinyin.

This project is only forked from out dated code of Google Pinyin on Android (Not the desktop version), and Google no longer provides up to date code for it since 2009.

If you are interested in full featured pinyin input method, please try libpinyin or sunpinyin, they are both supported by fcitx and ibus. They use more advanced algorithm (2-gram vs this project's unigram) and support more feature, like Shuangpin, Zhuyin, Fuzzy Pinyin and so on. Thank you. 


more info:
http://code.google.com/p/libgooglepinyin/
Comment 7 Sergey Popov gentoo-dev 2013-03-07 07:57:32 UTC
(In reply to comment #6)
> I'd suggest we close this bug.
> libgooglepinyin is abandoned by upstream. and the original author suggest to
> use libpinyin or sunpinyin
> ....

Ok, closed as OBSOLETE