Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 381123 - x11-drivers/xf86-video-intel[sna] CPU load very high when remotely connecting to a local X-Server using xorg-module from net-misc/tigervnc-p20110618-r11.0.1
Summary: x11-drivers/xf86-video-intel[sna] CPU load very high when remotely connecting...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Raúl Porcel (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-30 06:57 UTC by Gerhard Hintermayer
Modified: 2014-09-20 11:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Hintermayer 2011-08-30 06:57:58 UTC
I have a local X-Server with x11-drivers/xf86-video-intel-2.16.0 and x11-drivers/xf86-input-evdev-2.6.0, configured to use the xorgmodule from tigervnc.
When I remotely connect to the X-Server, the CPU usage of the X-Server process (X) goes to nearly 100% and I get a very poor performance when working remotely.
When closing the remote connection and working locally the cpu usage returns to normal values.

Reproducible: Always

Steps to Reproduce:
1. start  a local X-session
2. tigervnc to this Display
3. watch cpu load
Actual Results:  
CPU load high, bad performance

Expected Results:  
normal CPU usage, nearly the same performance as when working locally (at least when connected directly within the  same subnet)
Comment 1 Gerhard Hintermayer 2011-08-30 07:20:03 UTC
maybe this is already addressed in tigervnc-1.1, but unfortunately there's no ebuild for it yet :-(
Comment 2 Raúl Porcel (RETIRED) gentoo-dev 2011-11-19 17:44:12 UTC
There it is now(In reply to comment #1)
> maybe this is already addressed in tigervnc-1.1, but unfortunately there's no
> ebuild for it yet :-(

There it is
Comment 3 Gerhard Hintermayer 2011-11-21 10:41:04 UTC
(In reply to comment #2)
> There it is now(In reply to comment #1)
> > maybe this is already addressed in tigervnc-1.1, but unfortunately there's no
> > ebuild for it yet :-(
> 
> There it is

... your're right, but unfortunately I still do have high CPU Usage :-( But I do see some improvement, CPU usage is at about 50% max. Better than before, but still not optimal.

Gerhard
Comment 4 Gerhard Hintermayer 2011-11-21 16:40:46 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > There it is now(In reply to comment #1)
> > > maybe this is already addressed in tigervnc-1.1, but unfortunately there's no
> > > ebuild for it yet :-(
> > 
> > There it is
> 
> ... your're right, but unfortunately I still do have high CPU Usage :-( But I
> do see some improvement, CPU usage is at about 50% max. Better than before, but
> still not optimal.
> 
> Gerhard

I did some testing and discovered, that the load decrease is due to sna useflag  introduced in recent versions of xf86-video-intel and _not_ due to some changes in tigervnc.
Comment 5 Raúl Porcel (RETIRED) gentoo-dev 2012-09-16 18:15:27 UTC
@x11?
Comment 6 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-09-16 18:38:48 UTC
I don't know why this happens. Perhaps some profiling and reporting the results upstream would be good.
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2014-09-20 11:23:55 UTC
Reopen if still happens with recent versions