Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 379979 - sci-misc/boinc - no menu buttons in boincmgr with x11-libs/wxGTK-
Summary: sci-misc/boinc - no menu buttons in boincmgr with x11-libs/wxGTK-
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
Depends on:
Reported: 2011-08-20 15:35 UTC by Toralf Förster
Modified: 2013-06-30 14:56 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

screen shot (screenshot.jpeg,38.09 KB, image/jpeg)
2012-02-17 14:13 UTC, Toralf Förster
patch to force recalculation of menu bar (wxwidgets-,511 bytes, patch)
2012-05-20 01:34 UTC, trogdog
Details | Diff
ebuild patch (boinc.6.12.42.ebuild.patch,340 bytes, patch)
2012-05-20 01:39 UTC, trogdog
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2011-08-20 15:35:03 UTC
Only the "F" is visible of the "File" button, "View", "Tools", "Activity" and all others are completely invisible.

Reproducible: Always

n22 ~ # emerge --info x11-libs/wxGTK
Portage (default/linux/x86/10.0/desktop/kde, gcc-4.4.5, glibc-2.12.2-r0, 3.0.3 i686)
                        System Settings
System uname: Linux-3.0.3-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.0.3
Timestamp of tree: Sat, 20 Aug 2011 09:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo toralf
CFLAGS="-O2 -march=native -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
FEATURES="assume-digests binpkg-logs ccache compress-build-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdda cdr classic cli consolekit cracklib crypt css cups cxx dbus declarative dri dts dvb dvd dvdr emboss encode exif fam fastbuild fat ffmpeg firefox flac fortran gdbm gdu gif git gmp gphoto2 gpm gtk hyphenation iconv ipv6 java jpeg kde kipi kqemu kvm lastfm lcms ldap libnotify logrotate mad mbox mmx mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses nls nptl nptlonly nsplugin ntfs ogg opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pppd python qt3support qt4 rdesktop readline sdl semantic-desktop session sieve spell sse sse2 sse3 ssl ssse3 startup-notification svg sysfs tcpd test thinkpad tiff tk truetype udev unicode usb vaapi vim-syntax vnc vorbis wmf x264 x86 xcb xcomposite xinerama xml xorg xpm xscreensaver xulrunner xv xvfb xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump active" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" LIRC_DEVICES="devinput inputlirc" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 

                        Package Settings

x11-libs/wxGTK- was built with the following:
USE="X (consolekit) opengl (policykit) sdl test tiff -debug -doc -gnome -gstreamer -odbc -pch"
CFLAGS="-O2 -march=native -pipe -fno-strict-aliasing"
CXXFLAGS="-O2 -march=native -pipe -fno-strict-aliasing"
Comment 1 Toralf Förster gentoo-dev 2012-02-17 14:13:36 UTC
Created attachment 302265 [details]
screen shot
Comment 2 Toralf Förster gentoo-dev 2012-02-19 10:24:13 UTC
Because it might be rather related to the x11-libs package I added them too.
Comment 3 trogdog 2012-03-04 05:03:29 UTC
Try resizing the BM window as a workaround, came across that tip in the redhat bugzilla
Comment 4 Toralf Förster gentoo-dev 2012-03-04 09:05:21 UTC
(In reply to comment #3)
> Try resizing the BM window as a workaround, came across that tip in the
> redhat bugzilla
great - works
Comment 5 trogdog 2012-04-02 15:11:15 UTC
Recompiling against wxGTK - solves this.

Don't know if this is the proper change that should be applied to the ebuild but modding the wxGTK dependency fixes the missing menus.

< 		x11-libs/wxGTK:2.8[X,opengl]
> 		<=x11-libs/wxGTK-[X,opengl]
Comment 6 trogdog 2012-05-20 01:34:37 UTC
Created attachment 312313 [details, diff]
patch to force recalculation of menu bar

Patch from user huib at boinc forums to force a recalculation of menu bar
Comment 7 trogdog 2012-05-20 01:39:39 UTC
Created attachment 312315 [details, diff]
ebuild patch

Patched ebuild to use 312313
Comment 8 Toralf Förster gentoo-dev 2012-05-20 09:16:54 UTC
I tested a similar patchhere at my system - works fine.
Comment 9 Toralf Förster gentoo-dev 2013-01-27 10:34:41 UTC
upstream is informed and knows about the wxGTK issue
Comment 10 Justin Lecher (RETIRED) gentoo-dev 2013-01-27 12:17:25 UTC
Why are you closing bugs? Is this issue resolved for gentoo?
Comment 11 Toralf Förster gentoo-dev 2013-01-27 14:30:33 UTC
(In reply to comment #10)
> Why are you closing bugs? Is this issue resolved for gentoo?

this issue was solved w/ the given patch of comment #8 and is solved upstream with current (alpha) version.
Comment 12 Justin Lecher (RETIRED) gentoo-dev 2013-01-27 14:38:54 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > Why are you closing bugs? Is this issue resolved for gentoo?
> this issue was solved w/ the given patch of comment #8 and is solved
> upstream with current (alpha) version.

But we are not upstreams bug tracker. The patch wasn't included in any gentoo package and therefor this bug is still present here.
Comment 13 Justin Lecher (RETIRED) gentoo-dev 2013-06-30 14:56:15 UTC
+*boinc-7.2.0 (30 Jun 2013)
+  30 Jun 2013; Justin Lecher <> -boinc-7.0.29.ebuild,
+  +boinc-7.2.0.ebuild, -files/7.0.2-fix_subdirs.patch,
+  +files/boinc-7.2.0-fix_subdirs.patch, files/boinc.init,
+  files/, metadata.xml:
+  Version bump and drop old, fixes: security issue, #467908; link problems,
+  #464772; correlation with abrupt time changes through ntp, #413041; menu
+  items with newer x11-libs/wxGTK, #379979 & #376237