Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 379837 - sys-libs/tdb and sys-libs/talloc FEATURES=distcc - configure checks sometimes fail
Summary: sys-libs/tdb and sys-libs/talloc FEATURES=distcc - configure checks sometimes...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
: 406187 445120 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-19 07:41 UTC by Igor Novgorodov
Modified: 2015-03-18 09:48 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sys-libs/tdb build log (tdb-build.log,22.88 KB, text/plain)
2011-08-19 11:43 UTC, Igor Novgorodov
Details
emerge --info (emerge-info.txt,4.25 KB, text/plain)
2011-08-19 11:44 UTC, Igor Novgorodov
Details
Successful talloc build with distcc (build.log,28.24 KB, text/plain)
2011-08-19 14:18 UTC, Nikolaj Šujskij
Details
Successful tdb build with distcc (build.log,28.29 KB, text/plain)
2011-08-19 14:19 UTC, Nikolaj Šujskij
Details
Patch to show configure failure (cjb-debug.patch,478 bytes, patch)
2012-05-04 04:14 UTC, Chris Bandy
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Novgorodov 2011-08-19 07:41:06 UTC
Building these packages when DISTCC is used fails with:
[code]
Build failed:
[Errno 2] No such file or directory: '/var/tmp/portage/sys-libs/talloc-2.0.5/work/talloc-2.0.5/bin/default/lib/replace/snprintf_2.d'
[Errno 2] No such file or directory: '/var/tmp/portage/sys-libs/talloc-2.0.5/work/talloc-2.0.5/bin/default/lib/replace/getpass_2.d'
[/code]

sys-libs/tdb-1.2.9
sys-libs/talloc-2.0.5


Reproducible: Always
Comment 1 Andreis Vinogradovs ( slepnoga ) 2011-08-19 11:26:31 UTC
Please attach build.log and emerge --info
Comment 2 Igor Novgorodov 2011-08-19 11:43:16 UTC
Created attachment 283893 [details]
sys-libs/tdb build log
Comment 3 Igor Novgorodov 2011-08-19 11:44:01 UTC
Created attachment 283895 [details]
emerge --info
Comment 4 Nikolaj Šujskij 2011-08-19 14:17:27 UTC
Cannot confirm (see my logs attached).
Comment 5 Nikolaj Šujskij 2011-08-19 14:18:31 UTC
Created attachment 283915 [details]
Successful talloc build with distcc
Comment 6 Nikolaj Šujskij 2011-08-19 14:19:25 UTC
Created attachment 283919 [details]
Successful tdb build with distcc
Comment 7 Víctor Ostorga (RETIRED) gentoo-dev 2011-08-19 15:58:09 UTC
This have caught my eye in the failing build log:

Checking for building library support    : not found
Comment 8 Chris Bandy 2012-05-04 04:14:09 UTC
Created attachment 310735 [details, diff]
Patch to show configure failure

Fails to build for me also. I used this small patch to find out why configure prints

Checking for building library support    : not found

The answer is,

[Errno 2] No such file or directory: '/var/tmp/portage/sys-libs/tdb-1.2.9/work/tdb-1.2.9/bin/.conf_check_0/testbuild/default/main_2.d'

Even with this patch, disabling distcc allows it to build:

FEATURES="-distcc" emerge -1 tdb
...
Checking for building library support    : ok  
Checking for rpath library support       : ok  
Checking for -Wl,--version-script support  : ok
Comment 9 Marek Bartosiewicz 2012-06-05 12:41:04 UTC
I can also confirm this problem.
Comment 10 Francesco Riosa 2012-06-28 23:35:37 UTC


the problem probably arise when the first host in DISTCC_HOSTS is NOT localhost



neither stable tdb-1.2.9 nor tdb-1.2.10 install any shared library
when build with distcc, because of a failing chech @ configure time

Checking for building library support    : not found

setting MAKEOPTS=-j1 does not suffice FEATURES=-distcc is needed

FYI the check is inside
buildtools/wafsamba/samba_conftests.py
def CHECK_LIBRARY_SUPPORT(conf, rpath=False, version_script=False, msg=None):
bld.compile()
except with a file not found


Portage 2.2.0_alpha111 (default/linux/amd64/10.0, gcc-4.6.3,
glibc-2.15-r2, 3.4.1-vs2.3.3.4 x86_64)
=================================================================
System uname: 
Linux-3.4.1-vs2.3.3.4-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Sun, 24 Jun 2012 19:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2, 4.6.3, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo vivovl mysql
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=corei7-avx -pipe -frecord-gcc-switches -mno-movbe
-mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm
--param l1-cache-size=32 --param l1-cache-line-size=64 --param
l2-cache-size=8192 -mtune=corei7-avx -fgcse-after-reload
-fpredictive-commoning -ftree-vectorize -funswitch-loops
-fgraphite-identity -floop-block -floop-interchange -floop-strip-mine
-ggdb -gdwarf-4 -fvar-tracking-assignments"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt
/usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d
/etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release
/etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/
/etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d
/etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d
/etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=corei7-avx -pipe -frecord-gcc-switches -mno-movbe
-mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm
--param l1-cache-size=32 --param l1-cache-line-size=64 --param
l2-cache-size=8192 -mtune=corei7-avx -fgcse-after-reload
-fpredictive-commoning -ftree-vectorize -funswitch-loops
-fgraphite-identity -floop-block -floop-interchange -floop-strip-mine
-ggdb -gdwarf-4 -fvar-tracking-assignments
-fvisibility-inlines-hidden"
DISTDIR="/g/distfiles"
EMERGE_DEFAULT_OPTS="--ask-enter-invalid --quiet-build=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg compress-build-logs
compressdebug config-protect-if-modified distcc distlocks ebuild-locks
fail-clean fixlafiles installsources metadata-transfer news noinfo
notitles parallel-fetch parallel-install parse-eapi-ebuild-head
sandbox sfperms splitdebug strict test-fail-continue
unknown-features-warn unmerge-logs unmerge-orphans xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/
http://mirror.ovh.net/gentoo-distfiles/
http://mirror.switch.ch/ftp/mirror/gentoo/ http://gentoo.lagis.at/
http://mirror.qubenet.net/mirror/gentoo/";
INSTALL_MASK="/usr/lib64/libogrove.la /usr/lib64/libospgrove.la
/usr/lib64/libostyle.la
/usr/lib64/vlc/plugins/codec/libdirac_plugin.la
/usr/lib64/vlc/plugins/demux/libdirac_plugin.la /bin/systemd
/bin/systemctl /usr/lib64/elektra/libelektra-filesys.la
/usr/lib64/elektra/libelektra-hosts.la
/usr/lib64/elektra/libelektra-ini.la
/usr/lib64/elektra/libelektra-passwd.la /usr/lib64/libelektra-cpp.la
/usr/lib64/libelektra.la /usr/lib64/libelektratools.la "
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu
-Wl,--as-needed -Wl,--sort-common -Wl,--no-copy-dt-needed-entries
-Wl,--build-id "
LINGUAS="it"
MAKEOPTS="-j36"
PKGDIR="/g/packages"
PORTAGE_COMPRESS="lzma"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times
--compress --force --whole-file --delete --stats --human-readable
--timeout=180 --exclude=/distfiles --exclude=/local
--exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/g/portage"
PORTDIR_OVERLAY="/g/ovl/tmp /g/ovl/mysql"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl amd64 avx berkdb bzip2 caps cli cracklib crypt cups cxx dbus
dri fortran gdbm gpm iconv ipv6 modules mudflap multilib ncurses nls
nptl opencl opengl openmp pam pcre pppd qt3support readline
semantic-desktop session sse sse2 sse3 sse4_1 ssl ssse3 static-libs
svg tcpd unicode xattr xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp
atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938
es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio
via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy
dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa
lfloat linear meter mmap_emul mulaw multi null plug rate route share
shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest
authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm
authz_default authz_groupfile authz_host authz_owner authz_user
autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env
expires ext_filter file_cache filter headers ident imagemap include
info log_config
logio mem_cache mime mime_magic negotiation proxy proxy_ajp
proxy_balancer proxy_connect proxy_http rewrite setenvif so speling
status unique_id userdir usertrack vhost_alias reqtimeout"
APACHE2_MPMS="event" CALLIGRA_FEATURES="kexi words flow plan sheets
stage tables krita karbon braindump" CAMERAS="ptp2 directory canon"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
DRACUT_MODULES="bootchart btrfs mdraid syslog uswsusp biosdevname
caps" ELIBC="glibc" FFTOOLS="aviocat cws2fws ffeval ismindex pktdumper
qt-faststart trasher" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore
fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom
oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing
tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard
mouse evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633
glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer"
LINGUAS="it" PHP_TARGETS="php5-4" PYTHON_
TARGETS="pypy1_9 python2_7" QEMU_SOFTMMU_TARGETS="arm x86_64"
QEMU_USER_TARGETS="arm x86_64" RUBY_TARGETS="ruby18 ruby19"
SANE_BACKENDS="hp4200 net ricoh" USERLAND="GNU" VIDEO_CARDS="nouveau
radeon r300 r600 r700 r800 intel modesetting" XTABLES_ADDONS="quota2
psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy
condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude
chaos account"
Unset:  CPPFLAGS, CTARGET, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND,
PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 11 Jeroen Roovers gentoo-dev 2012-07-07 16:58:34 UTC
Sometimes it fails, sometimes it does not.
Comment 12 Joe Breuer 2013-06-03 11:49:40 UTC
I ran into this bug when upgrading tdb and talloc (with both packages, on 3 different machines).

The first host in DISTCC_HOSTS is localhost.

Suspecting a transient parallel build problem, I first tried to rebuild without any changes; I still got this bug on all machines.


I successfully built both tdb and talloc on all affected machines (and on the first attempt) by disabling parallel make, but without disabling distcc:
  MAKEOPTS="-j1" emerge -bavt -1 -j1 tdb talloc

(This was before I found this bug report.)
Comment 13 Sergey Popov gentoo-dev 2013-06-04 03:41:52 UTC
*** Bug 406187 has been marked as a duplicate of this bug. ***
Comment 14 Sergey Popov gentoo-dev 2013-06-04 03:42:08 UTC
*** Bug 445120 has been marked as a duplicate of this bug. ***
Comment 15 Alexander Tsoy 2015-02-15 15:41:03 UTC
Same problem with sys-libs/tevent
Comment 16 Lee Trager 2015-03-18 07:28:53 UTC
I've confirmed I can build this with FEATURES="-distcc". Is there any reason not to add export DISTCC_DISABLE=1 in pkg_setup, like the nvidia-driver?
Comment 17 Igor Novgorodov 2015-03-18 07:32:30 UTC
Oh, I like these 5-year old bugs. I've stopped using Gentoo awhile ago, and i still get mail for my bugs :) Anyone wants a bet when it'll get fixed?
Comment 18 Sergey Popov gentoo-dev 2015-03-18 09:48:40 UTC
Both current stable and unstable sys-libs/tdb and sys-libs/talloc build fine with distcc. They does not use it, but build succeeds.

Closing as OBSOLETE