Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 379383 - dev-perl/Unicode-Map8-0.13 fails
Summary: dev-perl/Unicode-Map8-0.13 fails
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Highest normal (vote)
Assignee: Gentoo Perl team
: 381235 (view as bug list)
Depends on:
Blocks: ExtUtils-ParseXS-3
  Show dependency tree
Reported: 2011-08-16 11:33 UTC by Dirk Gouders
Modified: 2011-08-31 02:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info (emerge_info,4.11 KB, text/plain)
2011-08-16 11:33 UTC, Dirk Gouders

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Gouders 2011-08-16 11:33:25 UTC
Created attachment 283541 [details]
emerge --info

I habe problems to build dev-perl/Unicode-Map8-0.13:

cp Map8/maps/ISO_8859-13.bin blib/lib/Unicode/Map8/maps/ISO_8859-13.bin
/usr/bin/perl5.12.4 /usr/lib64/perl5/vendor_perl/5.12.4/ExtUtils/xsubpp  -typemap /usr/lib64/perl5/5.12.4/ExtUtils/typemap -typemap typemap  Map8.xs > Map8.xsc && mv Map8.xsc Map8.c
Could not find a typemap for C type 'U16*' in Map8.xs, line 229

I tried perl-cleaner with --all and --allmodules but that did not help.
Comment 1 Dirk Gouders 2011-08-22 11:10:43 UTC
I want to add some information:

On a machine also with perl-5.12.4 installed, everything went fine,
but I noticed that "/usr/lib64/perl5/vendor_perl/5.12.2/ExtUtils/xsubpp"
was used to build Unicode-Map8.

After I ran `perl-cleaner --modules' on that machine, "/usr/lib64/perl5/vendor_perl/5.12.4/ExtUtils/xsubpp" is used and I cannot build
Unicode-Map8 on that machine, as well.
Comment 2 Dirk Gouders 2011-08-22 12:46:02 UTC
On the machine where I first noticed the problem, I downgraded to
perl-5.12.3-r1 and with that version Unicode-Map8 can be
installed without problems.
Comment 3 Torsten Veller (RETIRED) gentoo-dev 2011-08-25 13:11:33 UTC
Fixed by perl-core/ExtUtils-ParseXS-3.40.0
Comment 4 Torsten Veller (RETIRED) gentoo-dev 2011-08-31 02:18:57 UTC
*** Bug 381235 has been marked as a duplicate of this bug. ***