Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378765 - gnome-base/gdm-2.20.11 won't start with ati-drivers due unproper GdmXserverTimeout default
Summary: gnome-base/gdm-2.20.11 won't start with ati-drivers due unproper GdmXserverTi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-11 12:25 UTC by Enrique Domínguez
Modified: 2011-09-11 22:27 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xdm success start with another instance of X running in :1 vt8 (Xorg-success-.0.log,36.38 KB, text/plain)
2011-08-13 18:21 UTC, Enrique Domínguez
Details
xdm failed without any instance of X running (Xorg-failed-.0.log,35.23 KB, text/plain)
2011-08-13 18:22 UTC, Enrique Domínguez
Details
startx as user (as usual) (Xorg-success-startxasuser-.0.log,35.46 KB, text/plain)
2011-08-13 18:22 UTC, Enrique Domínguez
Details
dmesg when gdm start (two X instances) (dmesg-success_twoXservers.log,39.34 KB, text/plain)
2011-08-17 00:51 UTC, Enrique Domínguez
Details
dmesg when gdm failed (dmesg-failed.log,38.43 KB, text/plain)
2011-08-17 00:52 UTC, Enrique Domínguez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Enrique Domínguez 2011-08-11 12:25:29 UTC
Starting gdm via '/etc/init.d/xdm start' fails if there isn't a currently running Xserver in another vt (I'm using vt8 for X) It's a fresh install.
I have changed xorg.conf for several resolutions without success.

Reproducible: Always

Steps to Reproduce:
1. Fresh install gnome-light
2. run xdm via rc-update or logged in console
3. gdm start X for three times and, finally, X reporting a crash

Actual Results:  
X crashing

Expected Results:  
gdm loggin window started

for get it working (workaround)
1. start X in another vt: X :1 vt8
2. start xdm as usual
3. gdm starts well

I'm using ati-drivers in a notebook. startx works well.

Portage 2.1.10.3 (default/linux/amd64/10.0/no-multilib, gcc-4.5.2, glibc-2.12.2-r0, 2.6.39-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.39-gentoo-r2-x86_64-AMD_E-350_Processor-with-gentoo-2.0.3
Timestamp of tree: Tue, 02 Aug 2011 09:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 2.4 [enabled]
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.5.2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=amdfam10 -pipe -mmmx -msse -msse2 -mssse3 -msse4a -mabm -mcx16 -mpopcnt"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=amdfam10 -pipe -mmmx -msse -msse2 -mssse3 -msse4a -mabm -mcx16 -mpopcnt"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--load-average=4 -j"
FEATURES="assume-digests binpkg-logs ccache collision-protect distcc distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo "
LANG="en_US.iso88591"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 apic berkdb bzip2 cli cracklib crypt cxx dbus eds fortran gdbm gnome gpm gtk iconv jpeg libnotify loop-aes mmx mmxext modules mudflap nautilus ncurses nptl nptlonly opengl openmp pcre perl pppd python readline session sse sse2 sse3 sse4a ssl ssse3 sysfs tcpd threads unicode vaapi xorg zlib" ALSA_CARDS="hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-08-11 13:45:02 UTC
This bug cannot be diagnosed without additional information. Please attach /var/log/Xorg.0.log files that are generated when:
1. gdm fails to start
2. gdm starts successfully
3. startx starts successfully.

Also, please attach dmesg output.
Comment 2 Enrique Domínguez 2011-08-13 18:21:17 UTC
Created attachment 283227 [details]
xdm success start with another instance of X running in :1 vt8
Comment 3 Enrique Domínguez 2011-08-13 18:22:09 UTC
Created attachment 283229 [details]
xdm failed without any instance of X running
Comment 4 Enrique Domínguez 2011-08-13 18:22:38 UTC
Created attachment 283231 [details]
startx as user (as usual)
Comment 5 Enrique Domínguez 2011-08-13 18:23:57 UTC
Sure! Please feel free requesting all you need; I would like to find one solution for this annoying behavior.
I have attached Xorg.0.log in those three cases. I haven't got this notebook here, so I attaching dmesg later.

I couldn't find any significant error (is not first time I setting up gnome)
in success xdm: fglrx(0): PPLIB: PP_Initialize() failed.
while in failed and startx: fglrx(0): Unable to register ADL handler for 0x00C00000

No idea at all. Thanks for replies.
Comment 6 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-08-13 19:02:52 UTC
I can't see anything in the logs that would explain why startx works for you and gdm doesn't.

I am CCing the x11 herd in the hope that they might be able to help.
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2011-08-13 20:18:49 UTC
The main difference seems to be:

- (EE) fglrx(0): PPLIB: PP_Initialize() failed.
+ (WW) fglrx(0): Unable to register ADL handler for 0x00C00000

And then differences in addresses, EDID...

I'd say it's because the other X instance has locked the gfx card and a few things failed.

But what is happening, I really don't know. Maybe a log of the failing pre-last X restart would be useful. I guess that would be Xorg.0.log.old after failing gdm start.
Comment 8 Enrique Domínguez 2011-08-17 00:49:05 UTC
Thanks for replies, It's true, nothing in log is useful for finding trouble :S
diff between xdm start and xdm start with another instance of X was:
<  (==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 16 14:02:08 2011
---
>  (==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 16 13:58:44 2011
246c246
<  (WW) fglrx(0): Unable to register ADL handler for 0x00C00000
---
>  (EE) fglrx(0): PPLIB: PP_Initialize() failed.
384c384
<  (II) fglrx(0): FBADPhys: 0xf00000000 FBMappedSize: 0x009c4000
---
>  (II) fglrx(0): FBADPhys: 0xf01040000 FBMappedSize: 0x009c4000
407c407
<  (II) fglrx(0): X context handle = 0x1
---
>  (II) fglrx(0): X context handle = 0x3
562,581c562,567
<  (II) Power Button: Close
<  (II) UnloadModule: "evdev"
<  (II) Unloading evdev
<  (II) Power Button: Close
<  (II) UnloadModule: "evdev"
<  (II) Unloading evdev
<  (II) Sleep Button: Close
<  (II) UnloadModule: "evdev"
<  (II) Unloading evdev
<  (II) Genius Optical Mouse: Close
<  (II) UnloadModule: "evdev"
<  (II) Unloading evdev
<  (II) AT Translated Set 2 keyboard: Close
<  (II) UnloadModule: "evdev"
<  (II) Unloading evdev
<  (II) fglrx(0): Shutdown CMMQS
<  (II) fglrx(0): [uki] removed 1 reserved context for kernel
<  (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x81000 at 0x7fb90e29d000
<  (II) fglrx(0): Interrupt handler Shutdown.
<  (II) fglrx(0): Interrupt handler Shutdown.
---
>  (II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments
>  (II) AIGLX: Suspending AIGLX clients for VT switch
>  (II) fglrx(0): Backup framebuffer data.
>  (II) fglrx(0): Backup complete.
>  (II) fglrx(0): Backup framebuffer data.
>  (II) fglrx(0): Backup complete.

Hi Michał, there is no difference between Xorg.0.log and Xorg.0.log.old when xdm fails to start.

I have seen another strange behavior, if xdm service was started and I recompile gdm, when compiling was ended, gdm greeter is showed without restarting services at all.

I have done 'emerge -e world' but nothing helped. Thanks a lot for replies and sorry for my delay answering.
Comment 9 Enrique Domínguez 2011-08-17 00:51:51 UTC
Created attachment 283617 [details]
dmesg when gdm start (two X instances)
Comment 10 Enrique Domínguez 2011-08-17 00:52:12 UTC
Created attachment 283619 [details]
dmesg when gdm failed
Comment 11 Pacho Ramos gentoo-dev 2011-08-28 09:06:27 UTC
What gdm version are you using? Does "gdm" command work ok when manually running it instead of /etc/init.d/xdm? Have you tried with other display managers like "xdm" or "kdm"?

dmesg output shows some problems probably related with ati-drivers, what version of them are you using?
Comment 12 Enrico Tagliavini 2011-08-28 10:49:51 UTC
To be honest i don't see something wrong with ati-drivers, but it might be worth to try ati-drivers-11.8. Version 11.7 and 11.8 got a lot of fixes, so trying them is worth.
Comment 13 Gilles Dartiguelongue gentoo-dev 2011-08-29 21:37:00 UTC
Unles your chipset is not supported, I stronly suggest running with xf86-video-radeon.
Comment 14 Enrico Tagliavini 2011-08-30 07:33:13 UTC
(In reply to comment #13)
> Unles your chipset is not supported, I stronly suggest running with
> xf86-video-radeon.

Disclaimer: this is not a flame war or something :)

I don't agree. It is true fglrx is a bit more problematic then radeon, but it has many advantages, like 3d performance, really better powersave and better new hardware support. Nevertheless a test run with radeon is worth to understand if fglrx is the really bad component here (and from what i read there is no hint it is).

Btw does gdm have some log? It might have some additional information.
Comment 15 Pacho Ramos gentoo-dev 2011-08-30 08:33:42 UTC
Under /var/log/gdm you have logs for X when started with gdm
Comment 16 Enrique Domínguez 2011-08-30 18:05:47 UTC
I have read /usr/share/gdm/defaults.conf and found "# How long gdm should wait before it assumes a started Xserver is defunct and
# kills it.  10 seconds should be long enough for X, but Xgl may need 20 or 25.
GdmXserverTimeout=10" so I set /etc/X11/gdm/custom.conf in [daemon] like this,
GdmXserverTimeout=25
and all worked finally (first time I having to touch there)

Thanks all for replies. For reference:
gnome-base/gdm-2.20.11
x11-drivers/ati-drivers-11.6

Others display manager does work nice (I have tried slim) but logs (debug included) won't help me.
Comment 17 Pacho Ramos gentoo-dev 2011-08-30 19:02:57 UTC
We should probably increase default timeout value then as it shouldn't hurt other setups and I guess you are not using Xgl (that is pretty dead)
Comment 18 Enrique Domínguez 2011-09-04 09:38:28 UTC
(In reply to comment #17)
> We should probably increase default timeout value then as it shouldn't hurt
> other setups and I guess you are not using Xgl (that is pretty dead)

Sure, I'm not using Xgl. No idea, maybe installing a file for committing with dispatch-conf when people installing ati-drivers?
I have worked with a lot of drivers and never have had to change such param :S
Comment 19 Pacho Ramos gentoo-dev 2011-09-11 22:27:14 UTC
+*gdm-2.20.11-r1 (11 Sep 2011)
+
+  11 Sep 2011; Pacho Ramos <pacho@gentoo.org> +gdm-2.20.11-r1.ebuild:
+  Wait more before assuming Xserver is defunct (bug #378765 by Enrique
+  Domínguez), this change also solves a problem I was suffering for ages where
+  gdm had problems to restart on systems under heavy load. Also drop .la files
+  (bug #362961 by Stéphane Pagnon).
+