Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378745 - CD/LIVEDVD: keymap selection ignored on boot
Summary: CD/LIVEDVD: keymap selection ignored on boot
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: InstallCD (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
: 378425 379757 382037 383797 383903 (view as bug list)
Depends on: 370205
Blocks:
  Show dependency tree
 
Reported: 2011-08-11 08:54 UTC by Toralf Förster
Modified: 2012-05-06 23:07 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2011-08-11 08:54:29 UTC
If I boot the install-x86-minimal-20110809.iso in a virtual machine (KVM) and specify "de" for the keymap, it is ignored and "us" is loaded.


Reproducible: Always
Comment 1 Marc Perrudin 2011-08-12 14:33:47 UTC
I have the same problem when I boot the CD.

When I choose my keymap during the boot, my choice is overwritten when keymap init script is started.
Comment 2 Michael Mair-Keimberger (iamnr3) 2011-08-18 13:52:46 UTC
I can confirm this bug, it already happen in 20110726.
Comment 3 Michael Mair-Keimberger (iamnr3) 2011-08-27 12:36:26 UTC
As a temporary workaround, changing the local in /etc/conf.d/keymaps to the wanted keymap and restarting /etc/init.d/keymaps works flawless.
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-09-06 11:46:14 UTC
*** Bug 382037 has been marked as a duplicate of this bug. ***
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-09-06 11:50:14 UTC
@openrc / @base-system:

I've hit this issue as well. If we select a different keymap in the language selection screen during startup, that keymap isn't loaded and the US keymap is used. If we use loadkeys after the system finishes booting, the keymap is correctly updated.
Any ideas? This seems related to the move to bl2/openrc.
Comment 6 Toni Ballesta 2011-09-06 11:56:37 UTC
Gracias, Jose Manuel. I don't found this bug! ;)
Comment 7 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-09-14 13:13:18 UTC
*** Bug 378425 has been marked as a duplicate of this bug. ***
Comment 8 SpanKY gentoo-dev 2011-09-18 03:09:35 UTC
i have no idea how the boot code works.  is it some livecd hack ?

the keymaps init.d script only respects /etc/conf.d/keymaps
Comment 9 Marc Perrudin 2011-09-18 06:28:30 UTC
(In reply to comment #8)
> i have no idea how the boot code works.  is it some livecd hack ?

It's a isolinux feature, there is the same feature with genkernel. I don't know isolinux but with genkernel, it works with an embedded tar with all the keymaps. It's probably something similar with isolinux.

> 
> the keymaps init.d script only respects /etc/conf.d/keymaps

That's the problem, when the keymaps init.d sript is launched, it override the previously loaded keymap. I don't see why the keymaps init.d script is launched when it's a live cd ?
Comment 10 SpanKY gentoo-dev 2011-09-18 06:51:23 UTC
if keymaps isnt supposed to be run for livecds, then dont add it to the respective runlevels
Comment 11 Marc Perrudin 2011-09-18 06:55:36 UTC
(In reply to comment #10)
> if keymaps isnt supposed to be run for livecds, then dont add it to the
> respective runlevels

Indeed, I think this problem could be resolved by removed keymaps from all the runlevels for livecd.
Comment 12 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-09-20 12:10:39 UTC
*** Bug 383797 has been marked as a duplicate of this bug. ***
Comment 13 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-09-21 17:48:26 UTC
*** Bug 379757 has been marked as a duplicate of this bug. ***
Comment 14 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-09-21 17:48:43 UTC
*** Bug 383903 has been marked as a duplicate of this bug. ***
Comment 15 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-10-24 17:33:04 UTC
grep dokeymap /home/gentoo-scm/releng/trunk/releases/weekly/specs/*/*stage2*
/home/gentoo-scm/releng/trunk/releases/weekly/specs/alpha/installcd-stage2-minimal.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/alpha/installcd-stage2-universal.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/alpha/livecd-stage2.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/amd64/installcd-stage2-minimal.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/amd64/livecd-stage2.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/amd64/livedvd-stage2.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/hppa/installcd-stage2-minimal.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/hppa/installcd-stage2-universal.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/ia64/installcd-stage2-minimal.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/ia64/livecd-stage2.spec:livecd/bootargs: dokeymap
/home/gentoo-scm/releng/trunk/releases/weekly/specs/x86/installcd-stage2-minimal.spec:livecd/bootargs: dokeymap

I'll try removing the dokeymap from the amd64/x86 specs and see if that fixes this issue.
Comment 16 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-11-07 01:13:36 UTC
This should be fixed now in the specs[1] - I'm still testing it.

 [1] - http://sources.gentoo.org/cgi-bin/viewvc.cgi/releng?view=revision&revision=832
Comment 17 Naohiro Aota gentoo-dev 2011-11-22 11:27:25 UTC
(In reply to comment #16)
> This should be fixed now in the specs[1] - I'm still testing it.
> 
>  [1] -
> http://sources.gentoo.org/cgi-bin/viewvc.cgi/releng?view=revision&revision=832

Is this-fix-included install CD already available?
Comment 18 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-11-22 14:48:53 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > This should be fixed now in the specs[1] - I'm still testing it.
> > 
> >  [1] -
> > http://sources.gentoo.org/cgi-bin/viewvc.cgi/releng?view=revision&revision=832
> 
> Is this-fix-included install CD already available?

The fix was committed[1] to the amd64/x86 specs on November 7th. Given the recent issues, we don't have CDs for amd64[2] and x86[3] built since then. As the recent issues are now fixed[4], we should get fixed builds this Thursday for amd64 and next Monday for x86.

 [1] - http://sources.gentoo.org/cgi-bin/viewvc.cgi/releng?view=revision&revision=832
 [2] - http://distfiles.gentoo.org/releases/amd64/autobuilds/current-iso/
 [3] - http://distfiles.gentoo.org/releases/x86/autobuilds/current-iso/
 [4] - http://git.overlays.gentoo.org/gitweb/?p=proj/catalyst.git;a=commit;h=b83092d2b26ba189cce7c3295bae48be34289914
Comment 19 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-05-06 23:07:54 UTC
This was fixed some time ago.