Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378557 - media-libs/libvpx-0.9.7: Compile failure with debug USE flag - "No rule to make target libvpx_g.so, needed by vpxdec"
Summary: media-libs/libvpx-0.9.7: Compile failure with debug USE flag - "No rule to ma...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 383651 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-09 20:08 UTC by Matt McAdoo
Modified: 2013-06-25 17:06 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to only change target to libvpx_g for static libraries (libvpx-1.1.0-use-debug.patch,1001 bytes, patch)
2012-06-30 23:28 UTC, Brennan Shacklett
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matt McAdoo 2011-08-09 20:08:27 UTC
[AR] libvpx_g.a
    [LD] libvpx.so.0.9.7
    [CP] libvpx.a < libvpx_g.a
    [LN]      libvpx.so
    [LN]      libvpx.so.0
    [LN]      libvpx.so.0.9
    [EXAMPLE] vp8cx_set_ref.c
    [EXAMPLE] vp8_set_maps.c
    [EXAMPLE] vp8_scalable_patterns.c
    [EXAMPLE] error_resilient.c
    [EXAMPLE] decode_with_drops.c
    [EXAMPLE] force_keyframe.c
    [EXAMPLE] twopass_encoder.c
    [EXAMPLE] simple_encoder.c
    [EXAMPLE] decode_to_md5.c
    [DEP] md5_utils.c.d
    [EXAMPLE] postproc.c
    [EXAMPLE] simple_decoder.c
    [DEP] vpxenc.c.d
    [DEP] libmkv/EbmlWriter.c.d
    [DEP] tools_common.c.d
    [DEP] y4minput.c.d
    [DEP] args.c.d
    [DEP] vpxdec.c.d
    [DEP] nestegg/src/nestegg.c.d
    [DEP] nestegg/halloc/src/halloc.c.d
    [DEP] vp8cx_set_ref.c.d
    [DEP] error_resilient.c.d
    [DEP] decode_with_drops.c.d
    [DEP] decode_to_md5.c.d
    [DEP] postproc.c.d
    [DEP] simple_decoder.c.d
    [DEP] vp8_set_maps.c.d
    [DEP] vp8_scalable_patterns.c.d
    [DEP] force_keyframe.c.d
    [DEP] twopass_encoder.c.d
    [DEP] simple_encoder.c.d
make[1]: *** No rule to make target `libvpx_g.so', needed by `vpxdec'.  Stop.
make: *** [.DEFAULT] Error 2

Reproducible: Always




Portage 2.1.10.10 (hardened/linux/amd64, gcc-4.5.3, glibc-2.13-r4, 2.6.39-hardened-r1 x86_64)
=================================================================
System uname: Linux-2.6.39-hardened-r1-x86_64-Intel-R-_Xeon-R-_CPU_L5609_@_1.87GHz-with-gentoo-2.0.3
Timestamp of tree: Tue, 09 Aug 2011 14:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r2, 3.1.4-r2, 3.2-r2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1-r1
sys-devel/binutils:       2.21.1
sys-devel/gcc:            4.4.5, 4.5.3
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo webapp-experimental zugaina wschlich-testing wschlich arcon
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2 -mtune=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core2 -mtune=core2"
DISTDIR="/var/cache/http-replicator"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.netnitco.net http://gentoo.wetzlmayr.com/ http://www.cyberuse.com/gentoo/ http://gentoo.mirrors.tds.net/gentoo http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.arcticnetwork.ca/ http://gentoo.mirrors.tera-byte.com/ http://gentoo.osuosl.org/ http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ http://mirror.usu.edu/mirrors/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en"
MAKEOPTS="-j16"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/webapps-experimental /var/lib/layman/zugaina /var/lib/layman/wschlich-testing /var/lib/layman/wschlich /var/lib/layman/arcon"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="aac acl acpi amd64 apache2 archive bacula-console bash-completion berkdb bzip2 caps cgi cli command-args cracklib crypt cups cxx dbus debug device-mapper faac fam ffmpeg flac ftp fuse gd gdbm gdu git gmp gnutls gpm hardened http icecast iconv ipv6 iscsi ithreads jabber java java6 jpeg json justify kvm lame ldap libnotify libsysfs lighttpd logrotate logwatch lvm lzma lzo mercurial mmx mmxext modules mp3 mpeg mudflap multilib mysql mysqli nagios-dns nagios-ping nagios-ssh ncurses network nptl nptlonly offensive ogg openipmi openmp openssl overlays pam parted pcre perl php png postgres ppds pppd python qemu qt-faststart readline rrdtool secure-delete session smp snmp sockets socks speex sse sse2 sse3 ssl ssse3 stlport subversion svg sysfs tcpd test theora threads tiff tools udev unicode ups urandom utils vhosts vim-syntax vorbis vpx x264 xattr xml xmlrpc xorg xsl xvfb zip zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="dummy" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Matt McAdoo 2011-08-09 20:09:28 UTC
[ebuild     U  ] media-libs/libvpx-0.9.7 [0.9.6] USE="debug mmx sse sse2 sse3 ssse3 threads (-altivec) -doc -postproc"
Comment 2 Matt McAdoo 2011-08-09 20:11:44 UTC
Building with USE="-debug" works.
Comment 3 Tim Harder gentoo-dev 2011-09-24 21:03:48 UTC
*** Bug 383651 has been marked as a duplicate of this bug. ***
Comment 4 jannis 2012-03-07 06:13:49 UTC
Same on x86
Comment 5 Brennan Shacklett 2012-06-30 23:28:23 UTC
Created attachment 316825 [details, diff]
Patch to only change target to libvpx_g for static libraries

This bug still exists for me in libvpx-1.1.0. 
This patch changes the build system so libvpx_g is only used in debug mode for static libraries, so the name of the shared library isn't erroneously changed to libvpx_g.so
This patch allows me to build with USE=debug
Comment 6 John J. Aylward 2012-09-15 05:01:43 UTC
I'm seeing this too with media-libs/libvpx-1.0.0 on amd64
Comment 7 Alexis Ballier gentoo-dev 2013-06-25 17:06:43 UTC
 
   25 Jun 2013; Alexis Ballier <aballier@gentoo.org> libvpx-9999.ebuild:
+  drop debug useflag that only adds -g and doesnt build. bug #378557
+