Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378383 - media-gfx/imagemagick- fails to install because couldn't find a typemap for C type
Summary: media-gfx/imagemagick- fails to install because couldn't find a typema...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Graphics Project
: 378415 378893 (view as bug list)
Depends on:
Blocks: ExtUtils-ParseXS-3
  Show dependency tree
Reported: 2011-08-08 19:10 UTC by Andre Reinke
Modified: 2011-09-14 13:27 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,420.06 KB, text/plain)
2011-08-08 19:15 UTC, Andre Reinke

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Reinke 2011-08-08 19:10:44 UTC
While installing imagemagick an error occures every time I try:

chmod 644
/usr/bin/install -c -m 644 ./www/identify.html /var/tmp/portage/media-gfx/imagemagick-
/usr/bin/install -c -m 644 ./www/ImageMagickObject.html /var/tmp/portage/media-gfx/imagemagick-
cp blib/arch/auto/Image/Magick/
/usr/bin/install -c -m 644 ./www/import.html /var/tmp/portage/media-gfx/imagemagick-
/usr/bin/install -c -m 644 ./www/index.html /var/tmp/portage/media-gfx/imagemagick-
chmod 644 blib/arch/auto/Image/Magick/
/usr/bin/install -c -m 644 ./www/install-source.html /var/tmp/portage/media-gfx/imagemagick-
/usr/bin/install -c -m 644 ./www/jp2.html /var/tmp/portage/media-gfx/imagemagick-
/usr/bin/install -c -m 644 ./www/license.html /var/tmp/portage/media-gfx/imagemagick-
/usr/bin/install -c -m 644 ./www/links.html /var/tmp/portage/media-gfx/imagemagick-
/usr/bin/install -c -m 644 ./www/magick-core.html /var/tmp/portage/media-gfx/imagemagick-
/usr/bin/install -c -m 644 ./www/magick.css /var/tmp/portage/media-gfx/imagemagick-
Could not find a typemap for C type 'Image::Magick' in Magick.xs, line 2404
/usr/bin/install -c -m 644 ./www/magick++.html /var/tmp/portage/media-gfx/imagemagick-
make[3]: *** [Magick.c] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-gfx/imagemagick-'
make[2]: *** [install-exec-perl] Error 2
make[2]: *** Waiting for unfinished jobs....

If I turn of the use of perl it installs fine.

Reproducible: Always

Steps to Reproduce:
1. emerge -1 =media-gfx/imagemagick- fails
2. MAKEOPTS="-j1" emerge -1 =media-gfx/imagemagick- fails
3. USE="-perl" emerge -1 =media-gfx/imagemagick- works
Actual Results:  
Imagemagick is compiled fine, but can not be installed cause it can not find the typemap of C type.

Expected Results:  
Installing Imagemagick with USE="perl" enabled.
Comment 1 Andre Reinke 2011-08-08 19:11:38 UTC
ntarctica andre # emerge --info =media-gfx/imagemagick-
Portage (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.13-r4, 2.6.38-tuxonice-r2 x86_64)
                        System Settings
System uname: Linux-2.6.38-tuxonice-r2-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.0.3
Timestamp of tree: Sun, 07 Aug 2011 08:15:01 +0000
ccache version 3.1.5 [enabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2, 3.2-r2
dev-util/ccache:          3.1.5
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1
sys-devel/gcc:            4.5.3
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise voyageur tante amielke-overlay kde
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/voyageur /var/lib/layman/tante /var/lib/layman/amielke-overlay /var/lib/layman/kde"
USE="X \ a52 aac acl acpi alsa amd64 berkdb bidi branding bzip2 cairo cdda cdio cdr cli consolekit cracklib crypt cxx dbus declarative dri dts dvd dvdr emboss encode exif faac fam ffmpeg firefox flac fortran gdbm gdu gif gnutls gpm hbci iconv ipv6 jpeg kde kipi lame lcms libnotify lm_sensors mad mjpeg mmx mng modules mp3 mp4 mpeg mplayer mudflap multilib mysql ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pppd python qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl startup-notification svg sysfs tcpd theora tiff truetype udev unicode usb v4l2 vaapi vcd vdpau vorbis x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

media-gfx/imagemagick- was built with the following:
USE="X bzip2 (consolekit) corefonts cxx jpeg lcms (multilib) openmp perl png (policykit) svg tiff truetype xml zlib -autotrace -djvu -fftw -fontconfig -fpx -graphviz -gs -hdri -jbig -jpeg2k -lqr -lzma -opencl -openexr -q32 -q64 -q8 -raw -static-libs -webp -wmf"                     
CFLAGS="-O2 -pipe"
CXXFLAGS="-O2 -pipe"
Comment 2 Andre Reinke 2011-08-08 19:15:23 UTC
Created attachment 282605 [details]
Comment 3 Rafał Mużyło 2011-08-09 00:40:09 UTC
*** Bug 378415 has been marked as a duplicate of this bug. ***
Comment 4 Rafał Mużyło 2011-08-09 00:40:40 UTC
Did you check if '-j1' makes a difference ?
Comment 5 Robert Cabrera 2011-08-09 02:14:26 UTC
@Rafal Muzylo, had you bothered to take a moment and actually read this report or the one I made, you would have noticed that we both have tried emerging with MAKEOPTS="-j1" with no success.

Why was my Bug 378415 marked as a duplicate of this when the emerge error output is so much different between the two?

If my bug is indeed a duplicate of this one, then why is it listed as "unconfirmed" when there are at least 5 other users besides myself and this gentleman complaining about this issue, here and in the thread in the forums?

I'll repost the link again:

The only way any of us have found to get imagemagick- to build, is to do so with USE="-perl". So the problem is obviously perl related, not parallel-build related. 

Comment 6 Robert Cabrera 2011-08-09 02:19:21 UTC
Also this bug 378131 is related as this was the original one generated by the person who started the thread in the forum.

Comment 7 Robert Cabrera 2011-08-09 02:28:03 UTC
My bad!

After re-reading my bug 378415, I see that I didn't specifically mention that I tried to build with MAKEOPTS="-j1" but that I had done so in the forum thread.

Comment 8 Rafał Mużyło 2011-08-09 11:29:10 UTC
:roll: Grouching aside, graphicsmagick bug claims the problem lies in ExtUtils-ParseXS-3.20.0.
Test, if it helps here too.
Comment 9 Samuli Suominen (RETIRED) gentoo-dev 2011-08-09 17:12:04 UTC
This one should be fixed by following commit,

*perl-5.14.1-r1 (09 Aug 2011)
*perl-5.12.4-r1 (09 Aug 2011)

  09 Aug 2011; Torsten Veller <> -perl-5.12.2-r6.ebuild,
  -perl-5.12.3.ebuild, +perl-5.12.4-r1.ebuild, +perl-5.14.1-r1.ebuild:
  Add xsubpp to the dual-life scripts list. Cleanup

@bug-wranglers: Feel free to close this once verified upgrading perl to required -r1 version solves the problem
Comment 10 Torsten Veller (RETIRED) gentoo-dev 2011-08-09 17:39:08 UTC
No, the dev-lang/perl commit doesn't fix this.
Comment 11 Andre Reinke 2011-08-09 19:12:30 UTC
As written in Comment 10 it's not resolved by simply emerging perl-5.12.4-r1. Issue still persists.
Comment 12 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-08-09 22:21:32 UTC
Upstream bug report:
Comment 13 Robert Cabrera 2011-08-10 04:49:24 UTC
I can confirm that updating perl, then using perl-cleaner --reallyall to rebuild the perl packages against it has no affect. Imagemagick still fails at the same point with USE="perl".

However, as reported here and on the thread in the forum, masking perl-core/ExtUtils-ParseXS-3.20.0 and downgrading to the previous version allows imagemagick to compile and install without issues.

So the problem appears to be with that package.

I hope this helps
Comment 14 Andre Reinke 2011-08-10 19:57:55 UTC
I can confirm Comment 10
Comment 15 Andre Reinke 2011-08-10 19:58:40 UTC
Sorry,  confirming Comment 13
Comment 16 Torsten Veller (RETIRED) gentoo-dev 2011-08-12 12:21:25 UTC
*** Bug 378893 has been marked as a duplicate of this bug. ***
Comment 17 Jeroen Roovers (RETIRED) gentoo-dev 2011-08-15 00:53:31 UTC
Comparable to bug #378197?
Comment 18 Sebastian Beßler 2011-08-15 17:13:24 UTC
I can confirm Comment 13 too
Comment 19 Mart Raudsepp gentoo-dev 2011-09-01 22:18:41 UTC
imagemagick- (the stable version, whereas is in queue for stabilization now, and already stable on amd64) has the same problem as well now, workaround being USE=-perl
Comment 20 Rafał Mużyło 2011-09-02 15:31:15 UTC
Well, while I don't know much about perl, reading bug from comment 12 (and the followup bug) suggests that to fix it you'd just need to place a small file in that perl wrapper dir (and that file was added to recent imagemagick releases).

If that's really all, I'd say to put the content of that file into older ebuilds (it's just 23 bytes).
Comment 21 Torsten Veller (RETIRED) gentoo-dev 2011-09-14 13:27:53 UTC
Should be fixed in imagemagick-