Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 377641 - app-misc/lirc-0.9.0 doesn't work with most keys in imon_pad
Summary: app-misc/lirc-0.9.0 doesn't work with most keys in imon_pad
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Craig Andrews
Depends on:
Reported: 2011-08-04 01:46 UTC by John Klug
Modified: 2016-07-31 22:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description John Klug 2011-08-04 01:46:55 UTC
This worked before the driver moved into the kernel.  The mouse keys on the pad plus [esc] work.  Channel works.  Numbers, power, play, record do not work with irw.  Note that when I type or use a mouse key, instead of being displayed by irw, X responds.  I don't recall this happening before.

I don't think I need the mouse/X emulation.  I don't think I had that before.

I am using /usr/share/lirc/remotes/imon/lircd.conf.imon-pad.

 # emerge -vpq lirc 
[ebuild   R   ] app-misc/lirc-0.9.0  USE="X -debug -doc -hardware-carrier -transmitter" LIRC_DEVICES="imon_pad -accent -act200l -act220l -adaptec -all -alsa_usb -animax -asusdh -atilibusb -atiusb -audio -audio_alsa -avermedia -avermedia98 -avermedia_vdomate -awlibusb -bestbuy -bestbuy2 -breakoutbox -bte -bw6130 -caraca -chronos -commandir -cph06x -creative -creative_infracd -devinput -digimatrix -dsp -dvico -ea65 -ene0100 -exaudio -flyvideo -ftdi -gvbctv5pci -hauppauge -hauppauge_dvb -hercules_smarttv_stereo -i2cuser -igorplugusb -iguanaIR -imon -imon_24g -imon_knob -imon_lcd -imon_rsc -inputlirc -irdeo -irdeo_remote -irlink -irman -irreal -it87 -ite8709 -knc_one -kworld -leadtek_0007 -leadtek_0010 -leadtek_pvr2000 -livedrive_midi -livedrive_seq -logitech -macmini -mediafocusI -mouseremote -mouseremote_ps2 -mp3anywhere -mplay -nslu2 -packard_bell -parallel -pcmak -pcmak_usb -pctv -pixelview_bt878 -pixelview_pak -pixelview_pro -provideo -realmagic -remote_wonder_plus -remotemaster -sa1100 -samsung -sasem -sb0540 -serial -serial_igor_cesko -silitek -sir -slinke -streamzap -tekram -tekram_bt829 -tira -ttusbir -tuxbox -tvbox -udp -uirt2 -uirt2_raw -usb_uirt_raw -usbirboy -usbx -userspace -wpc8769l -xboxusb" 

# uname -a
Linux tvscribe 2.6.39-gentoo-r3 #1 SMP Sat Jul 23 11:24:04 CDT 2011 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ AuthenticAMD GNU/Linux

# lsusb
Bus 003 Device 003: ID 15c2:ffdc SoundGraph Inc. iMON PAD Remote Controller

# lsmod
Module                  Size  Used by
cx88_dvb               13504  1 
cx88_vp3054_i2c         1580  1 cx88_dvb
mt352                   4957  1 cx88_dvb
dvb_pll                 8428  1 cx88_dvb
s5h1411                 7705  1 cx88_dvb
videobuf_dvb            4154  1 cx88_dvb
stb6100                 5397  1 cx88_dvb
or51132                 6461  1 cx88_dvb
cx24116                12604  1 cx88_dvb
nxt200x                11108  1 cx88_dvb
isl6421                 1316  1 cx88_dvb
stb6000                 2519  1 cx88_dvb
zl10353                 5885  1 cx88_dvb
stv0900                46838  1 cx88_dvb
cx24123                11135  1 cx88_dvb
lgdt330x                6882  1 cx88_dvb
stv0299                 7833  1 cx88_dvb
dvb_core               77101  5 cx88_dvb,videobuf_dvb,or51132,lgdt330x,stv0299
stv0288                 6056  1 cx88_dvb
cx22702                 4525  1 cx88_dvb
tuner                  12581  2 
tea5767                 5029  1 tuner
tda8290                 8643  1 tuner
tda18271               45073  2 tuner,tda8290
tda827x                 8266  1 tda8290
tuner_xc2028           15823  2 cx88_dvb,tuner
xc5000                 10445  2 cx88_dvb,tuner
tda9887                 8149  2 cx88_dvb,tuner
cx88_alsa               8957  0 
tuner_simple           10438  2 cx88_dvb,tuner
tuner_types            10897  1 tuner_simple
mt20xx                  9030  1 tuner
ir_lirc_codec           3795  3 
tea5761                 3555  1 tuner
lirc_dev                9626  1 ir_lirc_codec
cx8800                 25537  0 
cx8802                 11137  1 cx88_dvb
cx88xx                 66564  4 cx88_dvb,cx88_alsa,cx8800,cx8802
tveeprom               12433  1 cx88xx
nvidia              10476079  30 
v4l2_common             4554  3 tuner,cx8800,cx88xx
videodev               59994  4 tuner,cx8800,cx88xx,v4l2_common
videobuf_dma_sg         6640  5 cx88_dvb,cx88_alsa,cx8800,cx8802,cx88xx
v4l2_compat_ioctl32     7223  1 videodev
videobuf_core          12849  5 videobuf_dvb,cx8800,cx8802,cx88xx,videobuf_dma_sg
btcx_risc               2763  4 cx88_alsa,cx8800,cx8802,cx88xx
imon                   17849  1 
rc_core                12677  5 ir_lirc_codec,cx88xx,imon
r8169                  32744  0 
scsi_wait_scan           719  0 
tvscribe ~ #      

Reproducible: Always

Steps to Reproduce:
1.emerge lirc with imon_pad use flag and build drivers in the kernel
2.Soundgraph imon_pad remote mostly does not respond and nothing is displayed by irw

Expected Results:  
Play should produce a code, and mythtv will interpret it as the letter "p" when configured for lirc.
Comment 1 John Klug 2011-08-04 03:37:05 UTC
Also, in dmesg, when I use the pad (mouse or keyboard arrow depending on mode) I see this:

[ 3215.974444] imon 3-5:1.0: imon_incoming_packet: unknown keypress, code 0x68fa81b7
[ 3216.078446] imon 3-5:1.0: imon_incoming_packet: unknown keypress, code 0x697299b7
[ 3217.878485] imon 3-5:1.0: imon_incoming_packet: unknown keypress, code 0x6afa81b7
[ 3217.950486] imon 3-5:1.0: imon_incoming_packet: unknown keypress, code 0x6b42b9b7
[ 3218.022484] imon 3-5:1.0: imon_incoming_packet: unknown keypress, code 0x6b42f9b7
[ 3218.094486] imon 3-5:1.0: imon_incoming_packet: unknown keypress, code 0x6b4299b7

This is despite the fact that it appears to work.  When it doesn't work, there is nothing added to dmesg.
Comment 2 Kai Damm 2011-11-06 09:00:55 UTC
Confirming that lirc-0.9.0 or kernel-3.0 does not work with my "Antec Fusion Remote" case which comes bundled with a Veris RM200 remote control, which is essentially the same as the iMon Pad, just rebranded.

Most of the RC keys do not work, and irw does not work to get the correct key codes, to create a config from scratch: I get no reaction from irw for nearly all keys, just the up/down/left/right keys trigger an output like "[[A".

I tried every combination of kernel-2.6.38-gentoo-r6/3.0.6 and lirc-0.8.7/0.9.0.

With lirc-0.9.0, I tried LIRC_DEVICES="imon", "imon_lcd", "imon imon_lcd" and "" in make.conf.

The only working combination is kernel-2.6.38 and lirc-0.8.7.

I did not test kernel-2.6.39.

lircd.conf is a link to /usr/share/lirc/remotes/imon/lircd.conf.imon-antec-veris.

emerge --info (of the working setup):

Portage (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.12.2-r0, 2.6.38-gentoo-r6-aoede-20110605-02 x86_64)
System uname: Linux-2.6.38-gentoo-r6-aoede-20110605-02-x86_64-AMD_Athlon-tm-_II_X4_630_Processor-with-gentoo-2.0.3
Timestamp of tree: Sat, 05 Nov 2011 00:45:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.8.5-r4, 1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo x-portage
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
EMERGE_DEFAULT_OPTS="--keep-going --with-bdeps y -j4 --load-average=4"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9 -l4"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt css cxx dbus dmx dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gpm iconv icu ipv6 java jpeg jpeg2k lcms ldap lirc mad matroska mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support readline schroedinger sdl session speex spell sse sse2 sse4a ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis wifi x264 xcb xgetdefault xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="imonlcd" LINGUAS="de" LIRC_DEVICES="imon imon_lcd" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 3 Craig Andrews gentoo-dev 2016-07-31 22:24:07 UTC
As of app-misc/lirc-0.9.4, lirc no longer distributes kernel drivers making this issue obsolete. Please use the latest lirc and build kernel drivers using linux kernel configuration - lirc only includes the userspace tools now.

If you have a problem with the linux kernel driver, please open a bug against the kernel, not lirc.