Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 377401 - app-portage/layman-2.0.0_rc1-r1 doesn't sync
Summary: app-portage/layman-2.0.0_rc1-r1 doesn't sync
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christian Ruppert (idl0r)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 375789
  Show dependency tree
 
Reported: 2011-08-02 09:47 UTC by neko259
Modified: 2011-12-03 00:41 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
layman -l (layman_-l,2.44 KB, text/plain)
2011-08-02 22:41 UTC, megabaks
Details
layman -S (layman_-S,1.03 KB, text/plain)
2011-08-02 22:41 UTC, megabaks
Details
layman --version (layman_--version,10 bytes, text/plain)
2011-08-02 22:41 UTC, megabaks
Details
terminal output of layman -S (layman-test.txt,5.28 KB, text/plain)
2011-08-03 02:26 UTC, Brian Dolbec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description neko259 2011-08-02 09:47:21 UTC
When trying to sync overlays I get

* Fetching remote list,...
* Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
* Last-modified: Tue, 02 Aug 2011 07:30:15 GMT
* Fetch Ok

instead of syncing.

Reproducible: Always

Steps to Reproduce:
Run layman -S or layman -s overlay_name


Expected Results:  
Overlay synchronization
Comment 1 megabaks 2011-08-02 09:54:11 UTC
confirm
>* Fetching remote list
layman must just sync overlays directly!!!
without this shit!
sorry my english
Comment 2 neko259 2011-08-02 10:19:04 UTC
Some people think I have no overlays to sync, so I add my overlay list:

* gamerlay                  [Git       ] (git://git.overlays.gentoo.org/proj/gamerlay.git                                                                           )
* java-overlay              [Subversion] (svn://overlays.gentoo.org/proj/java/java-overlay/                                                                         )
* kork                      [Git       ] (git://git.overlays.gentoo.org/user/kork.git                                                                               )
* multimedia                [Git       ] (git://gitorious.org/gentoo-multimedia/gentoo-multimedia.git                                                               )
* oss-overlay               [Mercurial ] (http://hg.atheme.org/users/majeru/portage-overlay/                                                                        )
* rion                      [Mercurial ] (http://rion-overlay.googlecode.com/hg/                                                                                    )
* roslin                    [Git       ] (git://gitorious.org/roslin/roslin.git                                                                                     )
* Spring                    [Git       ] (git://springlobby.info/git/overlay/springlobby.git                                                                        )
* zugaina                   [Rsync     ] (rsync://gentoo.zugaina.org/zugaina-portage                                                                                )
Comment 3 neko259 2011-08-02 12:34:53 UTC
Update: syncing works for some people, and for others it doesn't work for several days already.
Comment 4 Gef 2011-08-02 14:00:53 UTC
Please provide emerge --info
Any error code from layman ? (run #layman -s ; echo $?)

layman-2.0.0_rc1-r1 has been working flawlessly for me since the 18th of July.
Comment 5 neko259 2011-08-02 14:04:53 UTC
http://paste.pocoo.org/show/451245/ - my emerge --info
Comment 6 Brian Dolbec gentoo-dev 2011-08-02 14:44:08 UTC
big_daddy brian # layman --version
2.0.0_rc1
big_daddy brian # layman -S       
* Fetching remote list,...
* Fetching new list... http://www.gentoo.org/proj/en/overlays/repositories.xml
* Last-modified: Tue, 02 Aug 2011 08:30:12 GMT
* Fetch Ok
* Running Bzr... # ( cd /var/lib/layman/ferringb  && /usr/bin/bzr pull --overwrite http://pkgcore.org/~ferringb/bzr/overlay )
http://pkgcore.org/~ferringb/bzr/overlay is permanently redirected to http://www.pkgcore.org/~ferringb/bzr/overlay
http://www.pkgcore.org/~ferringb/bzr/overlay is permanently redirected to http://www.pkgcore.org/~ferringb/bzr/overlay/
http://pkgcore.org/~ferringb/bzr/overlay/ is permanently redirected to http+urllib://www.pkgcore.org/~ferringb/bzr/overlay/
No revisions to pull.                                                                                                               
* Running Git... # ( cd /var/lib/layman/kde  && /usr/bin/git pull )
remote: Counting objects: 5522, done.
remote: Compressing objects: 100% (3917/3917), done.
remote: Total 4930 (delta 4121), reused 1562 (delta 1004)
Receiving objects: 100% (4930/4930), 1.27 MiB | 489 KiB/s, done.
Resolving deltas: 100% (4121/4121), completed with 540 local objects.
From git://git.overlays.gentoo.org/proj/kde
   2de5a5f..1c47292  master     -> origin/master
[snip]...


* Running Subversion... # /usr/bin/svn up /var/lib/layman/sunrise
D    /var/lib/layman/sunrise/kde-misc
U    /var/lib/layman/sunrise/app-portage/pytage/Manifest
[snip]...


Updated to revision 12292.
* 
* Succeeded:
* ------
* 
* Successfully synchronized overlay "ferringb".
* Successfully synchronized overlay "kde".
* Successfully synchronized overlay "sunrise".
big_daddy brian # layman -s ferringb
* Fetching remote list,...
* Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
* Last-modified: Tue, 02 Aug 2011 08:30:12 GMT
* Fetch Ok
* Running Bzr... # ( cd /var/lib/layman/ferringb  && /usr/bin/bzr pull --overwrite http://pkgcore.org/~ferringb/bzr/overlay )
http://pkgcore.org/~ferringb/bzr/overlay is permanently redirected to http://www.pkgcore.org/~ferringb/bzr/overlay
http://www.pkgcore.org/~ferringb/bzr/overlay is permanently redirected to http://www.pkgcore.org/~ferringb/bzr/overlay/
http://pkgcore.org/~ferringb/bzr/overlay/ is permanently redirected to http+urllib://www.pkgcore.org/~ferringb/bzr/overlay/
No revisions to pull.                                                                                                               
* 
* Succeeded:
* ------
* 
* Successfully synchronized overlay "ferringb".
big_daddy brian # 


So, you can see I cannot reproduce your syncing problem, I do not know where to start to look for your problem.

As for the:


* Fetching remote list,...

This is something that was introduced to layman before I got involved in it's development.  It was present in the layman-1.2 version already.  It does this to update any url changes for the overlays you wish to sync.  It will fetch the remote list for any operation other than listing installed, info.

What layman-2.0.0_rc1 adds is the ability to ask the gentoo server to only send the download if the remote list has been changed since it was last downloaded.

that is the:


* Remote list already up to date:
http://www.gentoo.org/proj/en/overlays/repositories.xml
* Last-modified: Tue, 02 Aug 2011 07:30:15 GMT
* Fetch Ok

From there it proceeds to actually sync the overlays.
Comment 7 neko259 2011-08-02 14:50:43 UTC
But it doesn't sync for me! When I downgraded to 1.4.2, the sync was successfull. And 2.0 did't do anything for several days. As I know, it works normal for some people, and doesn't work for others.
Comment 8 Brian Dolbec gentoo-dev 2011-08-02 15:20:03 UTC
Please post/attach the complete terminal output of:

layman -l
layman -S
layman --version
Comment 9 megabaks 2011-08-02 16:50:19 UTC
(In reply to comment #8)
> Please post/attach the complete terminal output of:
> 
> layman -l
> layman -S
> layman --version
=============================================
[ root@desktop ] megabaks # layman -l
* aluco                     [Git       ] (git://git.overlays.gentoo.org/user/aluco.git                                                                        )
* arcon                     [Mercurial ] (https://arcon.googlecode.com/hg/                                                                                    )
* benf                      [Git       ] (git://git.overlays.gentoo.org/user/benf.git                                                                         )
* bicatali                  [Git       ] (git://git.overlays.gentoo.org/dev/bicatali                                                                          )
* booboo                    [Git       ] (https://github.com/l29ah/booboo.git                                                                                 )
* dottout                   [Git       ] (git://repo.or.cz/dottout.git                                                                                        )
* drizzt-overlay            [Subversion] (svn://overlays.gentoo.org/dev/drizzt/                                                                               )
* lxde                      [Mercurial ] (http://bitbucket.org/yngwin/lxde-overlay/                                                                           )
* mgorny                    [Git       ] (git://git.overlays.gentoo.org/dev/mgorny.git                                                                        )
* mozilla                   [Git       ] (git://git.overlays.gentoo.org/proj/mozilla.git                                                                      )
* multimedia                [Git       ] (git://gitorious.org/gentoo-multimedia/gentoo-multimedia.git                                                         )
* pro-audio                 [Subversion] (svn://svn.tuxfamily.org/svnroot/proaudio/proaudio/trunk/overlays/proaudio                                           )
* qting-edge                [Git       ] (git://gitorious.org/gentoo-qt/qting-edge.git                                                                        )
* rebutia                   [Git       ] (git://git.overlays.gentoo.org/user/rebutia.git                                                                      )
* rion                      [Mercurial ] (http://rion-overlay.googlecode.com/hg/                                                                              )
* roslin                    [Git       ] (git://gitorious.org/roslin/roslin.git                                                                               )
* science                   [Git       ] (git://git.overlays.gentoo.org/proj/sci.git                                                                          )
* stuff                     [Git       ] (https://github.com/megabaks/stuff.git                                                                               )
* sunrise                   [Subversion] (svn://overlays.gentoo.org/proj/sunrise/reviewed/                                                                    )
* tante                     [Git       ] (git://gitorious.org/tante_overlay/mainline.git                                                                      )
* toolchain                 [Subversion] (svn://overlays.gentoo.org/proj/toolchain                                                                            )
* ub0rlay                   [Git       ] (git://repo.or.cz/ub0rlay.git                                                                                        )
* wirelay                   [Git       ] (git://github.com/wired/wirelay.git                                                                                  )
* x11                       [Git       ] (git://git.overlays.gentoo.org/proj/x11                                                                              )
* zugaina                   [Rsync     ] (rsync://gentoo.zugaina.org/zugaina-portage                                                                          )
[ root@desktop ] megabaks # layman -S
* Fetching remote list,...
* Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
* Last-modified: Tue, 02 Aug 2011 08:30:12 GMT
* Fetch Ok
* Running Git... # ( cd /usr/local/portage/layman/aluco  && /usr/bin/git pull )
Already up-to-date.
* Running Mercurial... # ( cd /usr/local/portage/layman/arcon  && /usr/bin/hg pull -u https://arcon.googlecode.com/hg/ )
warning: arcon.googlecode.com certificate with fingerprint 63:81:16:5e:8f:3e:d7:e2:89:bb:45:47:5e:3b:c6:d9:7d:dd:00:11 not verified (check hostfingerprints or web.cacerts config setting)
подтягивая из https://arcon.googlecode.com/hg/
searching for changes
изменений не найдено
* Running Git... # ( cd /usr/local/portage/layman/benf  && /usr/bin/git pull )
Already up-to-date.
* Running Git... # ( cd /usr/local/portage/layman/bicatali  && /usr/bin/git pull )
Already up-to-date.
[ root@desktop ] megabaks # layman --version
2.0.0_rc1
[ root@desktop ] megabaks #
=======================================================================
[ root@desktop ] megabaks # emerge --info | wgetpaste
Your paste can be seen here: http://paste.pocoo.org/show/451348/
[ root@desktop ] megabaks #
Comment 10 Brian Dolbec gentoo-dev 2011-08-02 22:02:31 UTC
Megabaks it looks like it was syncing for you.  It also looks like you cut the bottom of the output.  By the count you have 25 overlays installed.  After all have been synced, it will display all the overlays that succeeded or failed.  There is none of that. Also it will list any errors.  Please attach it as a text file.
Comment 11 megabaks 2011-08-02 22:34:17 UTC
> It also looks like you cut the bottom of the output.
stop!
are you crazy!?
Comment 12 megabaks 2011-08-02 22:35:55 UTC
> it will display all the overlays that succeeded or failed. 
if it works fine only!!!!
but it didn't!
Comment 13 megabaks 2011-08-02 22:39:01 UTC
(In reply to comment #10)
> Megabaks it looks like it was syncing for you.  It also looks like you cut the
> bottom of the output.  By the count you have 25 overlays installed.  After all
> have been synced, it will display all the overlays that succeeded or failed. 
> There is none of that. Also it will list any errors.  Please attach it as a
> text file.

[ root@desktop ] megabaks # layman -l | wgetpaste && layman -S | wgetpaste && layman --version | wgetpaste 
Your paste can be seen here: http://paste.pocoo.org/show/451559/
warning: arcon.googlecode.com certificate with fingerprint 63:81:16:5e:8f:3e:d7:e2:89:bb:45:47:5e:3b:c6:d9:7d:dd:00:11 not verified (check hostfingerprints or web.cacerts config setting)
Your paste can be seen here: http://paste.pocoo.org/show/451560/
Your paste can be seen here: http://paste.pocoo.org/show/451561/
[ root@desktop ] megabaks #
Comment 14 megabaks 2011-08-02 22:41:00 UTC
Created attachment 281911 [details]
layman -l
Comment 15 megabaks 2011-08-02 22:41:30 UTC
Created attachment 281913 [details]
layman -S
Comment 16 megabaks 2011-08-02 22:41:54 UTC
Created attachment 281915 [details]
layman --version
Comment 17 Brian Dolbec gentoo-dev 2011-08-02 23:54:05 UTC
Thanks, megabanks.  I needed to be sure.  It looks like it is failing when it gets to the booboo overlay or during the bicatali overlay.  That was with both times you ran it for me.

I'll try installing those overlays and see what happens.  also if it is not too late for you.  I'm on irc at #gentoo-guis or #porthole.  I just got home from work.  The last post I did I did from my phone when I had a few minutes.
Comment 18 Brian Dolbec gentoo-dev 2011-08-03 02:25:25 UTC
megabaks, I've installed all your overlays and have been able to run layman -S with the only issues being connection refused for several overlays due to back to back syncing.

This last time I ran it on python-2.7 (py-2.6 is my default) again without issue.  However syncing the pro-audio overlay hung for some time and ended up failing due to a connection timeout. It then proceeded to the next overlay in the list. Is there any possibility that is what is happening for you?

 I'll add an attachment of the terminal output that I copied/pasted into an editor.

I asked another dev, he suggested it may be due to proxy/caching settings. caching specifically.  If you need to set some extra options for some types of overlays, 2.0 has added per repo type add and sync options that it will add in addition to the ones it does now.

Also, the layman backends for git, svn, and the others have had only very minor changes since layman-1.4.2.  They were only slight differences due to the middle/high level api's changes.
Comment 19 Brian Dolbec gentoo-dev 2011-08-03 02:26:27 UTC
Created attachment 281923 [details]
terminal output of layman -S
Comment 20 anTaRes 2011-08-03 10:10:33 UTC
in addition :
# layman --list  : http://paste.pocoo.org/show/451816/
unneeded errors in --list mode

# layman --nocolor -a akoya    : http://paste.pocoo.org/show/451819/
I think they must be here , but only once  

mercurial not installed && I don't need it : http://paste.pocoo.org/show/451811/
Comment 21 Brian Dolbec gentoo-dev 2011-08-03 14:17:05 UTC
(In reply to comment #20)
> in addition :
> # layman --list  : http://paste.pocoo.org/show/451816/
> unneeded errors in --list mode
>

already fixed in git  (layman-9999)

> # layman --nocolor -a akoya    : http://paste.pocoo.org/show/451819/
> I think they must be here , but only once  
> 
> mercurial not installed && I don't need it :
> http://paste.pocoo.org/show/451811/

I'll work on this one a bit.  It is due to the new api & message class which allows for full output re-direction.  The second printing is from cli detecting and printing recorded errors.


I was about to release _rc2 with a few bugfixes (current layman-9999/git HEAD), but delayed it to resolve this bug.
Comment 22 megabaks 2011-08-04 20:20:25 UTC
(In reply to comment #18)
> megabaks, I've installed all your overlays and have been able to run layman -S
> with the only issues being connection refused for several overlays due to back
> to back syncing.
> 
> This last time I ran it on python-2.7 (py-2.6 is my default) again without
> issue.  However syncing the pro-audio overlay hung for some time and ended up
> failing due to a connection timeout. It then proceeded to the next overlay in
> the list. Is there any possibility that is what is happening for you?
> 
2.* always work as here https://bugs.gentoo.org/attachment.cgi?id=281913
Comment 23 Brian Dolbec gentoo-dev 2011-08-06 18:42:31 UTC
While i could not duplicate your failure to sync.  I did mistakenly try to get layman to sync an overlay that was not installed via layman.  This resulted in the same type of output that you have been getting for your failures.

I found and fixed several bugs, one in the UnknownOverlayException class which prevented it from reporting itself.  I have also reworked the cli action handling to better handle multiple actions and error reporting. I also added a --debug-level option and additional debug messages in the code.

Please emerge layman-9999 (it is rc1 with bugfixes) and see if it works now and/or properly reports the errors that is causing it to die.

If you report it working, I'll push out an rc2 with all these changes/bugfixes.
Comment 24 megabaks 2011-08-06 19:10:04 UTC
9999 incompatible with 1.4.*!
(In reply to comment #23)
> While i could not duplicate your failure to sync.  I did mistakenly try to get
> layman to sync an overlay that was not installed via layman.  This resulted in
> the same type of output that you have been getting for your failures.
> 
> I found and fixed several bugs, one in the UnknownOverlayException class which
> prevented it from reporting itself.  I have also reworked the cli action
> handling to better handle multiple actions and error reporting. I also added a
> --debug-level option and additional debug messages in the code.
> 
> Please emerge layman-9999 (it is rc1 with bugfixes) and see if it works now
> and/or properly reports the errors that is causing it to die.
> 
> If you report it working, I'll push out an rc2 with all these changes/bugfixes.

9999 incompatible with 1.4.*!
but just work
thanks
fixed
Comment 25 Brian Dolbec gentoo-dev 2011-08-06 20:07:40 UTC
(In reply to comment #24)
> 9999 incompatible with 1.4.*!

What do you mean by incompatible?


> but just work
> thanks
> fixed

Your welcome.  I almost gave up trying to figure out your problem.  It was only by mistake that I stumbled on and found the cause.
Comment 26 megabaks 2011-08-06 20:56:07 UTC
(In reply to comment #25)
> (In reply to comment #24)
> > 9999 incompatible with 1.4.*!
> What do you mean by incompatible?
9999 cannot use local_overlays_1.4.*'s list
Comment 27 Brian Dolbec gentoo-dev 2011-08-06 22:40:12 UTC
Yes, it is compatible with local lists, both in the config and the- o option.  New! Lists can be saved in/ etc/layman/overlays/

Please provide examples.
Comment 28 megabaks 2011-08-07 00:35:45 UTC
[ root@desktop ] megabaks # grep "storage " /etc/layman/layman.cfg
storage   : /usr/local/portage/layman
[ root@desktop ] megabaks #
===================================
[ root@desktop ] megabaks # ls -1 /var/lib/layman/
aluco
arcon
benf
bicatali
cache_ac494f50f5736be7871962c0dec7b3bb.timestamp
cache_ac494f50f5736be7871962c0dec7b3bb.xml
dottout
drizzt-overlay
lxde
make.conf
mgorny
mozilla
multimedia
overlays.xml
pro-audio
qting-edge
rebutia
rion
roslin
science
stuff
sunrise
tante
toolchain
ub0rlay
wirelay
x11
zugaina
[ root@desktop ] megabaks #
=====================================
[ root@desktop ] megabaks # layman -l | grep booboo
[ root@desktop ] megabaks # ls -1 /usr/local/portage/layman | grep booboo
booboo
[ root@desktop ] megabaks # 
=======================================
What? o_O
it is not  incompatible
9999 just ignore storage variable in conf
Comment 29 megabaks 2011-08-07 01:01:50 UTC
again...
=============================
9999:
layman -s stuff
 * 
 * Fetching remote list,...
 * Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * Last-modified: Sat, 06 Aug 2011 21:15:12 GMT
 * Fetch Ok
 * 
 * Syncing selected overlays,...
 * Running Git... # ( cd /var/lib/layman/stuff  && /usr/bin/git pull )
Already up-to-date.
 * 
 * Succeeded:
 * ------
 * Successfully synchronized overlay "stuff".

===============
eix-update
eix chromium
.....
     Available versions:  
	(0)	12.0.742.112 (~)13.0.782.107 (~)13.0.782.107-r1 (~)13.0.782.109 {M}(~)14.0.835.15 {M}(~)14.0.835.18 {M}(~)14.0.835.24[1] {M}(~)14.0.836.0[1]
	(live)	{M}**9999-r1
.....
stop!
where 15.0.845.0? (chromium-15.0.845.0.ebuild	about 3 hours ago	hz [megabaks])
ok...
============================
1.4.3:

 layman -s stuff
* Running... # ( cd /usr/local/portage/layman/stuff  && /usr/bin/git pull )
remote: Counting objects: 10, done.
remote: Compressing objects: 100% (2/2), done.
remote: Total 6 (delta 3), reused 6 (delta 3)
Unpacking objects: 100% (6/6), done.
From https://github.com/megabaks/stuff
   c9e451f..7d80b0c  master     -> origin/master
Updating c9e451f..7d80b0c
Fast-forward
 www-client/chromium/Manifest                   |    2 +
 www-client/chromium/chromium-15.0.845.0.ebuild |  421 ++++++++++++++++++++++++
 2 files changed, 423 insertions(+), 0 deletions(-)
 create mode 100644 www-client/chromium/chromium-15.0.845.0.ebuild
* 
* Success:
* ------
* 
* Successfully synchronized overlay "stuff".
=============================
eix-update
eix chromium
.....

     Available versions:  
	(0)	12.0.742.112 (~)13.0.782.107 (~)13.0.782.107-r1 (~)13.0.782.109 {M}(~)14.0.835.15 {M}(~)14.0.835.18 {M}(~)14.0.835.24[1] {M}(~)14.0.836.0[1] {M}(~)15.0.845.0[1]
	(live)	{M}**9999-r1
......
cool!
Comment 30 megabaks 2011-08-07 01:04:31 UTC
> 1.4.3
sorry ) - 1.4.1
Comment 31 megabaks 2011-08-07 01:13:43 UTC
9999:
[ root@desktop ] megabaks # layman -S
 * 
 * Fetching remote list,...
 * Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * Last-modified: Sat, 06 Aug 2011 21:15:12 GMT
 * Fetch Ok
 * 
 * Syncing selected overlays,...
 * Running Git... # ( cd /var/lib/layman/aluco  && /usr/bin/git pull )
Already up-to-date.
 * Running Mercurial... # ( cd /var/lib/layman/arcon  && /usr/bin/hg pull -u https://arcon.googlecode.com/hg/ )
warning: arcon.googlecode.com certificate with fingerprint ed:19:7c:b9:a3:48:27:93:72:74:43:db:26:40:af:e0:7a:90:1c:97 not verified (check hostfingerprints or web.cacerts config setting)
подтягивая из https://arcon.googlecode.com/hg/
searching for changes
изменений не найдено
 * Running Git... # ( cd /var/lib/layman/benf  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/bicatali  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/booboo  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/dottout  && /usr/bin/git pull )
Already up-to-date.
 * Running Subversion... # /usr/bin/svn up /var/lib/layman/drizzt-overlay
At revision 163.
 * Running Mercurial... # ( cd /var/lib/layman/lxde  && /usr/bin/hg pull -u http://bitbucket.org/yngwin/lxde-overlay/ )
warning: bitbucket.org certificate with fingerprint 81:2b:08:90:dc:d3:71:ee:e0:7c:b4:75:ce:9b:6c:48:94:56:a1:fe not verified (check hostfingerprints or web.cacerts config setting)
real URL is https://bitbucket.org/yngwin/lxde-overlay/
подтягивая из http://bitbucket.org/yngwin/lxde-overlay/
warning: bitbucket.org certificate with fingerprint 81:2b:08:90:dc:d3:71:ee:e0:7c:b4:75:ce:9b:6c:48:94:56:a1:fe not verified (check hostfingerprints or web.cacerts config setting)
searching for changes
изменений не найдено
warning: bitbucket.org certificate with fingerprint 81:2b:08:90:dc:d3:71:ee:e0:7c:b4:75:ce:9b:6c:48:94:56:a1:fe not verified (check hostfingerprints or web.cacerts config setting)
 * Running Git... # ( cd /var/lib/layman/mgorny  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/mozilla  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/multimedia  && /usr/bin/git pull )
Already up-to-date.
 * Running Subversion... # /usr/bin/svn up /var/lib/layman/pro-audio
At revision 2024.
 * Running Git... # ( cd /var/lib/layman/qting-edge  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/rebutia  && /usr/bin/git pull )
Already up-to-date.
 * Running Mercurial... # ( cd /var/lib/layman/rion  && /usr/bin/hg pull -u http://rion-overlay.googlecode.com/hg/ )
подтягивая из http://rion-overlay.googlecode.com/hg/
searching for changes
изменений не найдено
 * Running Git... # ( cd /var/lib/layman/roslin  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/science  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/stuff  && /usr/bin/git pull )
Already up-to-date.
 * Running Subversion... # /usr/bin/svn up /var/lib/layman/sunrise
At revision 12304.
 * Running Git... # ( cd /var/lib/layman/tante  && /usr/bin/git pull )
Already up-to-date.
 * Running Subversion... # /usr/bin/svn up /var/lib/layman/toolchain
At revision 389.
 * Running Git... # ( cd /var/lib/layman/ub0rlay  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/wirelay  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/x11  && /usr/bin/git pull )
Already up-to-date.
 * Running Rsync... # /usr/bin/rsync -rlptDvz --progress --delete --delete-after --timeout=180 --exclude=distfiles/* --exclude=local/* --exclude=packages/* rsync://gentoo.zugaina.org/zugaina-portage/ /var/lib/layman/zugaina
Welcome to Zugaina rsync server
receiving file list ... 
3075 files to consider
                    
sent 83 bytes  received 79446 bytes  53019.33 bytes/sec
total size is 8347790  speedup is 104.97
 * 
 * Succeeded:
 * ------
 * Successfully synchronized overlay "aluco".
 * Successfully synchronized overlay "arcon".
 * Successfully synchronized overlay "benf".
 * Successfully synchronized overlay "bicatali".
 * Successfully synchronized overlay "booboo".
 * Successfully synchronized overlay "dottout".
 * Successfully synchronized overlay "drizzt-overlay".
 * Successfully synchronized overlay "lxde".
 * Successfully synchronized overlay "mgorny".
 * Successfully synchronized overlay "mozilla".
 * Successfully synchronized overlay "multimedia".
 * Successfully synchronized overlay "pro-audio".
 * Successfully synchronized overlay "qting-edge".
 * Successfully synchronized overlay "rebutia".
 * Successfully synchronized overlay "rion".
 * Successfully synchronized overlay "roslin".
 * Successfully synchronized overlay "science".
 * Successfully synchronized overlay "stuff".
 * Successfully synchronized overlay "sunrise".
 * Successfully synchronized overlay "tante".
 * Successfully synchronized overlay "toolchain".
 * Successfully synchronized overlay "ub0rlay".
 * Successfully synchronized overlay "wirelay".
 * Successfully synchronized overlay "x11".
 * Successfully synchronized overlay "zugaina".
 * 
Traceback (most recent call last):
  File "/usr/bin/layman-2.7", line 37, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/layman/cli.py", line 185, in __call__
    result += getattr(self, action[1])()
  File "/usr/lib/python2.7/site-packages/layman/cli.py", line 257, in Sync
    return self.api.sync(selection)
  File "/usr/lib/python2.7/site-packages/layman/api.py", line 381, in sync
    for ovl, result in warnings:
ValueError: too many values to unpack
[ root@desktop ] megabaks # 
====================================
A-A-A-A-A!
Comment 32 Brian Dolbec gentoo-dev 2011-08-07 07:24:34 UTC
both bugs fixed:

the config filepath bug: commit 4a856960773b513a6dd821b4dac2c5aa87ccc929

it will properly read your config file now.  megabaks, you will have to manually clean out either /var/lib/layman or /usr/local/layman depending which you wish to use for layman's storage.  

the traceback in comment #31: commit e76952c1e6817c0bec94665a6307a06507a0e029

Thank you for your patience.  It has been difficult at times to duplicate your errors, but having the correct info helps.  Thank you for having different settings to cause the errors which helped track down & fix their source.
Comment 33 megabaks 2011-08-07 12:17:43 UTC
new bug in 9999
====================
storage /usr/local/portage/layman/
/var/lib/layman removed
====================
[ root@desktop ] megabaks # layman -l

 * lxde                      [Mercurial ] (http://bitbucket.org/yngwin/lxde-overlay/                                                                          )
 * mgorny                    [Git       ] (git://git.overlays.gentoo.org/dev/mgorny.git                                                                       )
 * mozilla                   [Git       ] (git://git.overlays.gentoo.org/proj/mozilla.git                                                                     )
 * multimedia                [Git       ] (git://gitorious.org/gentoo-multimedia/gentoo-multimedia.git                                                        )
 * qting-edge                [Git       ] (git://gitorious.org/gentoo-qt/qting-edge.git                                                                       )
 * science                   [Git       ] (git://git.overlays.gentoo.org/proj/sci.git                                                                         )
 * sunrise                   [Subversion] (svn://overlays.gentoo.org/proj/sunrise/reviewed/                                                                   )
 * toolchain                 [Subversion] (svn://overlays.gentoo.org/proj/toolchain                                                                           )
 * x11                       [Git       ] (git://git.overlays.gentoo.org/proj/x11                                                                             )

[ root@desktop ] megabaks #
=====================================
but 
........

sent 83 bytes  received 98195 bytes  65518.67 bytes/sec
total size is 8983755  speedup is 91.41
 * 
 * Succeeded:
 * ------
 * Successfully synchronized overlay "aluco".
 * Successfully synchronized overlay "arcon".
 * Successfully synchronized overlay "benf".
 * Successfully synchronized overlay "bicatali".
 * Successfully synchronized overlay "booboo".
 * Successfully synchronized overlay "dottout".
 * Successfully synchronized overlay "drizzt-overlay".
 * Successfully synchronized overlay "lxde".
 * Successfully synchronized overlay "mgorny".
 * Successfully synchronized overlay "mozilla".
 * Successfully synchronized overlay "multimedia".
 * Successfully synchronized overlay "pro-audio".
 * Successfully synchronized overlay "qting-edge".
 * Successfully synchronized overlay "rebutia".
 * Successfully synchronized overlay "rion".
 * Successfully synchronized overlay "roslin".
 * Successfully synchronized overlay "science".
 * Successfully synchronized overlay "stuff".
 * Successfully synchronized overlay "sunrise".
 * Successfully synchronized overlay "tante".
 * Successfully synchronized overlay "toolchain".
 * Successfully synchronized overlay "ub0rlay".
 * Successfully synchronized overlay "wirelay".
 * Successfully synchronized overlay "x11".
 * Successfully synchronized overlay "zugaina".
 * 
=========================================
Comment 34 megabaks 2011-08-07 12:24:01 UTC
 1 files changed, 1 insertions(+), 0 deletions(-)
 create mode 100644 test/test/test
=======
layman -S
.....
 * Running Git... # ( cd /usr/local/portage/layman/stuff  && /usr/bin/git pull )
remote: Counting objects: 6, done.
remote: Compressing objects: 100% (1/1), done.
remote: Total 5 (delta 1), reused 5 (delta 1)
Unpacking objects: 100% (5/5), done.
From https://github.com/megabaks/stuff
   7d80b0c..c60389b  master     -> origin/master
Updating 7d80b0c..c60389b
Fast-forward
 test/test/test |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)
 create mode 100644 test/test/test
=======
it's work :)
Comment 35 Brian Dolbec gentoo-dev 2011-08-07 15:17:53 UTC
If the new bug you are referring to is the text wrapping wrapping wider than the terminal. It has been fixed already.  If that was the case you needed to copy/paste it into a text editor, save and attach it.  The text wrapping from bugzilla messes your paste up.

Also, please open a new bug for any other new bugs you find. Adding bugs to this one is not good, and will is confusing.

re-emerge layman-9999, retest.

hmm, the only other possible bug I see is that layman -l did not list all your overlays, but layman -S did sync them? It is working correctly here for me. If that is the case, re-emerge layman-9999, retest & open a new bug for it if it is still not working.

Then attach: 

/usr/local/portage/layman/overlays.xml 
/usr/local/portage/layman/make.conf
ls -l /usr/local/portage/layman

Please remember to write what bug you are seeing so I do not have to try & figure it out or guess.

I consider this bug to be closed/fixed
Comment 36 Brian Dolbec gentoo-dev 2011-12-03 00:41:56 UTC
Closing as there has been no further reported problems.  All fixes have been released in at least layman-2.0.0_rc3, some in rc2.  Re-open this bug if it is not, and provide some info to help me track down the problem.