Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 377285 - app-emulation/virtualbox-4.0.12 - Windows guest has USB disk woes
Summary: app-emulation/virtualbox-4.0.12 - Windows guest has USB disk woes
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal major with 1 vote (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-01 14:24 UTC by Pierre-Yves Bonnetain-Nesterenko
Modified: 2017-08-31 18:29 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Device manager shows an error (VBox-01.png,42.91 KB, patch)
2011-08-01 14:25 UTC, Pierre-Yves Bonnetain-Nesterenko
Details | Diff
USB keys is thought to be proprely attached (VBox-02.png,133.73 KB, text/plain)
2011-08-01 14:26 UTC, Pierre-Yves Bonnetain-Nesterenko
Details
Device manager shows an error (VBox-01.png,42.91 KB, image/png)
2011-08-01 14:31 UTC, Pierre-Yves Bonnetain-Nesterenko
Details
USB key is thought to be properly attached (VBox-02.png,133.73 KB, image/png)
2011-08-01 14:32 UTC, Pierre-Yves Bonnetain-Nesterenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre-Yves Bonnetain-Nesterenko 2011-08-01 14:24:37 UTC
When plugging an USB disk (or key, whatever) on my host, VBox 4.0.12 does see it properly (not greyed out) but utterly fails to take control of it when asked to.

Syslog messages (host-side) are :
kernel: usb-storage 2-1.4:1.0: disconnect by usbfs
kernel: usb 2-1.4: BOGUS urb flags, 1 --> 0
kernel: usb 2-1.4: usbfs: usb_submit_urb returned -22

Guest-side, VBox menus tell that the USB drive is properly attached, but the device manager shows an error.

This problem is new to VBox 4.0.12 (downgraded to 4.0.10, 4.0.8 and 4.0.6 just to be sure, with exactly the same host and emerge options).

Kernel is 2.6.38-gentoo-r6.

Reproducible: Always
Comment 1 Pierre-Yves Bonnetain-Nesterenko 2011-08-01 14:25:41 UTC
Created attachment 281737 [details, diff]
Device manager shows an error

Screen dump (edited) of Windows Device Manager
Comment 2 Pierre-Yves Bonnetain-Nesterenko 2011-08-01 14:26:22 UTC
Created attachment 281739 [details]
USB keys is thought to be proprely attached
Comment 3 Pierre-Yves Bonnetain-Nesterenko 2011-08-01 14:31:14 UTC
Created attachment 281741 [details]
Device manager shows an error
Comment 4 Pierre-Yves Bonnetain-Nesterenko 2011-08-01 14:32:10 UTC
Created attachment 281743 [details]
USB key is thought to be properly attached
Comment 5 Blake Leverett 2011-08-11 23:48:51 UTC
I have a similar problem.

USB works great with virtualbox-4.0.10.  But with 4.0.12, there are problems.  I can see the devices in the winXP guest, and the device shows up in the windows device dialog, with a working status.

However, the device doesn't really work.  A USB flash stick won't show up in the main "my computer" window.  My PE Micro USB Coldfire Multilink just won't connect to anything.  I actually bought another $250 USB CFM device because I thought mine was broken.

An Atmel AVR JTAG-ICE-MKII device actually works fine with 4.0.12.  Don't know why.

I was able to downgrade to 4.0.10 by using quickpkg on another machine that I had not yet updated (for some reason 4.0.10 was deleted from portage when 4.0.12 was unmasked).  Now it all works fine again with 4.0.10.  Also, I tried 4.1.0, and had the same USB problems.
Comment 6 Blake Leverett 2011-08-16 17:54:02 UTC
I figured out my problem.  The USB Coldfire Multilink device only works well with USB-1.1 (low speed).  Apparently the VirtualBox upgrade brought USB 2.0 to my setup, and the programming tool quit working.

I was able to solve the problem by removing USB-2.0 function:

modprobe -r ehci-hcd

Or supposedly putting an old USB-1.1-only USB hub in the loop works also.
Comment 7 Sergey S. Starikoff 2011-08-26 17:58:48 UTC
(In reply to comment #5)
> I have a similar problem.
> 
Similiar issue with app-emulation/virtualbox-4.0.12 on amd64 host system.
Tested guests Windows 2000 and Windows XP.

sys-kernel/gentoo-sources-2.6.39-r3:
CONFIG_USB_ARCH_HAS_EHCI=y
CONFIG_USB_EHCI_HCD=y

Guest OS shows error code 10.
Comment 8 Sergey S. Starikoff 2011-08-27 08:54:32 UTC
(In reply to comment #7)
> sys-kernel/gentoo-sources-2.6.39-r3:
> CONFIG_USB_ARCH_HAS_EHCI=y
> CONFIG_USB_EHCI_HCD=y
> 
> Guest OS shows error code 10.

Rebuilding kernel with CONFIG_USB_EHCI_HCD=m (and following unloading of this module) doesn't solved the issue.
Comment 9 jannis 2011-10-06 05:31:36 UTC
Can you retry with new virtualbox-4.1.4 please? There is something related to USB in the ChangeLogs on virtualbox.org
Comment 10 Pierre-Yves Bonnetain-Nesterenko 2011-10-06 07:23:47 UTC
Jannis : I will as soon as the 4.1.4 is available around here (latest emerge sync, a few minutes ago, gave me 4.1.2 only).
Comment 11 Pierre-Yves Bonnetain-Nesterenko 2011-10-17 06:46:13 UTC
Sorry for the delay.

Problem is the same with 4.1.4. Kernel still says (host-side) :

kernel: usb-storage 2-3:1.0: disconnect by usbfs
kernel: usb 2-3: BOGUS urb flags, 1 --> 0
kernel: usb 2-3: usbfs: usb_submit_urb returned -22
kernel: usb 2-3: BOGUS urb flags, 1 --> 0

when "connecting" the USB device to VirtualBox (Menu>Devices>USB Devices...). And, on the XP-guest side, we still get the device manager error.
Comment 12 alxndrtrofimov 2012-05-02 14:16:12 UTC
Problem is the same with app-emulation/virtualbox-4.1.12 with enabled PUEL extensions. There are no problem with app-emulation/virtualbox-bin-4.1.12.
Comment 13 Blake Leverett 2012-05-02 18:33:21 UTC
As an update, with virtualbox-4.1.12, the problem persists.  If I remove the USB-1.0 hub from my machine (and plug the USB device directly into the machine), the USB Coldfire Multilink device fails to work.  Shutting off USB-2.0 by removing the kernel module may still work, but since I have the 1.0 hub, I just use that.
Comment 14 Pierre-Yves Bonnetain-Nesterenko 2012-05-07 08:47:52 UTC
Problem still the same with virtualbox-4.1.14.
Comment 15 Gerald 2012-05-22 09:34:53 UTC
Also happens on my system (Gentoo x64 Host with WinServer2003 32Bit as Guest).

With Kernel 3.3.6 the USB drives do not appear in the guest even though Virtualbox (4.1.14) thinks they are correctly attached. The kernel log shows the "BOGUS urb flags, 1 --> 0" message as posted by others here.

With Kernel 3.4.0 the USB drives do appear and work in the guest but I have crashes of "drivers/usb/core/urb.c:440" every single second (!) in the kernel log:

[Tue May 22 02:07:16 2012] ------------[ cut here ]------------
[Tue May 22 02:07:16 2012] WARNING: at drivers/usb/core/urb.c:440 usb_submit_urb+0x2e6/0x3fa()
[Tue May 22 02:07:16 2012] Hardware name: MS-7638
[Tue May 22 02:07:16 2012] Device: usb
[Tue May 22 02:07:16 2012] BOGUS urb flags, 1 --> 0
[Tue May 22 02:07:16 2012] Modules linked in: vboxnetadp(O) vboxnetflt(O) vboxdrv(O)
[Tue May 22 02:07:16 2012] Pid: 2314, comm: VBoxHeadless Tainted: G        W  O 3.4.0 #1
[Tue May 22 02:07:16 2012] Call Trace:
[Tue May 22 02:07:16 2012]  [<ffffffff8106ef9f>] warn_slowpath_common+0x80/0x98
[Tue May 22 02:07:16 2012]  [<ffffffff8106f04b>] warn_slowpath_fmt+0x41/0x43
[Tue May 22 02:07:16 2012]  [<ffffffff8134e048>] usb_submit_urb+0x2e6/0x3fa
[Tue May 22 02:07:16 2012]  [<ffffffff81091a20>] ? should_resched+0x9/0x29
[Tue May 22 02:07:16 2012]  [<ffffffff81355d69>] proc_do_submiturb+0x71c/0x88d
[Tue May 22 02:07:16 2012]  [<ffffffff813567bf>] usbdev_do_ioctl+0x8e5/0xe03
[Tue May 22 02:07:16 2012]  [<ffffffff81356cf5>] usbdev_ioctl+0x9/0xd
[Tue May 22 02:07:16 2012]  [<ffffffff8112e0ba>] do_vfs_ioctl+0x458/0x499
[Tue May 22 02:07:16 2012]  [<ffffffff81091a0d>] ? need_resched+0x1e/0x28
[Tue May 22 02:07:16 2012]  [<ffffffff8144fd17>] ? __schedule+0x5fb/0x612
[Tue May 22 02:07:16 2012]  [<ffffffff81121a56>] ? fput+0x1d/0x1ce
[Tue May 22 02:07:16 2012]  [<ffffffff8112e13d>] sys_ioctl+0x42/0x65
[Tue May 22 02:07:16 2012]  [<ffffffff81451122>] system_call_fastpath+0x16/0x1b
[Tue May 22 02:07:16 2012] ---[ end trace 77afd28a2e4c52d7 ]---
Comment 16 Pierre-Yves Bonnetain-Nesterenko 2012-06-11 07:11:34 UTC
Tested with VirtualBox 4.1.6, same behaviour and bug.
Comment 17 Pierre-Yves Bonnetain-Nesterenko 2012-06-11 07:14:33 UTC
I meant VirtualBox 4.1.16.
Kernel is 3.2.12.
Comment 18 Pierre-Yves Bonnetain-Nesterenko 2012-06-26 08:53:47 UTC
VirtualBox 4.1.18, compiled from source
  - kernel 2.6.38, same problem
  - kernel 3.4.4, see comment 15. It does work, but with a very heavy flow of
    syslog messages

VirtualBox 4.1.18-bin
  Kernel 3.4.4, it does work (no syslog messages, nothing too bad).
  But the USB key/disk is NOT released to the host system when detached from the
  guest system. The USB key/disk becomes available again to the host system when
  the guest VM is stopped.
Comment 19 Pierre-Yves Bonnetain-Nesterenko 2012-10-10 12:09:35 UTC
VBox 4.1.22
Kernel 3.4.9

The problem seems to have been solved. No weird syslog messages anymore either.

Since VBox 4.1.22 with kernel 3.2.x still had troubles with USB, I will infer that it was something in the kernel.
Comment 20 Blake Leverett 2012-10-12 17:43:32 UTC
The problem persists for me.  Now the USB Coldfire Multilink tool does connect and appear to work at first, but it malfunctions when you try to single step into the embedded code.  When I plug the tool into my very old USB 1.0 hub, then debugging works.

Not a huge deal for me, but it would be nice if everything worked.
Comment 21 Blake Leverett 2012-10-12 17:44:31 UTC
I should have mentioned, I am also using VBox 4.1.22 Kernel 3.4.9.
Comment 22 Pierre-Yves Bonnetain-Nesterenko 2012-10-18 13:10:29 UTC
(In reply to comment #20)
> The problem persists for me.  Now the USB Coldfire Multilink tool does

Yes, I was a little bit too quick to jump to (inappropriate) conclusions. Guest USB does work, but

1/ with EHCI active in the guest, we get the once-per-second crash messages from comments 15 and 16. No other bothersome side effects.
2/ without EHCI in the guest, no message that fill up your syslog files. But after a few USB connect/disconnect, we loose the USB (as far as usb-storage is concerned) on the host system, needing a reboot. Regular host-USB (mouse and presumably keyboard) are okay.

So, the problem is still not (completely) solved.
Comment 23 Lars Wendler (Polynomial-C) gentoo-dev 2013-06-18 12:21:52 UTC
Any news here? is this still an issue?
Comment 24 Pierre-Yves Bonnetain-Nesterenko 2013-06-25 12:30:32 UTC
Currently using Virtualbox 4.1.26, kernel 3.7.10.
Yes, this is still an issue.

Same stuff outlined in comment #22 wrt EHCI in the guest system. Nothing seems to have changed.
Comment 25 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-11-11 21:30:03 UTC
Does this still happen on Linux kernel 3.12.0?
Comment 26 Pierre-Yves Bonnetain-Nesterenko 2013-11-14 23:15:14 UTC
(In reply to Tom Wijsman (TomWij) from comment #25)
> Does this still happen on Linux kernel 3.12.0?

Kernel 3.12.0, Virtualbox 4.2.18

Without EHCI on the guest, no problems, no errors, flash disk is properly detected and usable by the guest. No loss of USB (host-side) after several USB connect/disconnect (guest-side), as was the case when comment 22 was written.

With EHCI, same old stuff. Once per second (maybe a little less) :
Nov 14 23:54:51 localhost kernel: ------------[ cut here ]------------
Nov 14 23:54:51 localhost kernel: WARNING: CPU: 1 PID: 31550 at drivers/usb/core/urb.c:472 usb_submit_urb+0x351/0x478()
Nov 14 23:54:51 localhost kernel: Device: usb
Nov 14 23:54:51 localhost kernel: BOGUS urb flags, 1 --> 0
Nov 14 23:54:51 localhost kernel: Modules linked in: usb_storage vboxnetadp(O) vboxnetflt(O) vboxdrv(O) tun nvidia(PO) snd_hda_codec_hdmi snd_hda_intel snd_hda_codec snd_pcm snd_page_alloc snd_timer arc4 snd sdhci_pci iwldvm sdhci mmc_core ehci_pci mac80211 xhci_hcd iwlwifi ehci_hcd r8169 soundcore mii cfg80211 battery video ac button
Nov 14 23:54:51 localhost kernel: CPU: 1 PID: 31550 Comm: EMT Tainted: P        W  O 3.12.0-gentoo-test #2
Nov 14 23:54:51 localhost kernel: Hardware name: CLEVO CO.                        W860CU                          /W860CU                          , BIOS CALPELLACRB.86C.0000.X
Nov 14 23:54:51 localhost kernel: 0000000000000000 ffffffff81455543 ffffffff8133358f ffff8802268bfcd8
Nov 14 23:54:51 localhost kernel: ffffffff8102f068 ffff88023638b680 ffffffff8125042b ffffffff81603940
Nov 14 23:54:51 localhost kernel: ffff8800bae79000 ffff88017825a000 0000000000000200 0000000000000001
Nov 14 23:54:51 localhost kernel: Call Trace:
Nov 14 23:54:51 localhost kernel: [<ffffffff8133358f>] ? dump_stack+0x41/0x51
Nov 14 23:54:51 localhost kernel: [<ffffffff8102f068>] ? warn_slowpath_common+0x74/0x8d
Nov 14 23:54:51 localhost kernel: [<ffffffff8125042b>] ? usb_submit_urb+0x351/0x478
Nov 14 23:54:51 localhost kernel: [<ffffffff8102f119>] ? warn_slowpath_fmt+0x45/0x4a
Nov 14 23:54:51 localhost kernel: [<ffffffff8104a87a>] ? should_resched+0x5/0x23
Nov 14 23:54:51 localhost kernel: [<ffffffff8125042b>] ? usb_submit_urb+0x351/0x478
Nov 14 23:54:51 localhost kernel: [<ffffffff8104a87a>] ? should_resched+0x5/0x23
Nov 14 23:54:51 localhost kernel: [<ffffffff813367e8>] ? _cond_resched+0x6/0x1a
Nov 14 23:54:51 localhost kernel: [<ffffffff81258c06>] ? proc_do_submiturb+0x8ec/0xa55
Nov 14 23:54:51 localhost kernel: [<ffffffff81063ff3>] ? wake_futex+0x5d/0x69
Nov 14 23:54:51 localhost kernel: [<ffffffff812598e3>] ? usbdev_do_ioctl+0x8d4/0xe31
Nov 14 23:54:51 localhost kernel: [<ffffffff81259e52>] ? usbdev_ioctl+0x6/0xa
Nov 14 23:54:51 localhost kernel: [<ffffffff810c93c1>] ? do_vfs_ioctl+0x3f5/0x436
Nov 14 23:54:51 localhost kernel: [<ffffffff810664d1>] ? SyS_futex+0x11c/0x14f
Nov 14 23:54:51 localhost kernel: [<ffffffff810c9457>] ? SyS_ioctl+0x55/0x7a
Nov 14 23:54:51 localhost kernel: [<ffffffff81338122>] ? system_call_fastpath+0x16/0x1b
Nov 14 23:54:51 localhost kernel: ---[ end trace a25ce752154ed79b ]---

Aside from those messages, everything seems to work okay.
Comment 27 Pierre-Yves Bonnetain-Nesterenko 2013-11-14 23:27:08 UTC
(In reply to Pierre-Yves Bonnetain from comment #26)
> 
> With EHCI, same old stuff. Once per second (maybe a little less) :
> Nov 14 23:54:51 localhost kernel: ------------[ cut here ]------------
> Nov 14 23:54:51 localhost kernel: WARNING: CPU: 1 PID: 31550 at
[...]

The message frequency is higher during USB connect/disconnect  (guest-side). Then it drops down to something around one "error-block" per second.
Comment 28 Pierre-Yves Bonnetain-Nesterenko 2014-09-30 09:55:06 UTC
Kernel 3.10.41-gentoo-r1
VirtualBox 4.2.24
VBox extensions 4.2.22

The problem seems to have gone away.
Comment 29 Pierre-Yves Bonnetain-Nesterenko 2014-10-01 07:09:55 UTC
I was wrong yesterday. Did not look long enough.

Windows guest up, no user connected, the error messages do *not* appear whenever I connect a USB key.

As soon as one user session has been opened (whether it's still opened, locked or has been closed seems irrelevant), even if no access to the USB key as been done from the guest, the error messages are back.
Comment 30 Ben Kohler gentoo-dev 2017-08-31 18:29:09 UTC
Please reopen if this is still a problem on current versions