Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 376741 - www-plugins/google-talkplugin-2.1.7.0 fails to install: dodoc: ./usr/share/doc/google-talkplugin/changelog.Debian does not exist
Summary: www-plugins/google-talkplugin-2.1.7.0 fails to install: dodoc: ./usr/share/do...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christoph Junghans
URL: http://archives.gentoo.org/gentoo-dev...
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 373933 377249
  Show dependency tree
 
Reported: 2011-07-28 14:41 UTC by Nico Schlömer
Modified: 2011-08-03 17:02 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
cave resolve log (1311864011-install-www-plugins_google-talkplugin-2.1.7.0:0::gentoo.out,3.36 KB, text/plain)
2011-07-28 14:42 UTC, Nico Schlömer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Schlömer 2011-07-28 14:41:57 UTC
Hi all,

I just tried to install www-plugins/google-talkplugin-2.1.7.0 but installation failed with the error message

/usr/libexec/paludis/utils/dodoc: ./usr/share/doc/google-talkplugin/changelog.Debian does not exist

A full log is attached.

Cheers,
Nico

Reproducible: Always
Comment 1 Nico Schlömer 2011-07-28 14:42:33 UTC
Created attachment 281273 [details]
cave resolve log
Comment 2 Christoph Junghans gentoo-dev 2011-07-29 09:18:34 UTC
It seems like paludis' unpack behavior is different from portage.

For portage unpack ./usr/share/doc/google-talkplugin/changelog.Debian.gz 
will end up in ./usr/share/doc/google-talkplugin/ while paludis unpacks it in $WORKDIR.
Comment 3 Brian Harring gentoo-dev 2011-07-29 09:34:22 UTC
PMS mandates cwd; the problem is _unpack_tar function; *.{gz,bz2,xz}, etc, anything that's not tar.  It's a longstanding behaviour- I say that since pkgcore has the same behaviour and the two diverged in '06 or so.

PMS behaviour is sane imo, but isn't followed here... thoughts?
Comment 4 Christoph Junghans gentoo-dev 2011-07-29 17:01:25 UTC
I committed a workaround for google-talkplugin, but PMS-wise we should fix it.
Comment 5 Ciaran McCreesh 2011-07-29 17:05:26 UTC
What does Portage do for other formats in this case?
Comment 6 Zac Medico gentoo-dev 2011-07-29 18:54:58 UTC
Portage's _unpack_tar function is used for any compression type that unpack supports for tar files. The full list is gz|Z|z|bz2|bz|lzma|xz. For all of these extensions, if the file is not a tar file, _unpack_tar unpacks ${x} to ${x%.*}.
Comment 7 Ciaran McCreesh 2011-07-30 07:21:32 UTC
Given the inconsistency in Portage, and that PMS mandates what Portage does for some formats but not others, I can't really see this as being anything other than a Portage bug.
Comment 8 Zac Medico gentoo-dev 2011-07-30 20:26:18 UTC
Well, portage's unpack is just emulating tools like gunzip and bunzip2 in this case. I would prefer for it to unpack to cwd for consistency. Hopefully it won't break too many ebuilds, and we can always add compatibility code to ebuilds, like this:

   [[ ! -f ${x%.*} ]] || mv "${x%.*}" ./ || die "mv failed"

We might want to take a poll on the gentoo-dev mailing list to see if anyone wants to give feedback on this before we go through with it.
Comment 9 Zac Medico gentoo-dev 2011-08-01 23:51:35 UTC
I've fixed portage's unpack to agree with PMS, and also added a backward compatibility symlink for existing EAPIs:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=75a0cce2b6d7ecb8f369a65fbb047e3ce9d96b44
Comment 10 Brian Harring gentoo-dev 2011-08-02 04:17:35 UTC
(In reply to comment #9)
> I've fixed portage's unpack to agree with PMS, and also added a backward
> compatibility symlink for existing EAPIs:
> 
> http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=75a0cce2b6d7ecb8f369a65fbb047e3ce9d96b44

Me thinks it's better to just abide by PMS; paludis does it, pkgcore will within a week.  Don't much see the benefit in the sym either, especially since it's not documented anywhere.

Better to just break the noncompliant ebuilds and make them fix; sucks, but keep in mind anyone relying on this obviously didn't read PMS at all for it...
Comment 11 Zac Medico gentoo-dev 2011-08-02 18:33:09 UTC
Ok, I've removed the backward-compatibility symlink from portage:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=b33f68f8b3ade6531d45ad79c72acbd7f0cb9109

I've also fixed the only other ebuild that appears to be affected:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/games-arcade/tuxpuck/tuxpuck-0.8.2-r1.ebuild?view=log#rev1.7
Comment 12 Christoph Junghans gentoo-dev 2011-08-03 17:02:51 UTC
Thanks for your help, Zac !